Announcement

Collapse
No announcement yet.

HS3 and BL Plugins

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HS3 and BL Plugins

    Please post anything to do with HS3 and my plugins in this thread for now. Once HS3 is released I will create threads in each plugin forum specific to HS3.

    I have written a HS wrapper that all BL plugins will use once HS is released. This allows me to easily adapt changes to any HS calls in one place, rather than having to change it in each plugin.

    So far I have made the changes to BLRadar (using this one as my initial plugin update). I have BLRadar compiled under .net 4.0 with no issues.

    As soon as I can get a copy of the HS3 api doc I will be able to make any additional changes to the wrapper. Once I can HS3 I can start testing BLRadar.

    Just thought I would post an update.
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

  • #2
    Bob
    HST made a recent change where you must implement the SpeakIn method - I just saw this message:

    5/30/2013 10:22:35 AM ~!~Error~!~Warning, Cannot load EXE file (possibly missing dependencies) HSPI_BLRadar.exe: Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.Warning, Error details with EXE HSPI_BLRadar.exe: Method 'SpeakIn' in type 'HSPI_BLRadar.HSPI' from assembly 'HSPI_BLRadar, Version=2.0.0.0, Culture=neutral, PublicKeyToken=null' does not have an implementation.

    You can probably just implement an empty method and recompile.

    Thanks
    Rob
    HS3Pro Running on a Raspberry Pi3
    68 Z-Wave Nodes, 174 Events, 326 Devices
    UPB modules via OMNI plugin/panel
    Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
    HSTouch Clients: 3 Android, 1 Joggler

    Comment


    • #3
      The last build I loaded worked so something must have changed in the the newest build.
      I will have a look. It is likely going to affect all the plugins.
      Cheers,
      Bob
      Web site | Help Desk | Feature Requests | Message Board

      Comment


      • #4
        Yes, I had the same issue yesterday while "kicking the tires" of HS3. I tried to load 2 of your plugins (BLEdit and can't recall the other one) Although HS states that the plugin was installe correctly, I was never able to get to them via the GUI and has similar errors, as posted above, in my log. Hope this helps a bit

        Comment


        • #5
          Yea I am working on it.
          I have all the plugins recompiled with the fix.
          I just need to bundle them up.
          Cheers,
          Bob
          Web site | Help Desk | Feature Requests | Message Board

          Comment


          • #6
            UPDATE:

            I have updated all plugins in the HS updater. They are the same version number but just download and reinstall them. I have not updated the plugin builds on my web site. Will do that tomorrow or on the weekend.
            Cheers,
            Bob
            Web site | Help Desk | Feature Requests | Message Board

            Comment


            • #7
              Originally posted by Blade View Post
              UPDATE:

              I have updated all plugins in the HS updater. They are the same version number but just download and reinstall them. I have not updated the plugin builds on my web site. Will do that tomorrow or on the weekend.
              When you reinstall, will all the data related to the plug will converge ?
              Hector
              ____________________________________
              Win.2003 OS, HS3
              BLDSC,BLstat,BLRadar,BLRamdom,BLOccupied
              BLups,BLrain8,HSTouch,Ultrajones Weatherbug,
              MyTrigger,ACRF2,W800,Zwave
              AP800,Honeywell Stat

              Comment

              Working...
              X