Announcement

Collapse
No announcement yet.

HS3 Plugins Feedback

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HS3 Plugins Feedback

    Please use this thread and give me some feedback on how plugins are running in HS3.
    I have not heard anything so I guess I assume there are no issues.
    Thanks
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

  • #2
    BLBackup and BLRadar error on startup.

    01/06/2013 19:38:15 ~!~Startup~!~Settings Loaded.
    01/06/2013 19:38:15 ~!~Startup~!~Current sunrise/sunset values calculated.
    01/06/2013 19:38:15 ~!~Startup~!~
    01/06/2013 19:38:15 ~!~Startup~!~*********************************************** *********************************
    01/06/2013 19:38:15 ~!~Startup~!~ HomeSeer version 3.0.0.1 Starting Now (PRO Build)
    01/06/2013 19:38:15 ~!~Startup~!~*********************************************** *********************************
    01/06/2013 19:38:15 ~!~Startup~!~
    01/06/2013 19:38:15 ~!~Startup~!~Using system's regional settings
    01/06/2013 19:38:15 ~!~Startup~!~Creating Class Objects...
    01/06/2013 19:38:15 ~!~Startup~!~COM port classes started.
    01/06/2013 19:38:15 ~!~Startup~!~Application interface class started.
    01/06/2013 19:38:15 ~!~Startup~!~Web server class started.
    01/06/2013 19:38:15 ~!~Startup~!~E-Mail SEND class started.
    01/06/2013 19:38:15 ~!~Startup~!~E-Mail RECEIVE class started.
    01/06/2013 19:38:15 ~!~Startup~!~Plug-In Interface class started.
    01/06/2013 19:38:15 ~!~Startup~!~Speech recognition class started.
    01/06/2013 19:38:15 ~!~Startup~!~HSPhone external interface class started.
    01/06/2013 19:38:15 ~!~Startup~!~Local voice recognition class started.
    01/06/2013 19:38:15 ~!~Startup~!~Database SAVE process started.
    01/06/2013 19:38:15 ~!~Startup~!~Loading configuration file ...
    01/06/2013 19:38:15 ~!~Database~!~Opening (Mode=Read/Write) up HomeSeer database C:\Program Files\HomeSeer HS3\Config\Sample.hsd
    01/06/2013 19:38:15 ~!~Database~!~Loading Devices...
    01/06/2013 19:38:15 ~!~Load Config~!~1 total devices loaded.
    01/06/2013 19:38:15 ~!~Load Config~!~Loading Event Groups...
    01/06/2013 19:38:15 ~!~Load Config~!~Loading Events...
    01/06/2013 19:38:15 ~!~Load Config~!~1 total events loaded.
    01/06/2013 19:38:15 ~!~Load Config~!~Loading COUNTERS...
    01/06/2013 19:38:15 ~!~Load Config~!~Loading TIMERS...
    01/06/2013 19:38:15 ~!~Startup~!~HomeSeer version is: 3.0.0.1
    01/06/2013 19:38:15 ~!~Startup~!~Creating Speaker Client Interface Object...
    01/06/2013 19:38:15 ~!~Startup~!~This version of HomeSeer is not registered and is running as a trial, 28 days remaining.
    01/06/2013 19:38:15 ~!~Info~!~Remote plug-in API interface started on port 10400
    01/06/2013 19:38:15 ~!~Startup~!~Checking for available plug-ins
    01/06/2013 19:38:16 ~!~Plug-In~!~Found plug-in: BLBackup, version: 2.0.0.0
    01/06/2013 19:38:16 ~!~Plug-In~!~Found plug-in: BLLAN, version: 2.0.0.0
    01/06/2013 19:38:16 ~!~Plug-In~!~Found plug-in: BLRadar, version: 2.0.0.0
    01/06/2013 19:38:16 ~!~Plug-In~!~Found plug-in: HSTouch Server, version: 2.0.0.0
    01/06/2013 19:38:16 ~!~Startup~!~Initializing Plug-Ins
    01/06/2013 19:38:16 ~!~Info~!~Remote application or plugin has connected: 127.0.0.1:49235
    01/06/2013 19:38:16 ~!~Info~!~Remote application or plugin has connected: 127.0.0.1:49236
    01/06/2013 19:38:16 ~!~Info~!~Plug-in HSTouch Server has connected successfully
    01/06/2013 19:38:16 ~!~Plug-In~!~Finished initializing plug-in HSTouch Server
    01/06/2013 19:38:16 ~!~Info~!~Remote application or plugin has connected: 127.0.0.1:49241
    01/06/2013 19:38:16 ~!~Info~!~Remote application or plugin has connected: 127.0.0.1:49242
    01/06/2013 19:38:16 ~!~Info~!~Plug-in BLLAN has connected successfully
    01/06/2013 19:38:16 ~!~BLLAN start~!~Initializing BLLAN...
    01/06/2013 19:38:16 ~!~BLLAN start~!~BLLAN version is: 2.0.0.0
    01/06/2013 19:38:16 ~!~BLLAN start~!~Loaded configuration successfully
    01/06/2013 19:38:16 ~!~BLLAN start~!~No computers have been assigned to BLLAN!
    01/06/2013 19:38:16 ~!~BLLAN start~!~BLLAN plug-in has been initialized
    01/06/2013 19:38:16 ~!~Plug-In~!~Finished initializing plug-in BLLAN
    01/06/2013 19:38:17 ~!~Info~!~Remote application or plugin has connected: 127.0.0.1:49247
    01/06/2013 19:38:17 ~!~Info~!~Remote application or plugin has connected: 127.0.0.1:49248
    01/06/2013 19:38:17 ~!~Info~!~Plug-in BLBackup has connected successfully
    01/06/2013 19:38:17 ~!~BLBackup start~!~Initializing BLBackup...
    01/06/2013 19:38:17 ~!~BLBackup start~!~BLBackup version is: 2.0.0.0
    01/06/2013 19:38:17 ~!~BLBackup start~!~Loaded configuration successfully
    01/06/2013 19:38:17 ~!~BLBackup start~!~No backup folders have been assigned to BLBackup!
    01/06/2013 19:38:17 ~!~BLBackup start~!~BLBackup plugin has been initialized
    01/06/2013 19:38:17 ~!~BLBackup Error~!~DatabaseFunctionsSingleton.CompactDatabase(): An error has occurred during compacting of the database: Retrieving the COM class factory for component with CLSID {CD7791B9-43FD-42C5-AE42-8DD2811F0419} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).
    01/06/2013 19:38:17 ~!~BLBackup Error~!~DatabaseFunctionsSingleton.CompactDatabase(): DatabasePathAndName: C:\Program Files\HomeSeer HS3\Data\BLBackup\BLBackup.mdb
    01/06/2013 19:38:17 ~!~Plug-In~!~Finished initializing plug-in BLBackup
    01/06/2013 19:38:17 ~!~Plug-In~!~Interface BLRadar is running as a trial, 30 days remaining.
    01/06/2013 19:38:17 ~!~Info~!~Remote application or plugin has connected: 127.0.0.1:49249
    01/06/2013 19:38:17 ~!~Info~!~Remote application or plugin has connected: 127.0.0.1:49250
    01/06/2013 19:38:17 ~!~Info~!~Plug-in BLRadar has connected successfully
    01/06/2013 19:38:17 ~!~BLRadar start~!~Initializing BLRadar...
    01/06/2013 19:38:17 ~!~BLRadar start~!~BLRadar version is: 2.0.0.0
    01/06/2013 19:38:17 ~!~BLRadar start~!~Loaded configuration successfully
    01/06/2013 19:38:17 ~!~BLRadar start~!~Checking devices owned by BLRadar
    01/06/2013 19:38:17 ~!~BLRadar start~!~No sensors or active zones have been assigned to BLRadar!
    01/06/2013 19:38:17 ~!~BLRadar start~!~User Defined Motion Code has been loaded
    01/06/2013 19:38:17 ~!~HSTouch Server~!~Event: 64
    01/06/2013 19:38:17 ~!~BLRadar Error~!~DatabaseFunctionsSingleton.GetADODBConnection(): Caught exception opening database connection: The 'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine.
    01/06/2013 19:38:17 ~!~BLRadar Error~!~DatabaseFunctionsSingleton.PerformDatabaseUpdate(): An error has occurred during database update statement: ExecuteNonQuery requires an open and available Connection. The connection's current state is closed.
    01/06/2013 19:38:17 ~!~BLRadar Error~!~DatabaseFunctionsSingleton.PerformDatabaseUpdate(): DatabasePathAndName: C:\Program Files\HomeSeer HS3\Data\BLRadar\BLRadar.mdb
    01/06/2013 19:38:17 ~!~BLRadar Error~!~DatabaseFunctionsSingleton.PerformDatabaseUpdate(): sqlUpdateString: DELETE from tblSensorActivity WHERE txtDateTime < #5/22/2013 19:38:17#
    01/06/2013 19:38:18 ~!~HSTouch Server~!~Event: 32
    01/06/2013 19:38:18 ~!~HSTouch Server~!~Event: 32
    01/06/2013 19:38:18 ~!~BLRadar Error~!~DatabaseFunctionsSingleton.CompactDatabase(): An error has occurred during compacting of the database: Retrieving the COM class factory for component with CLSID {CD7791B9-43FD-42C5-AE42-8DD2811F0419} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).
    01/06/2013 19:38:18 ~!~BLRadar Error~!~DatabaseFunctionsSingleton.CompactDatabase(): DatabasePathAndName: C:\Program Files\HomeSeer HS3\Data\BLRadar\BLRadar.mdb
    01/06/2013 19:38:19 ~!~BLRadar start~!~BLRadar plug-in has been initialized
    01/06/2013 19:38:19 ~!~Plug-In~!~Finished initializing plug-in BLRadar
    01/06/2013 19:38:19 ~!~Web Server~!~Local IP address (subnet) is: 192.168.8.104 (255.255.255.0)
    01/06/2013 19:38:19 ~!~Web Server~!~UPNP Discovery started
    01/06/2013 19:38:19 ~!~Web Server~!~Web Server started on port 80
    01/06/2013 19:38:19 ~!~Startup~!~Start automation engine...
    01/06/2013 19:38:19 ~!~Startup~!~Initializing Speaker Client Interface
    01/06/2013 19:38:19 ~!~Speech~!~Listening for remote speaker connections on port 10401
    01/06/2013 19:38:19 ~!~Startup~!~HSSentry is disabled in Setup, sentry will not be started.
    01/06/2013 19:38:19 ~!~Startup~!~Starting Event Scheduler...
    01/06/2013 19:38:19 ~!~Web Server~!~Web Server authorized local login successful from: 192.168.8.104 User: default
    01/06/2013 19:38:19 ~!~Startup~!~Updater services starting...
    01/06/2013 19:38:19 ~!~Startup~!~Starting DDNS service...

    Comment


    • #3
      Can you update BLBackup again from the HSUpdater and let me know if you get the same error?
      Cheers,
      Bob
      Web site | Help Desk | Feature Requests | Message Board

      Comment


      • #4
        Try this for the BLRadar issue and see if resolves it
        It might resolved the BLBackup one too.

        http://social.msdn.microsoft.com/For...b-41d912d50a64

        Seems like the 2nd option seems to be working for everyone
        Last edited by Blade; June 6th, 2013, 05:19 AM.
        Cheers,
        Bob
        Web site | Help Desk | Feature Requests | Message Board

        Comment


        • #5
          Trying a few here Bob. I have a second "set" of Russound amps so will just connect the serial port and "extra" KPL keypads and will connect one to one amp and your plugin.

          Rest of the hardware I have as spares. Just have to cable it over (which is easy).

          One plugin download was an issue. See JPG attached.
          Attached Files
          - Pete

          Auto mator
          Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
          Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
          HS4 Pro - V4.0.5.0 - Ubuntu 18.04/W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.8X
          HS4 Lite -

          X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

          Comment


          • #6
            Thanks Pete. Let me know how it works with HS3. I cannot test Russound here as I do not have one.
            Cheers,
            Bob
            Web site | Help Desk | Feature Requests | Message Board

            Comment


            • #7
              8r1an, did that resolve your issue?

              I have not heard anything else. I assume things are working for the most part.
              Let me know
              Cheers,
              Bob
              Web site | Help Desk | Feature Requests | Message Board

              Comment


              • #8
                Originally posted by Blade View Post
                8r1an, did that resolve your issue?

                I have not heard anything else. I assume things are working for the most part.
                Let me know
                It fixed it for me (I have Office 2010 64 bit installed.). I used the second option from that link, which is to install the Access 2007 run time.

                Bill

                Comment


                • #9
                  Yea the 2nd one seemed to fix it for most people
                  Glad it worked
                  Cheers,
                  Bob
                  Web site | Help Desk | Feature Requests | Message Board

                  Comment


                  • #10
                    Originally posted by Blade View Post
                    8r1an, did that resolve your issue?

                    I have not heard anything else. I assume things are working for the most part.
                    Let me know
                    I reinstalled on a new vm but cant enable because of the good old Error (1) Unable to initialize interface BLRadar :Either no license or trial has expired

                    Comment


                    • #11
                      I am afraid I cannot help with a license issue.
                      I know Rich is releasing a new build with licensing soon.
                      Submit a bug report about it. They can probably reset it
                      Cheers,
                      Bob
                      Web site | Help Desk | Feature Requests | Message Board

                      Comment


                      • #12
                        Bob
                        It occurred to me today that BLRadar's UDMC will likely need to be edited by the users if some of the scripting commands have changed. For example, hs.DeviceStatus is no longer available and getting a device reference is done using the ID of the device.

                        I realize this falls more on the users than you, but just wanted to make you aware...
                        HS3Pro Running on a Raspberry Pi3
                        64 Z-Wave Nodes, 168 Events, 280 Devices
                        UPB modules via OMNI plugin/panel
                        Plugins: Z-Wave, BLRF, OMNI, HSTouch, weatherXML, EasyTrigger
                        HSTouch Clients: 3 Android, 1 Joggler

                        Comment


                        • #13
                          Yep everyone will have to double check their code.
                          I would disable UDMC until all code is checked. Just to cut down on errors
                          Cheers,
                          Bob
                          Web site | Help Desk | Feature Requests | Message Board

                          Comment


                          • #14
                            Bob,

                            I activated BLBackup. Did not use it before and am now a bit unsure how to configure a device. Should I create a virtual device bbefore configuring BLBackup?
                            If I create a device with device address Backup01 is it this id what I put in the configuration for a directory?

                            Point is, I have configured a directory (HS3 itself to start with) and try to combine it to a device, but do not know what to put in as adress?
                            So far I have been trying, saving the configuration does not genearate an error, but it just wont save the adress?


                            Regards,

                            Wim
                            -- Wim

                            Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                            650 devices ---- 336 events ----- 40 scripts

                            Comment


                            • #15
                              You do not need to use the virtual devices. I do not
                              Put in the device code or address and see if it works

                              What error do you get? Can you paste the error here and tell when it happens (what button you pressed)
                              Cheers,
                              Bob
                              Web site | Help Desk | Feature Requests | Message Board

                              Comment

                              Unconfigured PHP Module

                              Collapse

                              Working...
                              X