Announcement

Collapse
No announcement yet.

BL Plugin Database issue in HS3

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    BL Plugin Database issue in HS3

    If you seeing an error like the following then you will need to include the software at the link below:

    6/9/2013 10:16:53 AM ~!~BLBackup Error~!~DatabaseFunctionsSingleton.CompactDatabase(): An error has occurred during compacting of the database: Retrieving the COM class factory for component with CLSID {CD7791B9-43FD-42C5-AE42-8DD2811F0419} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).


    Click for Database Fix
    Last edited by Blade; April 10, 2019, 09:42 AM.
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

    #2
    Thanks!

    Fixed the issue. Will this be built into the installer?

    Cheers
    Nicolai
    Nicolai L

    Comment


      #3
      Glad it fixed it.
      I will not be including it in the installs
      Cheers,
      Bob
      Web site | Help Desk | Feature Requests | Message Board

      Comment


        #4
        Database fix needed

        Bob, the Database Fix Link takes me to a bad microsoft account link. is there any other way to get that, I am getting that odd error message.

        DatabaseFunctionsSingleton.CompactDatabase(): An error has occurred during compacting of the database: Retrieving the COM class factory for component with CLSID {CD7791B9-43FD-42C5-AE42-8DD2811F0419} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).

        Comment


          #5
          I just confirmed that the link does work.
          It downloaded the EXE install file for me
          Your firewall or anti-virus program is likely blocking it
          Cheers,
          Bob
          Web site | Help Desk | Feature Requests | Message Board

          Comment


            #6
            Duh! got it thanks

            And it seems to have cleared that issue up.

            Thanks for the quick response!

            Comment


              #7
              Bob is this for all your plugins? Or specific?
              Hector
              ____________________________________
              Win.2003 OS, HS3
              BLDSC,BLstat,BLRadar,BLRamdom,BLOccupied
              BLups,BLrain8,HSTouch,Ultrajones Weatherbug,
              MyTrigger,ACRF2,W800,Zwave
              AP800,Honeywell Stat

              Comment


                #8
                It will fix all plugins that use an Access database

                I am slowly changing them to SQLite
                Cheers,
                Bob
                Web site | Help Desk | Feature Requests | Message Board

                Comment


                  #9
                  Blank Log Page

                  Ok I installed the above program from the link but still had database errors and blank log page.
                  the solution (for me at least) seems to be this:
                  1. Install the Access Database program from the link above.
                  2. If you still get this database error, shut down HS3.
                  3. Go to C:\Program Files\HomeSeer HS3\Logs and delete or change the name of your current HomeSeerLog.hsd.
                  4. Run HS3 and you should be good

                  I'm posting this here because I've noticed a few other threads where folks didn't find the solution.
                  Tom
                  baby steps...starting again with HS3
                  HS3Pro: Z-NET & 80 Z wave Devices,
                  HSTouch: 4 Joggler (Android Kitkat), 2 iPhone, 3 iPads
                  Whole House Audio: 5 SqueezePlay Jogglers w Bose Speakers
                  In The Works: 10 Cameras Geovision, new Adecmo/Envisalink Alarm, Arduinos
                  System: XP on Fanless Mini-ITX w/ SSD

                  Comment

                  Working...
                  X