Announcement

Collapse
No announcement yet.

** Updating plugins via the HS3 Updater

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ** Updating plugins via the HS3 Updater

    There is an issue with the HS3 Updater in that when you update a plugin that you already have installed, the update will fail.

    Here is what you can do to fix while the issue is resolved:

    1. Disable the plugin you want to install
    2. Make sure the EXE is not still running... if it is then kill the process
    3. Go to the updater and install the plugin you want.
    4. Enable the plugin

    This should get you by until the issue is resolved.
    Last edited by Blade; May 17th, 2017, 03:12 AM.
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

  • #2
    I have found that I don't usually need to do the shutdown part. I disable the plug-in, update that plug-in and then enable it. Also when updating, it seems to work better if you do one at a time.

    Bill

    Comment


    • #3
      Rich emailed me and said he is working on it. It is a known issue
      Cheers,
      Bob
      Web site | Help Desk | Feature Requests | Message Board

      Comment


      • #4
        Is this the issue with the screens popping up all over the screen for each plugin. Each screen says initializing. I have restarted the program and still get the screens after setting them up, but I have not done a reboot. Am I doing something wrong? because I do not like those screens popping up for each plug in.
        danielbo

        Comment


        • #5
          If you cycle HS2 on the same machine as HS3, something HS2 does at startup shuts down the HS3 plug-ins and they all have to restart.

          Bill

          Comment


          • #6
            To update BLLAN I disabled it in manage plugins, restarted hs3 (3.0.0.9), and updated by selecting it in manage plugins and clicking update and install. It worked.

            What did not work are the following:

            1. With BLLAN enabled, click download and install
            2. Rebooting after 1. as suggested by the error in log
            3. Disabling BLLAN, clicking download and install
            4. Rebooting after 3. as suggested by error in log
            _______________________________________________

            HS3 : HSpro (3.0.0.460) on Win2012 (vm on ESXi)
            Plugins: HSTouch, UPBSpud, Kinect, Nest, IFTTT, DirecTV, EasyTrigger, Imperihome, Zwave, RFXcom, UltraMon3, UltraWeatherBug3, UltraGCIR3, UltraLog3, UltraPioneer, PHLocation, Pushover, Pushalot, MCSSPrinklers S, JowiHue
            Jon00 Plugins: Bluetooth Proximity, Performance Monitor, DB Chart, Links

            Comment


            • #7
              Rich informed me today that this should be fixed in HS3 3.0.10.0
              I had to make a change for the updater but I have done that for all plugins.
              Let me know if there are issues updating the plugins now using the updater
              Cheers,
              Bob
              Web site | Help Desk | Feature Requests | Message Board

              Comment

              Working...
              X