Announcement

Collapse
No announcement yet.

Jon00 Harmony Control

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • joegr
    replied
    Do you have XMPP enabled on your Harmony hub?

    Leave a comment:


  • chamtl
    replied
    Hi,
    I'm not able to get this to work. I think it might be related to the rest API. When I run the .exe the command windows just shows this and exit:

    08:16:38.942 [main] INFO c.b.restfulharmony.HarmonyRestServer - Harmony v1.0.0 rest server running....
    08:16:39.234 [main] DEBUG n.w.harmony.HarmonyClient - listener[com.bwssystems.restfulharmony.HarmonyRestServer$1@2de8284b] added

    Anybody knows what I do wrong?

    Thanks

    Regards

    Claus

    Leave a comment:


  • dannieboiz
    replied
    Thanks... deleting just the VD wasn't enough, had to delete the data.ini file and let everything rebuid. it's all there now.

    Leave a comment:


  • jon00
    replied
    All I can suggest is that you delete the existing virtual devices and let the plugin recreate them.

    Leave a comment:


  • dannieboiz
    replied
    Originally posted by jon00 View Post
    When you start the plugin. it shows what it has been discovered in the HS Log. What do you see?

    I assume you loaded the correct firmware in the Harmony Hub?
    Here's what showed up, the bold item is the one that I just added...I remember having the same issue I first installed this, I had to clear the ini and let it rebuild. But I'm trying to avoid that as I have events tied to this now. I haven't downgrade the firmware on Hub 2 so it's not finding anything so ignore that.


    Code:
     
    Jan-17 9:56:46 AM Jon00_Harmony Hub 1 - Timer Started
    Jan-17 9:56:46 AM Jon00_Harmony Hub 2 - No activities found
    Jan-17 9:56:45 AM Jon00_Harmony Hub 2 - Activity Trigger Delay is set to 20 seconds
    Jan-17 9:56:45 AM Jon00_Harmony Hub 2 - Restful Web Port Number: 16702
    Jan-17 9:56:45 AM Jon00_Harmony Hub 2 - Restful IPAddress: 192.168.1.101
    Jan-17 9:56:45 AM Jon00_Harmony Hub 2 - Reading....
    Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - 13 devices found
    Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Device found: Media Center KB
    Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Device found: SC 72 Zone 2
    Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Device found: Samsung TV
    Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Device found: Luminosum Light
    Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Device found: MCE OFF DEVICE
    Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Device found: iKKEGOL AV Switch
    Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Device found: Amazon Fire TV
    Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Device found: JOCOKA Media Player
    Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Device found: Google Media Player
    Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Device found: SC-72 AVR
    Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Device found: SUNTER Climate Control
    Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Device found: Velodyne Subwoofer
    Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Device found: Media Center PC
    Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Current activity is 'PowerOff'
    Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - 5 activities found
    Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Activity found: Surf Web
    Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Activity found: Watch Fire TV
    Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Activity found: Watch Chromecast
    Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Activity found: PowerOff
    Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Activity Trigger Delay is set to 20 seconds
    Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Restful Web Port Number: 16701
    Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Restful IPAddress: 192.168.1.101
    Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Reading....

    Leave a comment:


  • jon00
    replied
    When you start the plugin. it shows what it has been discovered in the HS Log. What do you see?

    I assume you loaded the correct firmware in the Harmony Hub?

    Leave a comment:


  • dannieboiz
    replied
    I tried stopping the Rest API then restarting HS3 as well as restarting the PC but nothing seems to work. I also made sure that it's not hidden anywhere as well.

    Any other suggestions w/o having to clear the configuration and start from scratch?

    Leave a comment:


  • jon00
    replied
    No, there is no limit in the plugin. That is normally set by the remote/hub. Please stop the Rest API and the plugin and then restart it (or restart your HS PC). See if that resolves the issue.

    Leave a comment:


  • dannieboiz
    replied
    I just added a new device to my HUB, event log found the device but it's not showing up in the devices. Is there a limit of how many devices can be added per hub?

    Leave a comment:


  • dannieboiz
    replied
    updated and seems to be working again. Thank you

    Leave a comment:


  • sirmeili
    replied
    Logitech re-evaluated their decision, they will officially support XMPP, but not actually provide any support (use at your own risk, but they will let you use it).

    I have verified that my plugin works with firmware .210 and I assume this one will as well.

    Here are the instructions to add the beta firmware. In January they said the will roll this into the main firmware. You can check my forums for updates on this (https://forums.homeseer.com/forum/au...nyhub-sirmeili) or if Jon00 wants to, he can provide updates in his forum.

    Thanks all

    Leave a comment:


  • joegr
    replied
    Hey, It looks like Logitech may have caved... (I haven't tried it yet)
    https://community.openhab.org/t/logi...tion/60090/118

    Of course, I had already deleted this plugin.

    Edit: Looks like this will only work till the 31st, so no change really.

    Leave a comment:


  • dannieboiz
    replied
    Originally posted by jon00 View Post

    I only wrote this because at the time, there was only one plugin available for the Harmony hub which was not that reliable with my setup. Since then, Frank as written MeHarmonyHub which is very well supported and superior to my offering. Most of the work for my plugin was handled by a third party application and this is the element which has failed. I have no intention in spending any more time on this now there are viable alternatives available. Frank has been spending days trying to repair his plugin to work with Web Sockets so I suggest you support him when he finally gets a working solution.
    We need a thumbs down option in the forum thread, not the response that I (and many other I'm sure) are hoping for. LOL

    I'll just have to remember to issue the GH command to shut down the switch for the amp or just put it in as a good night routine. or I'll just downgrade Harmony firmware.

    Leave a comment:


  • jon00
    replied
    Originally posted by dannieboiz View Post

    exactly why I asked.... I hope Jon00 continue to developer this plugin to work again like the other one.

    Waking up to see my all my system up all night was no joy. Things got really hot in the media closet.
    I only wrote this because at the time, there was only one plugin available for the Harmony hub which was not that reliable with my setup. Since then, Frank as written MeHarmonyHub which is very well supported and superior to my offering. Most of the work for my plugin was handled by a third party application and this is the element which has failed. I have no intention in spending any more time on this now there are viable alternatives available. Frank has been spending days trying to repair his plugin to work with Web Sockets so I suggest you support him when he finally gets a working solution.

    Leave a comment:


  • dannieboiz
    replied
    Originally posted by joegr View Post

    Different plugin and different developer...
    exactly why I asked.... I hope Jon00 continue to developer this plugin to work again like the other one.

    Waking up to see my all my system up all night was no joy. Things got really hot in the media closet.

    Leave a comment:

Working...
X