Announcement

Collapse
No announcement yet.

Jon00 Harmony Control

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • I just added a new device to my HUB, event log found the device but it's not showing up in the devices. Is there a limit of how many devices can be added per hub?

    Comment


    • No, there is no limit in the plugin. That is normally set by the remote/hub. Please stop the Rest API and the plugin and then restart it (or restart your HS PC). See if that resolves the issue.
      Jon

      Comment


      • I tried stopping the Rest API then restarting HS3 as well as restarting the PC but nothing seems to work. I also made sure that it's not hidden anywhere as well.

        Any other suggestions w/o having to clear the configuration and start from scratch?

        Comment


        • When you start the plugin. it shows what it has been discovered in the HS Log. What do you see?

          I assume you loaded the correct firmware in the Harmony Hub?
          Jon

          Comment


          • Originally posted by jon00 View Post
            When you start the plugin. it shows what it has been discovered in the HS Log. What do you see?

            I assume you loaded the correct firmware in the Harmony Hub?
            Here's what showed up, the bold item is the one that I just added...I remember having the same issue I first installed this, I had to clear the ini and let it rebuild. But I'm trying to avoid that as I have events tied to this now. I haven't downgrade the firmware on Hub 2 so it's not finding anything so ignore that.


            Code:
             
            Jan-17 9:56:46 AM Jon00_Harmony Hub 1 - Timer Started
            Jan-17 9:56:46 AM Jon00_Harmony Hub 2 - No activities found
            Jan-17 9:56:45 AM Jon00_Harmony Hub 2 - Activity Trigger Delay is set to 20 seconds
            Jan-17 9:56:45 AM Jon00_Harmony Hub 2 - Restful Web Port Number: 16702
            Jan-17 9:56:45 AM Jon00_Harmony Hub 2 - Restful IPAddress: 192.168.1.101
            Jan-17 9:56:45 AM Jon00_Harmony Hub 2 - Reading....
            Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - 13 devices found
            Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Device found: Media Center KB
            Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Device found: SC 72 Zone 2
            Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Device found: Samsung TV
            Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Device found: Luminosum Light
            Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Device found: MCE OFF DEVICE
            Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Device found: iKKEGOL AV Switch
            Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Device found: Amazon Fire TV
            Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Device found: JOCOKA Media Player
            Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Device found: Google Media Player
            Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Device found: SC-72 AVR
            Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Device found: SUNTER Climate Control
            Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Device found: Velodyne Subwoofer
            Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Device found: Media Center PC
            Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Current activity is 'PowerOff'
            Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - 5 activities found
            Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Activity found: Surf Web
            Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Activity found: Watch Fire TV
            Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Activity found: Watch Chromecast
            Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Activity found: PowerOff
            Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Activity Trigger Delay is set to 20 seconds
            Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Restful Web Port Number: 16701
            Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Restful IPAddress: 192.168.1.101
            Jan-17 9:56:45 AM Jon00_Harmony Hub 1 - Reading....

            Comment


            • All I can suggest is that you delete the existing virtual devices and let the plugin recreate them.
              Jon

              Comment


              • Thanks... deleting just the VD wasn't enough, had to delete the data.ini file and let everything rebuid. it's all there now.

                Comment


                • Hi,
                  I'm not able to get this to work. I think it might be related to the rest API. When I run the .exe the command windows just shows this and exit:

                  08:16:38.942 [main] INFO c.b.restfulharmony.HarmonyRestServer - Harmony v1.0.0 rest server running....
                  08:16:39.234 [main] DEBUG n.w.harmony.HarmonyClient - listener[com.bwssystems.restfulharmony.HarmonyRestServer$1@2de8284b] added

                  Anybody knows what I do wrong?

                  Thanks

                  Regards

                  Claus

                  Comment


                  • Do you have XMPP enabled on your Harmony hub?

                    Comment


                    • Originally posted by joegr View Post
                      Do you have XMPP enabled on your Harmony hub?
                      Yes, please check the announcement on this thread: https://forums.homeseer.com/forum/au...il-you-do-this (Thanks Frank )
                      Jon

                      Comment


                      • Originally posted by jon00 View Post

                        Yes, please check the announcement on this thread: https://forums.homeseer.com/forum/au...il-you-do-this (Thanks Frank )
                        That did it.

                        Thanks, it is working now :-)

                        /Claus

                        Comment


                        • Recently moved HS3 to a new dedicated PC. I'm noticing that my CPU is going at 100% all the time. Anyone else having this issue?

                          Comment


                          • I tried searching through this thread but had no luck. I am sure someone asked this already? I want to put a couple of buttons on the Harmony screen that trigger some homeseer events when pressed. Lights on, Lights Off, etc. For example - Do I set up a bogus device on the harmony and just rename it's actions so I can see them in Homeseer? Thanks.

                            Comment


                            • Originally posted by simonmason View Post
                              I tried searching through this thread but had no luck. I am sure someone asked this already? I want to put a couple of buttons on the Harmony screen that trigger some homeseer events when pressed. Lights on, Lights Off, etc. For example - Do I set up a bogus device on the harmony and just rename it's actions so I can see them in Homeseer? Thanks.
                              This (and other Harmony plugins) only read the configuration from the Harmony remote for devices it already controls. To do what you want can be achieved by using Jon00Flirc or assigning the control buttons for Philips Hue bulbs and using something like HAControl to read it and send JSON strings to HomeSeer.

                              Jon

                              Comment


                              • I am running into an issue adding a device. I added a new device to one of the remotes but cannot get it to show up in homeseer. I have added an activity, synchronized everything so it shows up in the remote and restarted the harmony tray icon several times, as well as restarting homeseer. It does not seem to matter? Am I doing something wrong? Thanks.

                                Comment

                                Working...
                                X