Announcement

Collapse
No announcement yet.

Jon00 Capture2Image HS3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Jon00 Capture2Image HS3

    Hi jon,

    after updating to last HS this doesnt work anymore..
    If i execute the script nothing happens, also no error in the logs..

    i did add 2 days ago a reference, but everything is working well with your other scripts..

    Code:
    ScriptingReferences=System.XML;System.XML.Dll,System.Data;System.Data.Dll,System.Web;System.Web.Dll,System.Drawing;System.Drawing.dll,System.Web.Script;System.Web.Extensions.dll,System.Web.DataVisualization;System.Web.DataVisualization.dll;System.Windows.Forms;System.Windows.Forms.dll,DDay.iCal;DDay.iCal.dll,DDay.Collections;DDay.Collections.dll,antlr.runtime;antlr.runtime.dll,System.Management;System.Management.Dll,Newtonsoft.Json;C:\Program Files (x86)\HomeSeer HS3\Bin\Newtonsoft.Json.dll
    i see the exe starting in the task manager, but then it goes away..
    before it worked normal..

    Any idea ?

    regards
    Preferred -> Jon's Plugins, Pushover, Phlocation, Easy-trigger,
    Rfxcom, Blade Plugins, Pushbullet, homekit, Malosa Scripts




    HS3Pro 4.0.8.0 on windows 10 enterprise X64 on hp quadcore laptop 8 GB.

    #2
    this morning it did run automatically, and i got some errors
    May-29 07:01:01 Error Compiling script C:\Program Files (x86)\HomeSeer HS3\scripts\Jon00Capture2ImageHS3.vben: 'Screen' is not a member of 'Forms'.
    May-29 07:01:01 Error Compiling script C:\Program Files (x86)\HomeSeer HS3\scripts\Jon00Capture2ImageHS3.vben: 'Screen' is not a member of 'Forms'.
    May-29 07:01:01 Error Compiling script C:\Program Files (x86)\HomeSeer HS3\scripts\Jon00Capture2ImageHS3.vben: 'Screen' is not a member of 'Forms'.
    May-29 07:01:01 Error Compiling script C:\Program Files (x86)\HomeSeer HS3\scripts\Jon00Capture2ImageHS3.vben: 'Screen' is not a member of 'Forms'.
    May-29 07:01:01 Error Compiling script C:\Program Files (x86)\HomeSeer HS3\scripts\Jon00Capture2ImageHS3.vben: 'Screen' is not a member of 'Forms'.
    May-29 07:01:01 Error Compiling script C:\Program Files (x86)\HomeSeer HS3\scripts\Jon00Capture2ImageHS3.vben: Namespace or type specified in the Imports 'System.Core' doesn't contain any public member or cannot be found. Make sure the namespace or the type is defined and contains at least one public member. Make sure the imported element name doesn't use any aliases.
    May-29 07:01:01 Error Compiling script C:\Program Files (x86)\HomeSeer HS3\scripts\Jon00Capture2ImageHS3.vben: 'Screen' is not a member of 'Forms'.
    May-29 07:01:01 Error Compiling script C:\Program Files (x86)\HomeSeer HS3\scripts\Jon00Capture2ImageHS3.vben: 'Screen' is not a member of 'Forms'.
    May-29 07:01:01 Error Compiling script C:\Program Files (x86)\HomeSeer HS3\scripts\Jon00Capture2ImageHS3.vben: 'Screen' is not a member of 'Forms'.
    May-29 07:01:01 Error Compiling script C:\Program Files (x86)\HomeSeer HS3\scripts\Jon00Capture2ImageHS3.vben: 'Screen' is not a member of 'Forms'.
    May-29 07:01:01 Error Compiling script C:\Program Files (x86)\HomeSeer HS3\scripts\Jon00Capture2ImageHS3.vben: 'Screen' is not a member of 'Forms'.
    May-29 07:01:01 Error Compiling script C:\Program Files (x86)\HomeSeer HS3\scripts\Jon00Capture2ImageHS3.vben: Namespace or type specified in the Imports 'System.Core' doesn't contain any public member or cannot be found. Make sure the namespace or the type is defined and contains at least one public member. Make sure the imported element name doesn't use any aliases.
    When executing manual doesnt get any errors, even when i create a new event..
    Preferred -> Jon's Plugins, Pushover, Phlocation, Easy-trigger,
    Rfxcom, Blade Plugins, Pushbullet, homekit, Malosa Scripts




    HS3Pro 4.0.8.0 on windows 10 enterprise X64 on hp quadcore laptop 8 GB.

    Comment


      #3
      The script does not run an exe (unless you are using the helper?). I've tried it here on Win 10 and works fine. What are your settings?
      Jon

      Comment


        #4
        this is my setting;

        [Capture5]
        App=iexplore.exe
        AppProcessName=iexplore
        Parms=http://mywebsite.com
        AppWaitTime=10
        KeyCtl=
        MouseCtl=
        KeyCtl1=
        AppClose=3
        MinimizeApps=1
        Crop=871,283,1365,600
        Resize=1500,1500
        ImagePath=C:\Program Files (x86)\HomeSeer HS3\html\Statusitems\weer2.png

        I was confused, the exe is from an other script

        but with exact the same settings it works normal on my test pc.. don't understand what's going on


        i wil restart my homeseer server and see what happens
        Preferred -> Jon's Plugins, Pushover, Phlocation, Easy-trigger,
        Rfxcom, Blade Plugins, Pushbullet, homekit, Malosa Scripts




        HS3Pro 4.0.8.0 on windows 10 enterprise X64 on hp quadcore laptop 8 GB.

        Comment


          #5
          Try the default settings which come with the script:

          [Capture5]
          App=iexplore.exe
          AppProcessName=iexplore
          Parms=http://www.google.com
          AppWaitTime=5
          KeyCtl=
          MouseCtl=
          KeyCtl1=
          AppClose=2
          MinimizeApps=1
          Crop=
          Resize=
          ImagePath=capture.png
          DelFile=1

          Jon

          Comment


            #6
            Originally posted by jon00 View Post
            Try the default settings which come with the script:

            [Capture5]
            App=iexplore.exe
            AppProcessName=iexplore
            Parms=http://www.google.com
            AppWaitTime=5
            KeyCtl=
            MouseCtl=
            KeyCtl1=
            AppClose=2
            MinimizeApps=1
            Crop=
            Resize=
            ImagePath=capture.png
            DelFile=1
            May-29 11:19:16 Error Compiling script C:\Program Files (x86)\HomeSeer HS3\scripts\Jon00Capture2ImageHS3.vben: Namespace or type specified in the Imports 'System.Core' doesn't contain any public member or cannot be found. Make sure the namespace or the type is defined and contains at least one public member. Make sure the imported element name doesn't use any aliases.
            May-29 11:19:16 Error Compiling script C:\Program Files (x86)\HomeSeer HS3\scripts\Jon00Capture2ImageHS3.vben: 'Screen' is not a member of 'Forms'.
            May-29 11:19:16 Error Compiling script C:\Program Files (x86)\HomeSeer HS3\scripts\Jon00Capture2ImageHS3.vben: 'Screen' is not a member of 'Forms'.
            May-29 11:19:16 Error Compiling script C:\Program Files (x86)\HomeSeer HS3\scripts\Jon00Capture2ImageHS3.vben: 'Screen' is not a member of 'Forms'.
            May-29 11:19:16 Error Compiling script C:\Program Files (x86)\HomeSeer HS3\scripts\Jon00Capture2ImageHS3.vben: 'Screen' is not a member of 'Forms'.
            May-29 11:19:16 Error Compiling script C:\Program Files (x86)\HomeSeer HS3\scripts\Jon00Capture2ImageHS3.vben: 'Screen' is not a member of 'Forms'.

            getting this error with default settings
            Preferred -> Jon's Plugins, Pushover, Phlocation, Easy-trigger,
            Rfxcom, Blade Plugins, Pushbullet, homekit, Malosa Scripts




            HS3Pro 4.0.8.0 on windows 10 enterprise X64 on hp quadcore laptop 8 GB.

            Comment


              #7
              I would check your ScriptingReferences again. Make a copy of your entry and just try the following on its own:
              Code:
              ScriptingReferences=System.Windows.Forms;System.Windows.Forms.dll,System.Drawing;System.Drawing.dll
              Remember, you need to shutdown HS3 first before changing Settings.ini
              Jon

              Comment


                #8
                Originally posted by jon00 View Post
                I would check your ScriptingReferences again. Make a copy of your entry and just try the following on its own:
                Code:
                ScriptingReferences=System.Windows.Forms;System.Windows.Forms.dll,System.Drawing;System.Drawing.dll
                Remember, you need to shutdown HS3 first before changing Settings.ini
                Apperantly there was an error with my references..

                it was not in the correct order, now i changed it and it works.

                thanks again for your support

                Preferred -> Jon's Plugins, Pushover, Phlocation, Easy-trigger,
                Rfxcom, Blade Plugins, Pushbullet, homekit, Malosa Scripts




                HS3Pro 4.0.8.0 on windows 10 enterprise X64 on hp quadcore laptop 8 GB.

                Comment

                Working...
                X