Announcement

Collapse
No announcement yet.

Jon00 Event Viewer & Documenter for Homeseer 4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • vasrc
    replied
    Ahh... It's THAT problem..
    Seems that brain cell was on vacation..

    All is well again, sorry for the noise..

    Leave a comment:


  • jon00
    replied
    Originally posted by vasrc View Post
    Windows 10
    Same result for test.aspx

    Do have your Links installed as well.
    OK, this is a general ASPX issue. Shutdown Homeseer and restart via the desktop icon. Does it now work?

    If so, do you use Task Scheduler to start Homeseer?

    Leave a comment:


  • vasrc
    replied
    Windows 10
    Same result for test.aspx

    Do have your Links installed as well.

    Leave a comment:


  • jon00
    replied
    Is this Windows or Linux.

    Try calling /test.aspx to see if you get the same error.

    Leave a comment:


  • vasrc
    replied
    For DeviceViewer (HS4)

    Just upgraded to HS4 4.1.16.0
    Getting:
    Error Processing ASP.NET page: Object reference not set to an instance of an object.

    Was running 4.1.10.0

    Thanks

    Leave a comment:


  • avpman
    replied
    Originally posted by jon00 View Post
    Unfortunately, that is a HS generated error. It may be that your system is too slow to query all the event data.
    I'm running it on a Pi-4 with 8gb of ram. I don't have a lot of events. Is there a way for me to verify that this is the problem?
    Thanks!

    Leave a comment:


  • jon00
    replied
    Unfortunately, that is a HS generated error. It may be that your system is too slow to query all the event data.

    Leave a comment:


  • avpman
    replied
    Hi, I'm getting this error in the log every time I run Event Viewer on HS4 (Linux). Thanks in advance for any help.

    5/23/2021 10:10:24 AM HomeSeer Error
    Exception in (Action Name)/Build UI: Index was out of range. Must be non-negative and less than the size of the collection. Parameter name: index

    Leave a comment:


  • jon00
    replied
    Many thanks!

    Leave a comment:


  • avpman
    replied
    Originally posted by avpman View Post

    Thanks! Mono JIT compiler version 6.12.0.122 fixed it.
    Wow, using the script just saved me a bunch of time tracking down a pesky problem I had with an event. This should be built into HS. Made a donation to show my appreciation for your hard work.

    Leave a comment:


  • avpman
    replied
    Originally posted by jon00 View Post
    I would also recommend you update to Mono 6 first.
    Thanks! Mono JIT compiler version 6.12.0.122 fixed it.

    Leave a comment:


  • jon00
    replied
    I would also recommend you update to Mono 6 first.

    Leave a comment:


  • zwolfpack
    replied
    To verify you've made the vbnc patch correctly,
    at the Linux command line run command: vbnc

    Look for a line starting with 'Copyright'. If it indicates "Copyright (C) Microsoft Corporation" you've done it correctly. If it says something like "Copyright (C) 2004-2010 Rolf Bjarne Kvinge" ... you haven't.

    My recommendation for implementing the patch is the following command
    Code:
    cd /usr/bin && sudo install -p vbc vbnc
    As it seems less prone to fat-finger than opening up a text editor in a potentially unfamiliar environment...

    Leave a comment:


  • avpman
    replied
    Originally posted by jon00 View Post
    You will probably need to upgrade your Linux PC to use vbc rather than vbnc. See post 11.
    I made the change:

    #!/bin/sh
    exec /usr/bin/mono --debug $MONO_OPTIONS /usr/lib/mono/4.5/vbc.exe "$@"

    Then rebooted and I still get the error below (which is weird because it's still referring to VBNC) :
    (FWIW MONO Version is: Mono JIT compiler version 5.18.0.240 (Debian 5.18.0.240+dfsg-3 Sat Apr 20 05:16:08 UTC 2019)



    Click image for larger version

Name:	jonEvents2.JPG
Views:	72
Size:	31.4 KB
ID:	1474688

    Leave a comment:


  • jon00
    replied
    You will probably need to upgrade your Linux PC to use vbc rather than vbnc. See post 11.

    Leave a comment:

Working...
X