Announcement

Collapse
No announcement yet.

Echo Skill Helper for Homeseer 3: Problems with "Set CAPI Value (from parsed #):"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Echo Skill Helper for Homeseer 3: Problems with "Set CAPI Value (from parsed #):"

    I'm trying use the Echo Skill Helper to set my thermostat using a parsed integer. According to the HS logs, the number is being parsed correctly, but I cannot seem to get the proper formatting of what I should put in the "Set CAPI Value (from parsed #)" field.

    I used the little cheat tool at the top of the page to generate the proper text for the "CAPI Control:" field above. According to this tool, if I want to set the thermostat target to 72 degrees I would use the following format "10,72,72 °F" in the CAPI Control field and it works great. The thermostat setting gets changed. But I can't figure out how to include the parsed number into the field below. I have tried things like "10,+60,+90" and "10,{#},{#} °F" with no luck.

    I just downloaded the most recent version. So I am running Script Version: 1.2.9, ASPX Script Version: 1.2.7. I have searched high and low through this forum and have found similar issues but still haven't gotten it sorted out. Any guidance would be appreciated.

    Thanks!

    #2
    If 10,72,72 °F works in the CAPI control field then 10,40,100,{#} °F should work in the Set CAPI Value (from parsed #) field.

    You can change the 40 & 100 to set the lower/upper values as necessary.
    Jon

    Comment


      #3
      Originally posted by jon00 View Post
      If 10,72,72 °F works in the CAPI control field then 10,40,100,{#} °F should work in the Set CAPI Value (from parsed #) field.

      You can change the 40 & 100 to set the lower/upper values as necessary.

      That did the trick! I could have sworn that was one of the combinations I tried, but clearly not. Thank you for the fast response Jon!

      Comment

      Working...
      X