Announcement

Collapse
No announcement yet.

Jon00 HS4 Installed Plugin Update Notifier

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Jon00 HS4 Installed Plugin Update Notifier

    This package allows you monitor for HS4 installed plugin updates via a virtual device. This can be used to trigger events if necessary.

    Email/Pushover messages etc. can include details of the plugins which have updates available.

    Click image for larger version  Name:	HS4PIUpdateNotifier1.png Views:	0 Size:	15.9 KB ID:	1411398
    Click image for larger version  Name:	HS4PIUpdateNotifier2.png Views:	0 Size:	23.4 KB ID:	1411399

    Any issues, please let me know.

    As always, it is available on my site. Click on my banner below.

    (No banner shown? check your forum display settings!)
    Jon


    #2
    Does it check for updates of your own plug-ins?

    Comment


      #3
      Originally posted by baudi View Post
      Does it check for updates of your own plug-ins?
      No
      Jon

      Comment


        #4
        Beautiful! Thank you, jon00 !!!
        Karl S
        HS4Pro on Windows 10
        242 Devices
        56 Z-Wave Nodes
        37 Events
        HSTouch Clients: 3 Android, 1 iOS
        Google Home: 3 Mini units 1 display

        Comment


          #5
          Hi Jon thanks for this tool,

          I installed the plugin yesterday, i ran it manually and at that time it created the device showing one plugin to be updated. I set an event to run at midnight and this morning I looked if there was any other update and I can't see the device anymore.

          I tried manually running script again, i can see it ran in the log file but it does not recreate the device. I see no error in the log when i run the script

          Just so you know, I have not updated the plugin that showed as to be update yesterday.

          10-11-2020 06:06:24 HomeSeer Event Running script in background (HS4 Plugin Update (Jon00 Check available Plugin update)): Jon00HS4PluginUpdateNotifier.vben

          Comment


            #6
            I think I saw another post from you that the update cloud on plugins are not seen in your updater. If that is the case then this will not work either.
            Jon

            Comment


              #7
              Originally posted by jon00 View Post
              I think I saw another post from you that the update cloud on plugins are not seen in your updater. If that is the case then this will not work either.
              You are right legacy plugin does not show the cloud in the plugin installed page BUT HS4 native plugin does.

              Yesterday when I installed the plugin it created the device showing the Jowihue HS4 plugin available update. Last night after the schedule script run, the device dissepear, this morning eventough the plugin has not been updated, manually running script does not even create the device

              see below, the JowiHue plugin showing available updates

              Click image for larger version

Name:	a.JPG
Views:	55
Size:	11.9 KB
ID:	1425343

              Comment


                #8
                Did you delete the device?

                If not, check your filtering. There should be "Jon00 HS4 PI Update Notifier" in the "Room" filter which you should tick and then save at the bottom of the drop-down.
                Jon

                Comment


                  #9
                  Originally posted by jon00 View Post
                  Did you delete the device?

                  If not, check your filtering. There should be "Jon00 HS4 PI Update Notifier" in the "Room" filter which you should tick and then save at the bottom of the drop-down.
                  I did not delete the device. I also checked my filtering and "Jon00 HS4 PI Update Notifier" is not in the filter list. I also did a search in the Device page on "PI" and the search did not find any device with "PI" in the description, I noted the device ID when it was created and even searching with the device ID I can't find back the device

                  Comment


                    #10
                    I have no idea then. If the script detects that the virtual device device does not exist, it will recreate it. If you run the script and nothing happens then the device must be created somewhere. With your other issues, perhaps part your Hs4 installation is corrupted?
                    Jon

                    Comment


                      #11
                      Originally posted by jon00 View Post
                      I have no idea then. If the script detects that the virtual device device does not exist, it will recreate it. If you run the script and nothing happens then the device must be created somewhere. With your other issues, perhaps part your Hs4 installation is corrupted?
                      I brought back a backup frm 2 days ago, re-installed the script and run it. It created the device, now I have set a recurring event for every 12 hours as it was before, I will see in 12 hours if the devices is still there or not.

                      Meanwhile I am still waiting for a call back from Homeseer for the problem I reported about legacy plugin not showing the cloud when there are updates available (it looks like I am not the only one with this problem)

                      I will report my findings here

                      thanks

                      Comment

                      Working...
                      X