Announcement

Collapse
No announcement yet.

Errors with filegrabber

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Errors with filegrabber

    Hi guys,

    I installed and configured filegrabber as per instructions, and then made an attempt at locating and sending myself a zipped copy of the filegrabber.ini file.

    This is the result in the HS log:

    07/05/2008 12:08:12 ERROR InTCPSendFile: Illegal characters in path.
    07/05/2008 12:08:12 Error Web Server Error 404, cannot serve file: C:\Program Files\HomeSeer 2\html/filegrabber.asp?ref=C:\Documents and Settings\All Users\Documents\
    07/05/2008 12:15:02 Info Web Server authorized local login successful from: 192.168.1.43 User: *****
    07/05/2008 12:15:54 Error In Zip file handling: Could not find a part of the path 'C:\Program Files\HomeSeer 2\HTML\Temp\Filegrabber.zip'.
    07/05/2008 12:15:54 Error Building SMTP message for sending: Invalid mail attachment 'C:\Program Files\HomeSeer 2\HTML\Temp\Filegrabber.zip'.

    Does anyone know what this may be caused by?

    Thanks

    #2
    What was the full path of the file you were trying to zip?
    Jon

    Comment


      #3
      Jon,

      the complete path was

      Path: C:\Program Files\HomeSeer 2\Config\filegrabber.ini

      Although I wasn't able to zip & email it, I managed to download it directly with no problem. I have not tried downloading in .zip format

      Comment


        #4
        The error in line 2 suggests you were navigating down the documents & settings route which is not the path you have described.

        If you have any more issues let me know.
        Jon

        Comment


          #5
          Jon,

          I have tried again. Here is the screenshot of what I was trying to send (tried with a different file)

          This is the result in the log file:

          07/05/2008 16:35:07 Error Sending email using SMTP: The system cannot find the file specified.
          07/05/2008 16:35:37 Error Building SMTP message for sending: Invalid mail attachment 'C:\Program Files\HomeSeer 2\HTML\Temp\zipEditor.zip'.
          07/05/2008 16:36:07 Error Building SMTP message for sending: Invalid mail attachment 'C:\Program Files\HomeSeer 2\HTML\Temp\zipEditor.zip'.
          07/05/2008 16:36:37 Error Building SMTP message for sending: Invalid mail attachment 'C:\Program Files\HomeSeer 2\HTML\Temp\zipEditor.zip'.
          07/05/2008 16:36:37 Warning Sending email To: xxx@xxx aborted after 4 tries

          Could the fact the file size is reported as "B" have something to do with this?

          For other files, the size is reported correctly...
          Attached Files

          Comment


            #6
            Odd...

            Look in the Temp directory as you posted. Is the file actually there?
            Do you run a Spanish version of Windows?
            Jon

            Comment


              #7
              Just checked - the temp dir is empty.

              The OS is Win XP Pro SP2 English.

              A thought: does winzip have to be installed, or d you make use of Window's built in capability to handle zip files?

              Comment


                #8
                No, the zip facility is built in to Homeseer.

                I've just got home and can verify that there is an issue with emailing a file if you zip it first. Downloading either a zipped or unzipped file seems to work as does emailing a file directly. I have to confess, I never email files so did not notice that this problem existed.

                If you can confirm this, It would be appreciated.

                I'll need to take a look to see where the issue is. I think you get the 'B' if the file is less than 1000 bytes in size.
                Jon

                Comment


                  #9
                  Jon,

                  sorry for the delay. I have verified what you state above: downloading either native or zipped, and emailing native all work fine.

                  If emailing in zipped format does not work properly, it's hardly a major issue at least for me. I am more than happy with the ability to download and very grateful at that - it's just what I needed!!! In any case, I can think of times when it would be nice to receive an email with a zipped attachment (particularly for accounts that will filter out emails with executable attachments - sometimes they let them through if contained within a .zip archive)

                  One note: I have seen that, after downloading the file, when I press continue the page that confirms the deletion of the temp file does not always load. Sometimes I need to refresh the URL and then the deletion page does come up. I will add this is on a slow connection, so I am not sure if this has something to do with it.

                  Comment


                    #10
                    This was working when I released it so something has changed with Homeseer over the last year or two. I will fix it when I get some free time.

                    The file deletion is being carried out by the asp so it may take some time to process and respond. It obviously better to do this via script but at the time I just wanted drop in pages that worked.
                    Jon

                    Comment

                    Working...
                    X