Announcement

Collapse
No announcement yet.

Jon00s Web Page Builder - camera page

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • jon00
    replied
    Steve,

    I'm doing some modifications to this web page to assist you and others with this issue. That said, is port 8080 your Homeseer server or another one serving your camera picture?

    Leave a comment:


  • Steve Q
    replied
    Duh! I guess it was easy to spot! However, I am a but unclear regarding what is the right approach to access Homeseer information from outside my local network. In the past I have always signed into Homeseer and then I select a Homeseer menu button to go to my iTouch web page. Is this the correct approach? Or is there a way to get to the iTouch web page without signing in to Homeseer. Excuse me if I sound confused, but I have never had much of an opportunity to experiment with the iTouch from free WIFI access spots.

    Thanks,
    Steve Q

    Leave a comment:


  • jon00
    replied
    Steve,

    That problem is easy to spot. The URL to the image you posted is your local IP address so you will never see it outside your network. You would have to use your WAN IP address to see this outside.

    Leave a comment:


  • Steve Q
    replied
    Jon, Thanks

    I think I have some other issues going on as well because I cannot get the camera image at all unless I am on my local wireless network. At any other WIFI spot, I am able to access my iTouch web page and everything but the camera image is displayed properly. If I access the camera web page, I am able to see the image, so I don't think it is a firewall issue. I'm not sure what the problem is?

    Steve Q

    Leave a comment:


  • jon00
    replied
    That is odd. I just set up a page showing a camera image (with the same file name) that is updated every minute. On my iTouch with page refresh set to 1 minute, it updates the picture correctly?

    It also does this with IE.

    What I will do is make and send you a test build with a method to append a random number to the end of the image string. This will look like:

    Column1Section6-1Right=Imagehttp://192.168.1.102:8080/cam_1.jpg#[rand],225,165

    The browser will see the image URL as Cam_1.jpg#12646237282 but the number will change each time the page is refreshed. The browser thinks it is another image and therefore not cached.

    The only problem is that this method only works in Safari and Fire fox.

    Maybe tomorrow or the weekend.

    Leave a comment:


  • Steve Q
    replied
    Jon,

    I understand that the page is cached. But Safari is properly refreshing the other parts of the page like the temperatures and device status. My weather map is also refreshing, but the camera image is not? By the way, the same thing happens in Internet Explorer.

    Steve Q

    Leave a comment:


  • jon00
    replied
    Steve,

    I had a look at this but there is not much I can do. The iTouch stores pages in memory when Safari is closed. If you return to that same page, this is restored including the old images. Even if you have set the page to refresh, this is disabled if you go away from Safari. Only a refresh will get the current page back.

    Leave a comment:


  • jon00
    replied
    I will need to do some tests but yes, of course I will make changes if necessary.

    Leave a comment:


  • Steve Q
    replied
    I have not closely followed the touchscreen thread, so I was unaware of its similar problems. Yes, the issue relates to myiTouch. Are you making changes to webpage builder?

    Steve Q

    Leave a comment:


  • jon00
    replied
    If you have been following my touchscreen thread, there are similar problems. I have made a few modifications to that I can also add to this.

    I assume your problem is with the iTouch?

    Leave a comment:


  • Steve Q
    started a topic Jon00s Web Page Builder - camera page

    Jon00s Web Page Builder - camera page

    On my web page for my iTouch I have a security camera photo displayed. I use the following code in web pagebuilder:

    Column1Section6-1Right=Imagehttp://192.168.1.102:8080/cam_1.jpg,225,165

    The problem is the image is always the last image that page builder displayed, not the current cam_1.jpg image. I have to refresh the page to get the current camera image. Is there any way to force pagebuilder to get the current image?

    Steve Q
Working...
X