Announcement

Collapse
No announcement yet.

Jon00 Cumulative Uptime Monitor For Homeseer Devices

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Jon00 Cumulative Uptime Monitor For Homeseer Devices

    **** Discussion for Homeseer 3 version here ****
    Attached Files
    Last edited by jon00; August 13, 2014, 04:45 PM.
    Jon


    #2
    Works great. Thanks Jon.
    Regards, Bob

    Comment


      #3
      this looks awesome... i've just found this as well as your graphing script as i haven't been on the boards for a while.

      how are you monitoring the on/off status of the playstation?

      Comment


        #4
        You can do so by using one of the network monitoring plugins or probably by pinging it to see if there is a response.
        Jon

        Comment


          #5
          Well I've had over 45 downloads for this now with only a small number of comments. Anyone willing to share what applications they are actually using this for?
          Jon

          Comment


            #6
            I'm using it to track the kids television / video game playing time. Works great for setting limits on the time the kids can "zone out" in front of the boob tube.
            Regards, Bob

            Comment


              #7
              Hello

              I'm using it to track the time for my heating system
              And for some lamps

              ed

              Comment


                #8
                housecode will not be generated

                When i run the script i doesn't creat the housecodes.
                Do you know what i could be doing wrong.
                I have attached my ini file.
                I call the script like this: Jon00Uptime.vben("Main","")
                Attached Files

                Comment


                  #9
                  You need to tell the script what parameters in the ini file you wish to use via the optional parameters.

                  It looks like you have 11 devices.

                  If you wanted to start the timer for all 11 devices you would call the script as follows:

                  Jon00Uptime.vben("Main","1,1|2,1|3,1|4,1|5,1|6,1|7,1|8,1|9,1 |10,1|11,1")

                  or individually:

                  Jon00Uptime.vben("Main","1,1")
                  (for device 1)
                  Jon00Uptime.vben("Main","2,1")
                  (for device 2 etc)

                  and to stop:

                  Jon00Uptime.vben("Main","1,0")
                  (for device 1)
                  Jon00Uptime.vben("Main","2,0")
                  (for device 2 etc)

                  To update all devices only you use:

                  Jon00Uptime.vben("Main","1|2|3|4|5|6|7|8|9|10|11")

                  or individually:

                  Jon00Uptime.vben("Main","1")
                  etc
                  Jon

                  Comment


                    #10
                    That was fast :-)

                    Thanks for the quick response.

                    Comment


                      #11
                      Hi Jon,

                      Just discovered this great script. I'm using it to track runtime for my two furnaces and trigger reminders for filter changes. This is great because I have one furnace that only provides heat to the underground part of the house so it only runs in the Winter but the upstairs furnace provide heating and cooling so it has much more runtime and thus needs the filter changed more often.

                      Thanks for the great work,
                      Ken

                      Comment


                        #12
                        Thanks!

                        Always interested in uses for this script.
                        Jon

                        Comment


                          #13
                          Can't reset.....

                          Jon,

                          I've downloaded your script and set up 3 devices (1 daily, 1 weekly, 1 monthly) for my HVAC cooling function. 1 is daily, 2 is weekly, 3 is monthly.

                          I've got the devices to update, and set up events (midnight, midnight on Sunday, Midnight on 1st of every month) to reset the devices.

                          This first morning, the daily device was not reset, though the script ran.

                          The parameters passed from the script are: ("Main","1,Reset") I copied this from the documentation.

                          Here's my device 1 from the config file:

                          [Device1]
                          Housecode=y80
                          Title=Daily Cooling
                          TextBeforeValue="Cooling today: "
                          TextAfterValue=
                          TimeStringFormat=2
                          ShowTriggers=0
                          EventValueType=
                          DeviceValueType=1
                          EventName1=
                          EventValue1=
                          EventName2=
                          EventValue2=
                          EventName3=
                          EventValue3=


                          *** Read Values Only ***
                          TotalUptime=0 days 18 hrs 49 mins
                          CurrentDays=0
                          CurrentHours=18
                          CurrentMinutes=49
                          CurrentSeconds=0
                          TotalDays=0
                          TotalHours=18
                          TotalMinutes=1129
                          TotalSeconds=67740
                          LastReset=
                          LastOff=6/22/2009 3:31:51 PM
                          LastOn=6/22/2009 3:40:51 PM
                          LastTotalUptime=18:07:00
                          Status=3
                          CurrentUptime=18:49:00.0806432
                          EventFlag1=
                          EventFlag2=
                          EventFlag3=


                          Did I just not read the manual correctly (again....)?

                          I also set up a manual event, copied/pasted the parameters from the documentation and ran it manuallly. Here is a line from the log:

                          6/22/2009 4:15:44 PM - Info - Running script in background: Jon00Uptime.vben("Main","1,Reset")

                          Comment


                            #14
                            Now I'm sure this was working when I was on V2.3.0.19 but I have just tried it again on V2.2.0.66 and it is not. I know what is causing this (it's the comma in the parms being used as a delimiter incorrectly by HS).

                            Would you please confirm the version of HS you are running.
                            Jon

                            Comment


                              #15
                              2.2.0.11

                              Jon,


                              It's 2.2.0.11 . I have avoided the 2.3 hype and continuing upgrade/beta hassles as much as possible. Too many people have lost their databases, lost their events, had a password put on their .mdb for my tastes. Therefore, I have left well enough alone for a while.

                              Let me know if this is incompatible with my version.

                              Thanks for all you do....

                              Gayle

                              Comment

                              Working...
                              X