Announcement

Collapse
No announcement yet.

Jon00 Cumulative Uptime Monitor For Homeseer Devices

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • jon00
    replied
    Bob,

    Whilst I know you were the one to request this script, I feel your suggestion is specific to you. Rather than create all these virtual devices, why not just store the previous uptime values to the ini file and then read all the data out to a single device. This is probably all I would do.

    Leave a comment:


  • itanic
    replied
    I'm using the script to track TV on time. For each television in the house, I've created three devices - one for tracking daily use (reset nightly), one for tracking weekly use (reset weekly) and the third for tracking monthly use (reset monthly).

    I use three companion devices to keep information on the up time from the prior period aptly named yesterday, last week and last month. I populate these devices using a script like that mentioned previously (hs.SetDevicestring "Q10",hs.GetIniSetting("Device1","TotalUptime","","Jon00Upti me.ini")).

    So all in all, I have six devices for each TV in the house (of which I have three). I sure would be nice if the plugin could consolidate some of these items for me within a single device. Any ideas?

    Leave a comment:


  • rmasonjr
    replied
    Originally posted by dinki View Post
    Thank you for the quick reply. I indeed did restart Homeseer and got the same message upon restarting.

    *EDIT* I just deleted all files from Uptime and still seeing the error. Sorry for the bother.
    Yeah, that's definitely not from Jon00's uptime utility - it is from your ZWave Thermostats plugin.

    Leave a comment:


  • dinki
    replied
    Thank you for the quick reply. I indeed did restart Homeseer and got the same message upon restarting.

    *EDIT* I just deleted all files from Uptime and still seeing the error. Sorry for the bother.

    Leave a comment:


  • jon00
    replied
    I would say your error is totally unrelated with unzipping the files. Did you restart Homeseer as the error suggested?

    Leave a comment:


  • dinki
    replied
    I'm a newbie so please be gentle. I'm having issues installing this plugin on my HS2 2.5.0.20 install. I downloaded and extracted the contents to my HS directory while HS was shut down. When I started HS again, I was greeted with this:

    Code:
    4/14/2011 11:04:23 AM  	ZWave Thermostats  	Error in HSPI.GetTemp, Object reference not set to an instance of an object. Plugins may be out of sync, restart HomeSeer
    4/14/2011 11:04:23 AM  	ZWave Thermostats  	Error in HSPI.GetHeatSet, Object reference not set to an instance of an object. Plugins may be out of sync, restart HomeSeer
    4/14/2011 11:04:23 AM  	ZWave Thermostats  	Error in HSPI.GetCoolSet, Object reference not set to an instance of an object. Plugins may be out of sync, restart HomeSeer
    4/14/2011 11:04:23 AM  	ZWave Thermostats  	Error in HSPI.GetModeSet, Object reference not set to an instance of an object. Plugins may be out of sync, restart HomeSeer
    4/14/2011 11:04:23 AM  	ZWave Thermostats  	Error in HSPI.GetFanMode, Object reference not set to an instance of an object. Plugins may be out of sync, restart HomeSeer
    4/14/2011 11:04:23 AM  	ZWave Thermostats  	Error in HSPI.GetCurrentMode, Object reference not set to an instance of an object. Plugins may be out of sync, restart HomeSeer
    4/14/2011 11:04:23 AM  	ZWave Thermostats  	Error in HSPI.GetOperating, Object reference not set to an instance of an object. Plugins may be out of sync, restart HomeSeer
    4/14/2011 11:04:23 AM  	ZWave Thermostats  	Error in HSPI.GetHoldMode, Object reference not set to an instance of an object. Plugins may be out of sync, restart HomeSeer
    4/14/2011 11:04:23 AM  	ZWave Thermostats  	Error in HSPI.GetHoldMode, Object reference not set to an instance of an object. Plugins may be out of sync, restart HomeSeer
    4/14/2011 11:04:23 AM  	ZWave Thermostats  	1 Thermostats converted Successfully.
    I'm using the Zwave Tstat plugin with a Trane Zwave Tstat. I did not have this problem before copying the files over to my HS directory. Any ideas on what to do to fix this?

    Leave a comment:


  • jon00
    replied
    V1.03.2 released!

    Just got around to another feature request.

    This version will now optionally show an up counter on the virtual device to display the number of times the device has been triggered as on (provided it was off before).

    If upgrading, please read the upgrade.txt in the zip. Apart from replacing the script, it just a matter of adding a new entry to the ini file (per device) and adding the new image file.

    Leave a comment:


  • jon00
    replied
    It calculates using timestamps, so if nothing happens to the device when Homeseer is offline, reset etc, it will continue to calculate the uptime correctly.

    Leave a comment:


  • drozwood90
    replied
    Jon,

    What do you think your Uptime script will do, if I have something set "on" then HS gets reset?

    Will it continue to count? That is, when this is turned on, does it just say "I was on at: [ time ]" then when you say OFF, it just does a difference in time and add to the already accumulated time?

    Or, will it goof up the counting if I reset while the devices are on?

    --Dan

    Leave a comment:


  • ESSCHENK
    replied
    Jon,

    Thanks it works great
    Now I can fill my database so I can see how long
    per day per week per month per year
    the device is on.
    Thanks Ed

    Leave a comment:


  • jon00
    replied
    The single script line was meant to be run in the event's script statement box.

    If you want to run it as a separate script, just remove the & at the beginning of the second line of your script.

    Leave a comment:


  • ESSCHENK
    replied
    Hello,

    Thanks Jon for your answer
    I have create a event with the following

    sub main()
    &hs.SetDevicestring "N30",hs.GetIniSetting("Device1","TotalUptime","","Jon00Upti me.ini")
    End Sub
    I have saved it as a txt file

    But its give some errors

    Can you give the setup to make it work

    Thanks

    Ed

    Leave a comment:


  • jon00
    replied
    All the data is stored in the uptime.ini

    You could create an event at 23:59 with an immediate script command something like:

    PHP Code:
    &hs.SetDevicestring "Q10",hs.GetIniSetting("Device1","TotalUptime","","Jon00Uptime.ini"

    Leave a comment:


  • ESSCHENK
    replied
    Hello Jon,

    Iam using your uptime monitor from the beginning and I love this plug-in.
    I have 1 question
    Is it possible to copy the uptime at the end of the day, say 23:59
    To another virtual device so I can see what the uptime was the day before
    Then i can also use this device to log this time to my database

    Thanks

    Ed

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Thanks, I will look into that. Much appreciated

    Leave a comment:

Working...
X