Announcement

Collapse
No announcement yet.

Jon00 PicViewer Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • X10joe
    replied
    Jon,

    I played with folder names and that will work. Now I just have to work on my script to create the new folders.

    Leave a comment:


  • jon00
    replied
    Ah Ok. For the date picker to work, I think you have to store images in a directory with the last folder in date format i.e.

    C:\Program Files\HomeSeer HS2\html\netcam1\08072013

    I'm about to retire for the night but the docs should cover this.

    Leave a comment:


  • X10joe
    replied
    I will try that a little later when I get home.

    Just to clarify, I can see the images and slide shows fine. I just trying to filter down to today or another day with the date picker.

    Leave a comment:


  • jon00
    replied
    As a test, rename the files without the brackets. Do they now show?

    Leave a comment:


  • X10joe
    replied
    Jon,

    Here are the files names in the order they are in the netcam1-4 folders.

    Back Porch(2013-08-06at07-25-14-023).jpg
    Garage Cam(2013-08-06at07-19-05-008).jpg
    Garage View of Back Porch(2013-08-05at07-06-13-430).jpg
    Iles Ave Cam(2013-08-05at07-06-20-430).jpg

    Joe

    Leave a comment:


  • jon00
    replied
    Wow. I have not looked at this in ages.

    It looks OK. Can you give me a couple of examples of the filenames in the netcam1 directory?

    Leave a comment:


  • X10joe
    replied
    Either confused or just don't get it!

    Jon,

    Really cool Picture Viewer. Lots of potential for security camera use. Great work!!

    I have four folders:
    C:\Program Files\Home Seer HS2\html\netcam1
    C:\Program Files\Home Seer HS2\html\netcam2
    C:\Program Files\Home Seer HS2\html\netcam3
    C:\Program Files\Home Seer HS2\html\netcam4

    I have a script that copies images with the wild card criteria from
    C:\Program Files\Home Seer HS2\html\netcam1
    and pastes them into the proper netcam1 to 4 folders.

    So I have four distinct image names in four different folders. Each folder has the image time stamp for sorting. What I am having a problem with is no matter what I try in the picviewer.ini I cant get it to select the "today" date pictures.

    First folder settings:
    [ImagePath1]
    Path="c:\Program Files\HomeSeer HS2\html\netcam1\"
    Description="Back Porch"
    SkipList=""
    Subfolder="1"
    UseFilter="0"
    InitialImage=""
    ShowSlideShowButton=""
    Slidespeed=""
    Blendduration=""
    ImageWidth=""
    Imageheight=""
    CreateThumb="1"
    Range=""

    Any idea??

    Joe

    Leave a comment:


  • jon00
    replied
    Thanks Bryan...appreciated!

    Leave a comment:


  • TechHA
    replied
    Jon,
    Thank you very much! Works great now. A donation has been sent!

    Thanks again.

    Leave a comment:


  • jon00
    replied
    Bryan,

    My next attempt can now be downloaded. The only change is that if you now set Usefilter=2 then this disables date checking but still leaves the date select bar.

    Try the settings below.

    [Settings]
    ThumbnailWidth="95"
    ThumbnailHeight="95"
    DisplayImageHeight="250"
    ThumbnailWindowHeight="198"
    ImageTypes ="jpg,gif,png,bmp"
    LargeImageBGColor="#000000"
    ImagePathFontColor="#FF0000"
    ShowImagePath="1"
    DateSeparator="/"
    DateFormat="1"
    DateFolderFormat="2"
    HeightOffset="20"
    GuestViewAll="0"
    DropdownWidth=""
    HideHeaderButton=0
    AllowEnlarge=1
    ThumbnailLastModified=1

    [ImagePath1]
    Path="\\BigBrother\1\<Date>\"
    Description="Security Front Porch Camera"
    SkipList=""
    Subfolder="1"
    UseFilter="2"
    InitialImage=""

    Leave a comment:


  • jon00
    replied
    OK, I will remove the date checking when using date folders.

    I'll take a look on Saturday when I have some time free.

    Leave a comment:


  • TechHA
    replied
    Hey Jon,
    I don't have the dir 20090505, sorry ... I just deleted it this morning.

    I like the option to ignore the date stamp if using date folders idea. To me this seems like the easiest way out of this.

    For your reference though, this is what the properties look like on a picture taken today.
    Attached Files

    Leave a comment:


  • jon00
    replied
    Bryan,

    I'm really not sure what is going wrong as I've tried it here with all the different folders etc and all seems to work OK with my security images.

    When filtering is in use, it looks at the last modified date of each image and that has to match the date selected. It may be that process which is causing the issue. I could add an option to ignore the date stamp if using date folders.

    The second could be US date format which I cannot test easily.

    If you have a folder with 20090505, select this date using the 3 drop downs (you must select each one - do not assume what is displayed on the drop down will be used). See if that works.

    Leave a comment:


  • TechHA
    replied
    Sorry, Jon

    I tried the new download with the new settings. Still get 'No Image Found'.

    If I remove the UseFilter="1" to UseFilter="0", I get todays pics. So there are pics available in the directory.

    Leave a comment:


  • jon00
    replied
    I think I've sorted out the problem.

    I've seperated the Datefolderformat with the Dateformat.

    There is a new ini entry under [Settings] called DatefolderFormat

    Try these settings once you download the new version:

    [Settings]
    ThumbnailWidth="95"
    ThumbnailHeight="95"
    DisplayImageHeight="250"
    ThumbnailWindowHeight="198"
    ImageTypes ="jpg,gif,png,bmp"
    LargeImageBGColor="#000000"
    ImagePathFontColor="#FF0000"
    ShowImagePath="1"
    DateSeparator="/"
    DateFormat="1"
    DateFolderFormat="2"
    HeightOffset="20"
    GuestViewAll="0"
    DropdownWidth=""
    HideHeaderButton=0
    AllowEnlarge=1
    ThumbnailLastModified=1

    [ImagePath1]
    Path="\\BigBrother\1\<Date>\"
    Description="Security Front Porch Camera"
    SkipList=""
    Subfolder="0"
    UseFilter="1"
    InitialImage=""

    Leave a comment:

Working...
X