Announcement

Collapse
No announcement yet.

Jon00 Homeseer Plugin Enable/Disable utility

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    The only thing I can think of is that you do not now have (or disabled) the following line in your startup.vb file:

    hs.RunScript("Jon00Plugin.vben", False, False)
    Jon

    Comment


      You mean the line that was blown away when I did a restore of my HS3 setup a while back? Thanks - up and running again.

      Comment


        Following some z-wave problems many moons ago, I've been using this utility for a scheduled daily restart of Z-wave. I'm not sure it's still necessary, but I suddenly noticed that the restart was not occurring. Checking the virtual devices, I found nothing in the drop down menu for plugin selection. Checked the help and confirmed that the two requirements mentioned were fulfilled. Then noticed my Z-wave plugin was 3.0.7.0 and 3.0.9.0 was available.......but even after updating to the new version and restarting HS3, the problem is still there. Anything else I could try or check? Many thanks in advance

        Comment


          I would delete the two virtual devices and then restart Homeseer. Check to they are recreated with the plugins listed in the drop downs.
          Jon

          Comment


            Hi Jon - thanks for the suggestion, which I just tried - but the plugins are still not listed in the drop-down menus.

            Comment


              What OS are you using? Homeseer version?
              Jon

              Comment


                Win 10 Home / HS3 Pro 3.0.0548

                Comment


                  Have you change your accounts?

                  Remember you must have 'No Password Required for Local Login' ticked under Setup or update to version 1.0.9 which allows local login credentials.
                  Jon

                  Comment


                    BTW, since 3.0.9.0 of the plugin, I disabled the repeating restart of the ZWave plugin and no issues at all. FYI.

                    Comment


                      Originally posted by jon00 View Post
                      Have you change your accounts?

                      Remember you must have 'No Password Required for Local Login' ticked under Setup or update to version 1.0.9 which allows local login credentials.
                      I haven't made any account changes, and that setup option was and still is enabled.

                      Only thing that has changed recently is that I had to replace my router - but I don't think that's relevant.......

                      Comment


                        Remember you must have 'No Password Required for Local Login' ticked under Setup or update to version 1.0.9 which allows local login credentials.
                        If you do have password on local login then you may want to consider mcsMQTT for plugin and HS enable/disable control. It provides the mechanism to provide the credentials needed to perform the required login.

                        Comment


                          This morning, I got the message for a successful restart of Z-wave on my system - and when I checked the plugin's virtual devices, the drop-down menu was indeed populated again. Baffling - but happy that the problem seems resolved. Thanks for you help Jon00!

                          Comment


                            Originally posted by Lio View Post
                            This morning, I got the message for a successful restart of Z-wave on my system - and when I checked the plugin's virtual devices, the drop-down menu was indeed populated again. Baffling - but happy that the problem seems resolved. Thanks for you help Jon00!
                            Indeed. Most odd but glad its working again for you!
                            Jon

                            Comment

                            Working...
                            X