Announcement

Collapse
No announcement yet.

Jon00 Homeseer Plugin Enable/Disable utility

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #46
    Sorry Moskus. I tried for another 2 hours (I had tried all this before BTW) but HS refuses to accept the same POST string with Credentials when local login is enabled.
    Jon

    Comment


      #47
      Hi Jon, I found a weird one - the mediacontroller plugin (its in the updater).
      If it's started, it can stop it. However, once stopped, for some reason it can't find it to start it.

      Comment


        #48
        Can you please post screen shots of the stop & start run script event actions you are using.
        Jon

        Comment


          #49
          Sure, please see attached.
          Attached Files

          Comment


            #50
            It looks OK. Just wondering if you have you tried a duration longer than 20 seconds between stopping and starting? Some plugins take longer than others to stop/start.
            Jon

            Comment


              #51
              Tried a few minutes, it just doesn't seem to see the name of the plugin while it's disabled, which is weird.

              Comment


                #52
                Look at the plugin page. When you enable/disable the plugin manually, is the plugin text name exactly the same for both?
                Jon

                Comment


                  #53
                  Yep, hence why I'm confused why it doesnt work

                  Comment


                    #54
                    Thanks for this plugin it will fix a bug in Thinking Cleaner, however I have tried this on the other plugins and it does work but it cant "find" the ThinkingCleaner plugin , I have checked and double checked the spelling and layout it just says it cant find this plugin. any ideas ?
                    Attached Files
                    detail of setup in profile. Link to videos of my projects there as well. Over 300 scripts running every min and counting

                    Comment


                      #55
                      I don't know. I downloaded the plugin and tried it here....works fine:

                      Code:
                      Aug-27 16:10:25         Info    Plugin ThinkingCleaner with instance: has disconnected   
                      
                       Aug-27 16:10:25         Plug-In    Shutting down Plug-In: ThinkingCleaner   
                      
                       Aug-27 16:10:25         Event    Running script in background: C:/Program Files (x86)/HomeSeer HS3/scripts/Jon00PluginSet.vben("Main","ThinkingCleaner;0")   
                      
                       Aug-27 16:10:25         Event    Event Trigger "Test PluginSet"   
                      
                       Aug-27 16:10:25         Event    Event Test PluginSet triggered by the event page 'Run' button.   
                      
                       Aug-27 16:09:50         Plug-In    Finished initializing plug-in ThinkingCleaner   
                      
                       Aug-27 16:09:50         ThinkingCleaner    DEBUG1: GetLogLevel: Entered function   
                      
                       Aug-27 16:09:49         Info    Plugin ThinkingCleaner has connected. IP:127.0.0.1:2529   
                      
                       Aug-27 16:09:49         Event   Running script in background: C:/Program Files (x86)/HomeSeer HS3/scripts/Jon00PluginSet.vben("Main","ThinkingCleaner;1")
                      Jon

                      Comment


                        #56
                        Oddly its def NOT working for me
                        Attached Files
                        detail of setup in profile. Link to videos of my projects there as well. Over 300 scripts running every min and counting

                        Comment


                          #57
                          After working with Zac, I've identified the issue and have released V1.0.2 on my site.
                          Jon

                          Comment


                            #58
                            Multiple Instances of Plugin

                            Jon,
                            Thanks for the great work. I have noticed that if you have multiple instances of a plugin and you try to disable/enable a plugin after the multiple instance plugin, it will disable the wrong one. For example, I use a DirecTv plugin and it has two instances running, one for each room. The script will disable/enable the plugin before the plugin I am trying to control. If I delete the multiple instance, it works as planned. Any thoughts?

                            Comment


                              #59
                              Not an easy one to solve unfortunately. I may have to add an option where you have to physically count where the plugin is on the list and use that number. The problem is that if you add another plugin, you will have to adjust if necessary.
                              Jon

                              Comment


                                #60
                                Ok,
                                Thanks for looking into it. I see your point about counting the list, not the most convenient if you add/delete plugins. Right now I am just using the name below the one I need to disable/enable and it works.

                                Comment

                                Working...
                                X