Announcement

Collapse
No announcement yet.

Jon00 Homeseer 2 - Homeseer 3 - Homeseer 4 Connector

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Jon00 Homeseer 2 - Homeseer 3 - Homeseer 4 Connector

    This package allows you to link copies of Homeseer versions together for device mirroring and control purposes. It was originally written to connect Homeseer 2 systems to Homeseer 3 (as prevalent in the instructions); however, it can also be used to connect:

    Homeseer 2 to Homeseer 2
    Homeseer 2 to Homeseer 4
    Homeseer 3 to Homeseer 3
    Homeseer 3 to Homeseer 4
    Homeseer 4 to Homeseer 4

    It has the following features:

    Mirror Homeseer devices between systems
    Trigger events between systems
    Control devices between systems
    Run scripts between systems

    Virtual devices are created automatically and can be configured to show different details depending on the device being displayed.

    Due to the loss of device status in Homeseer 3, Homeseer 2 devices are translated with device values wherever possible.

    Configuration is very easy via text files.

    Due to Homeseer 2 being written in VB.NET 2 and Homeseer 3/4 written using VB.NET 4, it has been necessary to write 2 separate clients which are connected to Homeseer 2 and Homeseer 3/4 respectively but also connected together via a TCP bridge to provide the necessary communication path.

    NOTE: For security reasons, DO NOT connect remote instances of Homeseer together over the internet (i.e. a second property) without the use of a VPN.

    As always, you can download it from my web site (Click on the banner below)
    Last edited by jon00; March 31st, 2020, 06:03 AM.
    Jon


  • #2
    Thank you. Will give it a try.

    Appreciate the effort.
    Don

    Comment


    • #3
      Hey Jon:

      I have both HS2 and HS3 on the same machine. Set everything up per your excellent directions, but don't get a log entry indicating that the plugin is working in the HS3 log.

      The HS2 log appears as your directions states. I used the same IP address for all four settings in the HS2Settings.txt and HS3Settings.txt.

      Is there some sequence to start up these programs? I have HS2 and HS3 running before I start Jon00HS3Gateway and Jon00HS2Gateway.

      As an aside, I can't close the HS3Gateway.... The two icons are present in the task bar, and both pop up when I start HSJon00HS2Gateway. I can close the HS2 Gateway by right clicking the icon, but the HS3Gateway doesn't do anything.

      Thanks
      Don

      Comment


      • #4
        For some reason ESET decided that "downloadactionHS3.aspx?buttonID=11" was suspicious and blocked the download. Just mentioning it in case others encounter this also.

        Comment


        • #5
          David:

          Were you successful making this work?
          Don

          Comment


          • #6
            Originally posted by donstephens View Post
            Hey Jon:

            I have both HS2 and HS3 on the same machine. Set everything up per your excellent directions, but don't get a log entry indicating that the plugin is working in the HS3 log.

            The HS2 log appears as your directions states. I used the same IP address for all four settings in the HS2Settings.txt and HS3Settings.txt.

            Is there some sequence to start up these programs? I have HS2 and HS3 running before I start Jon00HS3Gateway and Jon00HS2Gateway.

            As an aside, I can't close the HS3Gateway.... The two icons are present in the task bar, and both pop up when I start HSJon00HS2Gateway. I can close the HS2 Gateway by right clicking the icon, but the HS3Gateway doesn't do anything.

            Thanks
            It looks like the HS3 client is not running correctly. Has an error log appeared in the HS3 client directory? Also what OS are you running the clients/Homeseer on?
            Jon

            Comment


            • #7
              Originally posted by donstephens View Post
              David:

              Were you successful making this work?
              Wasn't able to download it. When I find the time I'll download it to an isolated sandbox and eventually get it that way. I'd rather Jon00 not waste time on the issue if no one else is encountering it. I only posted it to start a counter in case others are.

              I'm running Windows 7 and sometimes Windows 8.1.

              Am I correct in assuming both HS3 and HS2/PRO need to be running on the same machine for the plug-in to work? Without Jon00's solution, I was marinating on the idea of using a switchbox as a near-term solution. I'm assuming the plug-in does its syncing based purely on status changes and does not rely on polling all the nodes to keep the two in sync? I actually was doing the download in hopes of reading a manual that would answer that particular question.

              Anyhow, TIA to Jon00 for doing the plug-in. Kudos. HS should hire you!
              Last edited by NeverDie; November 4th, 2013, 09:41 AM.

              Comment


              • #8
                I'm running XP. There are no log entries.
                Don

                Comment


                • #9
                  Originally posted by NeverDie View Post
                  Wasn't able to download it. When I find the time I'll download it to an isolated sandbox and eventually get it that way. I'd rather Jon00 not waste time on the issue if no one else is encountering it. I only posted it to start a counter in case others are.

                  I'm running Windows 7 and sometimes Windows 8.1.

                  Am I correct in assuming both HS3 and HS2/PRO need to be running on the same machine for the plug-in to work? Without Jon00's solution, I was marinating on the idea of using a switchbox as a near-term solution. I'm assuming the plug-in does its syncing based purely on status changes and does not rely on polling all the nodes to keep the two in sync? I actually was doing the download in hopes of reading a manual that would answer that particular question.

                  Anyhow, TIA to Jon00 for doing the plug-in. Kudos. HS should hire you!
                  I can send you a copy via email if you want. My email address is in my user notes on my profile here.

                  All devices that are configured are continually polled and if it detects any change including value, string, icon (and status in HS2), it will update accordingly.

                  You can have HS2 and HS3 on different PC's.
                  Jon

                  Comment


                  • #10
                    Originally posted by donstephens View Post
                    I'm running XP. There are no log entries.
                    Don,

                    Do you have another PC that you can run the HS3 client on your network. I've just tried it here on XP and it is working fine.

                    Just to check, you did use the correct scheduler.dll from HS3 and not use the HS2 version?
                    Jon

                    Comment


                    • #11
                      Re: Jon00 Homeseer 2 - Homeseer 3 Connector

                      Pretty sure I got the correct scheduler. I'll try on another machine when I get home.
                      I'm wondering if perhaps the download might've been corrupted.

                      Thanks.

                      Sent from my DROID X2 using Tapatalk 2
                      Don

                      Comment


                      • #12
                        Hi Jon

                        I have the same issue as Don Stephens and I am running Windows 7 Pro x64. Both HS2 and HS3 are running on the same machine.

                        HS2 has a log file but HS3 does not.

                        HS2 log file has an entry Jon00_HS2GW started but HS log file has no such entry.

                        Same issue when closing HS2 can be closed in the tray but HS3 has to be closed by killing the process in Task manager.

                        Hope that may give a clue.

                        Thanks

                        Jo

                        Comment


                        • #13
                          Originally posted by Jo View Post
                          Hi Jon

                          I have the same issue as Don Stephens and I am running Windows 7 Pro x64. Both HS2 and HS3 are running on the same machine.

                          HS2 has a log file but HS3 does not.

                          HS2 log file has an entry Jon00_HS2GW started but HS log file has no such entry.

                          Same issue when closing HS2 can be closed in the tray but HS3 has to be closed by killing the process in Task manager.

                          Hope that may give a clue.

                          Thanks

                          Jo
                          OK so there obviously is an issue. Can someone try this replacement exe?
                          Last edited by jon00; November 17th, 2013, 11:46 AM.
                          Jon

                          Comment


                          • #14
                            Ha...found the issue. It looks like I left in a hard coded IP address for the HS3 Host address. The link above has the corrected version and I have also updated the download.
                            Jon

                            Comment


                            • #15
                              Great Job. Works better than advertised.

                              Thanks Jon.
                              Don

                              Comment

                              Working...
                              X