Announcement

Collapse
No announcement yet.

Jon00 Database Charting Utility for Homeseer 3 & Homeseer 4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by jon00 View Post
    Bart,

    It's a similar question and response at posts 785 and 786. This is built in and nothing I can do about it.
    @Bart Yes, look at my graph a couple of posts up. I have the exact same problem. Very annoying and it doesn't seem solvable when using columns.

    Comment


    • Just sent you a PayPal donation for tonights pints. Have a couple of nice ones and keep up the great work.

      Comment


      • Originally posted by Freddan101 View Post
        When I think of Week I would like to show this week only from Monday until today. The same with LastWeek, only Monday though Sunday previous week.

        With LastMonth I would only like to see day 1-30 (or 31) for previous month.

        Is this possible at all?
        Originally posted by Freddan101 View Post
        Just sent you a PayPal donation for tonights pints. Have a couple of nice ones and keep up the great work.
        Thanks very much. OK I understand. I'll take a look when I can.
        Jon

        Comment


        • Originally posted by Freddan101 View Post
          When I think of Week I would like to show this week only from Monday until today. The same with LastWeek, only Monday though Sunday previous week.

          With LastMonth I would only like to see day 1-30 (or 31) for previous month.

          Is this possible at all?
          I've sent you a PM with a new version to try.
          Jon

          Comment


          • Looking real good. Thanks a lot. I don't have that much data to test with but I've attached a few screenshots.

            I got an idea when playing around with the graphs. Instead of This/Last, would it be possible to use Day, Week, Month, Year as ChartTimeFormat and then set how many complete periods to display using ChartTimeStart/ChartTimeFinish?

            For example Day and 3/0 would show data from three days back starting 00:00 and ending now. Week and 2/1 would show data from two weeks back starting Monday 00:00 and ending last week Sunday 23:59. Year and 1/1 shows data from Jan 1 00:00 last year until Dec 31 23:59 last year.
            Attached Files

            Comment


            • Yes, that sounds feasible. Let me see what I can do.
              Jon

              Comment


              • OK, I've sent you a new version to try. Check your PM.
                Jon

                Comment


                • Originally posted by mrceolla View Post
                  Thank you for the reply, Jon.

                  Bummer about the transparency too.

                  Thanks again!
                  When I release V1.0.19,you will have the option to define up to 8 custom palettes with optional transparency. I've also updated the PlotColor so you can add transparency via that route too.
                  Jon

                  Comment


                  • V1.0.19 has now been released

                    V1.0.19 has now been released.

                    Changes since V1.0.17

                    Added MaxYSources and MinYSources to allow selected data sources to determine the maximum and baseline values on a chart.

                    Added 'ThisWeek', 'LastWeek', 'ThisMonth', 'LastMonth', 'DaySpan', 'Weekspan', 'MonthSpan', 'YearSpan' to the ChartTimeFormat setting.

                    New Ini section [CustomPalette] added. This allows the definition of up to eight custom palettes with optional colour transparency values.

                    Added the option to add colour transparency to the PlotColor setting.
                    Jon

                    Comment


                    • Many thanks, Jon. The ChartTimeFormat additions are of great help.

                      I have tested a few varieties and all look great except "Weekspan 3-3" which spans over two months. The first date is not displayed on the x-axis. I first thought is was because that there wasn't enough space but "Weekspan 1-1" looks ok.
                      Attached Files

                      Comment


                      • Thanks, I'll check out Weekspan 3-3 later this week.
                        Jon

                        Comment


                        • Originally posted by Freddan101 View Post
                          Many thanks, Jon. The ChartTimeFormat additions are of great help.

                          I have tested a few varieties and all look great except "Weekspan 3-3" which spans over two months. The first date is not displayed on the x-axis. I first thought is was because that there wasn't enough space but "Weekspan 1-1" looks ok.
                          Weekspan 3-3 is correct. That covers a period from 31st October to 6th November when you created that chart. It's just not showing the 31st October label but has been plotted.
                          Jon

                          Comment


                          • Yes, but what is the reason the label is not shown? The other graphs look ok.

                            Comment


                            • Originally posted by Freddan101 View Post
                              Yes, but what is the reason the label is not shown? The other graphs look ok.
                              It is all automatic so if it decides it cannot fit the label, it won't. I have no control of this. A larger chart may help.
                              Jon

                              Comment


                              • Nice work on the new release, Jon. I haven't installed it yet but I'm excited to see what you added in terms of colors and transparency. Sounds like it is exactly what I was looking for.

                                I'm having an issue with my Area plot types. As you may recall, my goal was to produce a background type effect for these data sources since they are all on/off sources. I'm using your new MaxYSources/MinYSources option to achieve this along with plot type 1, Area. Since temps could go below 0 F and above 100 F, I created virtual devices where On is 120 and Off is -35. All looks good until another data point drops below 0. Then the Area plots flip their shading. I understand why this is but is there any way to change this behavior? Is there some way to have these sources or plot types treat -35 as their 0 as far as their rendering/placement is concerned?

                                FYI, My -30 degree temp is from WeatherXML. WeatherUnderground API is giving everyone grief. I have my ini setup to limit everything to -30 otherwise it would be -999.

                                Thanks!
                                Attached Files
                                HomeSeer 3, Insteon, Z-wave, USB-UIRT, Google Hub/Chromecasts/Smart Speakers, Foscam cameras, Amcrest camera, RCA HSDB2a doorbell
                                Plugins: BLLAN, BLOccupied, BLUSBUIRT, Chromecast, Insteon, Jon00 Homeseer/Echo Skill Helper, Jon00 DB Charting, MediaController, NetCAM, PHLocation2, Pushover 3P, weatherXML, Z-wave

                                Comment

                                Working...
                                X