Announcement

Collapse
No announcement yet.

Jon00 Database Charting Utility for Homeseer 3 & Homeseer 4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by jon00 View Post
    Looks good. Did you try the updated chart style setup page?
    Yes, I loaded it I think its working better. thanks.

    I did notice there are two styles named "Modern White Step Line Chart": style 18 & style19. is that intentional, or did I mess up one of the names?
    Mark

    HS3 Pro 3.0.0.534
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

    Comment


    • Jon,
      are there any analysis capabilities on the data logged?

      for instance, if i capture a temperature every 5 minutes all day long, can i graph the average temperature by hour?
      Mark

      HS3 Pro 3.0.0.534
      Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
      Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
      Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

      Comment


      • Originally posted by mnsandler View Post
        Yes, I loaded it I think its working better. thanks.

        I did notice there are two styles named "Modern White Step Line Chart": style 18 & style19. is that intentional, or did I mess up one of the names?
        18 should be Modern White Column Chart. It is wrong in the ini file.

        Originally posted by mnsandler View Post
        Jon,
        are there any analysis capabilities on the data logged?

        for instance, if i capture a temperature every 5 minutes all day long, can i graph the average temperature by hour?
        Not really. All you could do is create a chart to show the last hour of data. Then set SaveLastValues to 1 (search the docs) which will then write the Max/Min/Average/Total/Max/Max-Min/Current values for that chart in the ini file. Finally you would need to use the average ini data to form a new chart updated just past the hour.
        Jon

        Comment


        • Originally posted by jon00 View Post
          I've also added more debug code to the routine that has caused some errors to see if I can pinpoint the issue.

          It looks like the watchdog I incorporated many versions ago could never have worked (silly mistake). This monitors the connection to HS3. Those with stability issues, please give this one a try.
          I just installed 1.1.3 and will let you know if I run into any issues. Thanks!

          FYI: I did encounter the issue again under 1.1.1. This is what appeared in the /HomeSeer HS3/Bin/Jon00DBChart/Errorlog.txt
          Code:
          2017-02-11 16:45:21.339	Watchdog activated - Restarting plugin
          2017-02-11 16:46:22.549	Error in OnTimedEvent: System.NullReferenceException: Object reference not set to an instance of an object.
             at System.Runtime.Remoting.Messaging.LogicalCallContext.PropagateIncomingHeadersToCallContext(IMessage msg)
             at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
             at HomeSeerAPI.IHSApplication.SystemUpTimeTS()
             at Jon00DBChartingHS3.Form1.橠ᛗⅫ晠एᄚ㳟�(Object ㊑ᡀ䡌鲞泿ถ乑烍, ElapsedEventArgs ␭䜐趤ꦠ뱵ꥻ擁)
          2017-02-11 16:46:23.505	Error in OnTimedEvent: System.NullReferenceException: Object reference not set to an instance of an object.
             at System.Runtime.Remoting.Messaging.LogicalCallContext.PropagateIncomingHeadersToCallContext(IMessage msg)
             at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
             at HomeSeerAPI.IHSApplication.SystemUpTimeTS()
             at Jon00DBChartingHS3.Form1.橠ᛗⅫ晠एᄚ㳟�(Object ㊑ᡀ䡌鲞泿ถ乑烍, ElapsedEventArgs ␭䜐趤ꦠ뱵ꥻ擁)
          The "Error in OnTimedEvent" repeated every half second until I manually killed the charting exe. What's strange to me is that it looks like HS3 restarted itself about 3 minutes after the above watchdog error occurred (based on looking at the HS3 log which shows the full set of startup entries including plugins, etc.). There's no indication of what caused it to restart. I didn't even think HS3 could auto-restart itself like that - that's the first time I've ever seen that happen (though I've only been using HS3 for a couple months now).

          Comment


          • Jon,
            how does the plot order related to the colors selected from a given palette theme?

            i created a custom palette but the chart doesn't seem to follow the order of the colors i specified

            Custom palette 1: red,darkorange,green,blue,violet,purple,brown,cyan
            Attached Files
            Mark

            HS3 Pro 3.0.0.534
            Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
            Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
            Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

            Comment


            • Originally posted by mnsandler View Post
              Jon,
              how does the plot order related to the colors selected from a given palette theme?

              i created a custom palette but the chart doesn't seem to follow the order of the colors i specified

              Custom palette 1: red,darkorange,green,blue,violet,purple,brown,cyan
              false alarm. i figured out the issue. i had a color override in the chart defintion.
              Mark

              HS3 Pro 3.0.0.534
              Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
              Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
              Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

              Comment


              • jon,
                the number of data points in the below pic doesn't match the number of rows displayed
                Attached Files
                Mark

                HS3 Pro 3.0.0.534
                Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                Comment


                • I'm not sure. I cannot replicate it here. On my databases, the total tallies with the number of metrics displayed.
                  Jon

                  Comment


                  • Originally posted by jon00 View Post
                    I'm not sure. I cannot replicate it here. On my databases, the total tallies with the number of metrics displayed.
                    i'll try reinstalling the charting.asp page and see if that fixes it. the count seems to be off for everything in my system. I just started a new database, it only has one 1 entry (I verified the data), but the chart reports 2.


                    Second question:

                    if I collected 1 data item and then save the data at 2/18/17 23:59:59. how do I get it to display on a chart on 2/17 & 2/18? the chart seems to want to display it on 2/18 & 2/19
                    Attached Files
                    Last edited by mnsandler; February 19th, 2017, 06:04 PM. Reason: added graph
                    Mark

                    HS3 Pro 3.0.0.534
                    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                    Comment


                    • The only thing it could be is some extra code I had to put in to get around a known bug where one the metrics from the SQLite database range was not plotted in .NET charting.

                      2nd question....not sure.You may need to record the metric at 23:59:58 and use and end time of 23:59:59
                      Jon

                      Comment


                      • Originally posted by jon00 View Post
                        The only thing it could be is some extra code I had to put in to get around a known bug where one the metrics from the SQLite database range was not plotted in .NET charting.

                        2nd question....not sure.You may need to record the metric at 23:59:58 and use and end time of 23:59:59
                        Jon, I have the latest Jon00DBCharting.asp files. what else can I check to resolve this 'total datapoint' count issue

                        On #2, all ChartTimeFormat options seem to want to include the time component on the x-axis. Would it be possible to add a special ChartTimeFormat, that would truncate the time component from the datestamp of the database entries and plot them against the date component only?

                        update: I tried setting AxisX Interval Type: Days, but it doesn't change anything.
                        Last edited by mnsandler; February 20th, 2017, 10:49 AM. Reason: I tried setting AxisX Interval Type: Days, but it doesn't change anything.
                        Mark

                        HS3 Pro 3.0.0.534
                        Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                        Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                        Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                        Comment


                        • Unless I can replicate the issue, it is very difficult to fix. Whatever I do here produces the correct number of datapoints.

                          The x-axis time format is set using the AxisXFormat setting. Search the docs for this setting.
                          Jon

                          Comment


                          • Originally posted by jon00 View Post
                            Unless I can replicate the issue, it is very difficult to fix. Whatever I do here produces the correct number of datapoints.

                            The x-axis time format is set using the AxisXFormat setting. Search the docs for this setting.
                            can I send you my database and see if you have the same issue?
                            Mark

                            HS3 Pro 3.0.0.534
                            Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                            Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                            Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                            Comment


                            • jon, i made the following example in excel. can i get a column chart in your plugin to look like this? specifically the x-axis where the column and x axis labels are between the ticks
                              Attached Files
                              Last edited by mnsandler; February 20th, 2017, 03:52 PM. Reason: IntervalOffset
                              Mark

                              HS3 Pro 3.0.0.534
                              Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                              Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                              Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                              Comment


                              • Originally posted by mnsandler View Post
                                can I send you my database and see if you have the same issue?
                                Originally posted by mnsandler View Post
                                jon, i made the following example in excel. can i get a column chart in your plugin to look like this? specifically the x-axis where the column and x axis labels are between the ticks
                                I can probably take a look over the weekend but I will also need your ini files. Send them to me (your) Friday evening.

                                Regarding column charts, I don't think you can. The columns automatically align at the start of the Y axis.
                                Jon

                                Comment

                                Working...
                                X