Announcement

Collapse
No announcement yet.

Jon00 Database Charting Utility for Homeseer 3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Jon,

    That does the trick, I am now getting the correct values in the axis...


    Thanks!!

    Wim
    Attached Files
    -- Wim

    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
    650 devices ---- 336 events ----- 40 scripts

    Comment


    • Good stuff!

      It is amazing how many bugs still come from regional settings!
      Jon

      Comment


      • Originally posted by mwaite View Post
        Humm, that's interesting! I don't know how I could have it configured wrong if all I need is Timer=0 in Jon00DBCharting.ini.
        Mike,

        Would you contact me via email. I want you to try a small change to the code for the device triggering issue. I cannot replicate the issue here.
        Jon

        Comment


        • Originally posted by jon00 View Post
          Mike,

          Would you contact me via email. I want you to try a small change to the code for the device triggering issue. I cannot replicate the issue here.
          email sent.
          Mike

          Comment


          • Looks like we have found the issue with Mike's setup. Will post an updated version in a day or two.
            Jon

            Comment


            • Has anyone had any problems with the plugin with the recent upgrade to HS3? I tried to install the plugin and I can't get it to execute. I get no errors in the log and when I click the exe nothing happens. I know I was getting errors on the scheduler.dll in HS and it was recommended to run as administrator. I tried changing the charting exe as well and nothing happens?

              Comment


              • Did you update the 3 Homeseer dll files in the exe folder?
                Jon

                Comment


                • I got the most current files. I update HS before installing the plugin so I assumed it would be the newest?

                  Comment


                  • Just found this log in the folder:

                    2015-01-18 13:54:02.974 Jon00 Database Charting Error Log
                    2015-01-18 13:54:02.975 Error in ReadCreateIni Block 1: System.NullReferenceException: Object reference not set to an instance of an object.
                    at System.Runtime.Remoting.Messaging.LogicalCallContext.Propaga teIncomingHeadersToCallContext(IMessage msg)
                    at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Mess ageData& msgData, Int32 type)
                    at HomeSeerAPI.IHSApplication.WaitSecs(Double secs)
                    at Jon00DBChartingHS3.Form1.????????(String ????????)
                    2015-01-18 13:57:04.717 Error in ReadCreateIni Block 1: System.NullReferenceException: Object reference not set to an instance of an object.
                    at System.Runtime.Remoting.Messaging.LogicalCallContext.Propaga teIncomingHeadersToCallContext(IMessage msg)
                    at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Mess ageData& msgData, Int32 type)
                    at HomeSeerAPI.IHSApplication.WaitSecs(Double secs)
                    at Jon00DBChartingHS3.Form1.????????(String ????????)

                    Comment


                    • Did you install the supplied 6 ini files in the Homeseer config directory?
                      Jon

                      Comment


                      • I deleted everything and put the files back from the download zip and it worked first time here (on .152)
                        Jon

                        Comment


                        • I deleted everything and started over. Even downloaded it again. Still nothing happens. I confirmed that the INI files are in place.
                          Attached Files

                          Comment


                          • Can you also post a screenshot of your Bin\Jon00DBChart folder please.
                            Jon

                            Comment


                            • Here you go
                              Attached Files

                              Comment


                              • Looks fine. It created the database file which is correct.

                                Go to your device management page and tick "Utility" under the floor filter, "Jon00 DBChartDemo" under the Room filter and "Virtual" under the Device Type filter. Do you see any charts?

                                Also can you confirm you still have your default user account?
                                Jon

                                Comment

                                Working...
                                X