Announcement

Collapse
No announcement yet.

Jon00 Database Charting Utility for Homeseer 3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • The file is there and the last time it was modified is today 18th of June 20:28 local time but the chart there displays straight lines while Jon00DBCharting.asp show some trends in the data.

    BTW:
    Both charts (Temp and Hum.) looks the same HS3\html\images\jon00\dbchart even though they should represent different data.(chart001.png chart002.png)

    Regards,

    hadyos

    Comment


    • Right, you need to define the timespan to something different as it is still set to 2 minutes.

      As you are using Timer11 (1 minute) you need to change the following in Jon00DBCharingCreate.ini:

      ChartTimeStart=2

      This is set to 2 minutes so you would only see 2 plots which is just a straight line.

      If you set this to ChartTimeStart=20 then you should get 20 plots on the chart.

      Read page 9 onwards in the docs to understand the various timespan settings.
      Jon

      Comment


      • I set the Chart time Startup to 20 and the chart style 13 (Line Chart) for both data sources and I still see straight lines and same numbers for both Temp. and Hum. It looks like only data from DBTable 1 is being ploted and even then it's only straight lines.

        How would you set up the ini's if you want to show trends of Temp and Hum. in various place in the House?

        Thanks,
        hadyos

        Sent from my A0001 using Tapatalk

        Comment


        • Remember if you are displaying indoor temperature or humidity over a short period, it is very unlikely to change much (if at all) and you would still get straight lines on the chart.

          Try creating a chart over a 12 hour period.

          Use:

          ChartTimeStart=720

          For a Line Chart you need to use Chartstyle=4
          Jon

          Comment


          • if I use ChartStyle=4 I get this chart
            Attached Files

            Comment


            • OK, you are now trying to display 720 data points on the chart.

              Chartstyle 4 has the "show values" and "Markers" on by default hence the mess.

              Open up Jon00DBChartingStyle.ini and under [ChartStyle4] change


              MarkerType=6,6,6,6,6,6,6,6,6,6
              ShowValues=1,1,1,1,1,1,1,1,1,1

              To:

              MarkerType=4,4,4,4,4,4,4,4,4,4
              ShowValues=0,0,0,0,0,0,0,0,0,0

              See if that improves things.
              Jon

              Comment


              • Look much better now.

                Is there any rule of how to decide on a number MarkerType and ShowValues?

                Thanks a million, you've been great help.

                Comment


                • It is the number of data points you want to plot that determines whether you should use markers and/or values.

                  Unfortunately there is a relationship with the update frequency of the database versus the time span you wish to display.

                  In your case, you could setup a second database that recorded the Temp/Humidity every 30 minutes. In this situation, creating a chart over 24 hours would relate to 48 data points and would easily benefit from markers and/or values. This will still show trends as metrics such as indoor/outdoor temp/humidity do not widely fluctuate.

                  Using your original database which updates every minute, you can create charts for each hour, therefore giving better detail of small trends. These would display 60 data points so again suitable for markers etc.

                  Another method would be to set the database timer to 0. In this instance, the database will only update when there is a value change for the first metric being recorded i.e. the device set under Data1=XXXXXX. That way you will always record a change but with far fewer data points being logged.
                  Last edited by jon00; June 22nd, 2015, 05:09 AM.
                  Jon

                  Comment


                  • Hi Jon,
                    I love your program. I do have a rookie question.

                    What commend do I use to store a string value to the database?


                    Click image for larger version

Name:	Jon.PNG
Views:	1
Size:	19.2 KB
ID:	1179240

                    Ray

                    Comment


                    • Try using the following (change the Data number to suit)

                      Data1=$dtnr:238||1

                      Look at page 13 in the docs which gives more details of this method.
                      Jon

                      Comment


                      • New error

                        Hi Jon,

                        I get this error lately and charts stopped to be produced.

                        2015-06-24 15:03:19.198 Jon00 Database Charting Error Log
                        2015-06-24 15:03:19.198 Error in CreatePage Block 1: System.DivideByZeroException: Attempted to divide by zero.
                        at System.Decimal.FCallDivide(Decimal& d1, Decimal& d2)
                        at System.Decimal.Divide(Decimal d1, Decimal d2)
                        at Jon00DBChartingHS3.Form1.栞閅撩ꆤ㬎无岿(Object 䠤㯑镾䪓뙈棂勢ᙟ)
                        2015-06-24 15:03:33.948 Error in CreatePage Block 1: System.DivideByZeroException: Attempted to divide by zero.
                        at System.Decimal.FCallDivide(Decimal& d1, Decimal& d2)
                        at System.Decimal.Divide(Decimal d1, Decimal d2)
                        at Jon00DBChartingHS3.Form1.栞閅撩ꆤ㬎无岿(Object 䠤㯑镾䪓뙈棂勢ᙟ)

                        Any idea why?

                        Regards,
                        hadyos

                        Comment


                        • In Jon00DBCharting.ini, have you set any of the DataXMultiplier= values to 0?
                          Jon

                          Comment


                          • No, can't see any parameter like that.

                            hadyos

                            Comment


                            • When do you see this error appear? When you call up the web page?
                              Jon

                              Comment


                              • There is a file under Jon00DBChart folder named Errorlog, there and only there I see this error.

                                It started when I didn't see any Temp chart in the virtual device status then I checked the logs and then I saw that there were a file named Errolog in the mentioned folder, but in the last 12 hours the error stopped and I can see the chart again (before I only saw an empty rectangle in the virtual device status).

                                Comment

                                Working...
                                X