Announcement

Collapse
No announcement yet.

Jon00 Database Charting Utility for Homeseer 3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bob,

    Would you please list the files you currently have in your \Bin\Jon00DBChart folder.
    Jon

    Comment


    • Jon00,
      Here is a snapshot:
      Attached Files

      Comment


      • Most odd....Can you search your entire drive to see if you have a jon00dbchartingdemo.db3 file somewhere?
        Jon

        Comment


        • Jon00,
          No file by this name on the C Drive!

          I'm on a Win7 system and when you start a program on the Task Bar, the area around the Icon "lights" up and stays that way until the program is terminated. When I click on your "multi-color bar chart" icon, it lights up for 5 or 6 seconds then fades(the icon stays in the system tray and I exit the program there. Question: Does the fading icon background indicate any malfunction? I see the program running in the Windows Task Manager.

          Thanks again for the help,
          BobSpen

          Comment


          • No, that's fine. The only issue is that it appears not to be creating the demo database file for you.

            Rather than the demo, read the docs to set it up as it should be used normally. It should create another database file for that.
            Jon

            Comment


            • Jon00,
              Acts the same with a new chart. Creates the device, shows the legends(Data Labels) but chart is blank, and "updates"(last change date increments) with timer. Also no DB file is created.

              BobSpen

              Comment


              • Bob,

                Attached is a blank db3 file for normal use. Drop this in to your Homeseer 3\Bin\Jon00DBChart folder. Stop the plugin and restart. See if it updates or not.

                Also check that this folder has not been set to read only by mistake.
                Attached Files
                Jon

                Comment


                • Jon00,
                  When I unzip your attachment, it was a file named "attachment.php". How do I get a .db3 file? Can you send an unzipped .db3?
                  Thanks,
                  BobSpen

                  Comment


                  • Originally posted by BobSpen View Post
                    Jon00,
                    When I unzip your attachment, it was a file named "attachment.php". How do I get a .db3 file? Can you send an unzipped .db3?
                    Thanks,
                    BobSpen
                    Just rename the file to attachment.zip, then you can open it.
                    Mike

                    Comment


                    • Mike,
                      Thanks, learn something every day!
                      BobSpen

                      Comment


                      • Jon00,
                        Put the .db3 file in and started program. Not updating and chart is still blank. The "device" is still getting a new "last change date" every 15 seconds(which is what I set for this trial). There is no data in the table either.

                        thanks,
                        BobSpen

                        Comment


                        • Hi Jon,

                          2 questions please...

                          1. Whenever I restart HS3 (not Windows), the plugin does not reconnect to HS automatically. I have to exit the exe and relaunch. Is there a solution for this? I have, on occasion, had to restart HS remotely (quicker and safer than rebooting IMHO), only to find out later my charts are dead.

                          2. I didn't hear back from you re: max data value fix. I know you said you were going to get to it later that evening, and I had mentioned no rush, so I was just waiting a bit. Then I realized perhaps you did update the exe. So I re-downloaded the same link via email today. The file size is 994 KB (1,017,856). Can you confirm this is the newest? (the version info on the file always show 1.0.0.0).

                          Thanks!
                          Mike

                          Comment


                          • Originally posted by BobSpen View Post
                            Jon00,
                            Put the .db3 file in and started program. Not updating and chart is still blank. The "device" is still getting a new "last change date" every 15 seconds(which is what I set for this trial). There is no data in the table either.

                            thanks,
                            BobSpen
                            Bob,

                            I've run out of ideas. If there was an error, there would be an error log file created.
                            Jon

                            Comment


                            • Originally posted by mwaite View Post
                              Hi Jon,

                              2 questions please...

                              1. Whenever I restart HS3 (not Windows), the plugin does not reconnect to HS automatically. I have to exit the exe and relaunch. Is there a solution for this? I have, on occasion, had to restart HS remotely (quicker and safer than rebooting IMHO), only to find out later my charts are dead.

                              2. I didn't hear back from you re: max data value fix. I know you said you were going to get to it later that evening, and I had mentioned no rush, so I was just waiting a bit. Then I realized perhaps you did update the exe. So I re-downloaded the same link via email today. The file size is 994 KB (1,017,856). Can you confirm this is the newest? (the version info on the file always show 1.0.0.0).

                              Thanks!
                              1) If you shutdown Homeseer, can you confirm that the exe continues to run? It should terminate whenever HS is not running.

                              2) I did send you an email stating I had updated the file. Obviously you never received it. The version number is always displayed in the Homeseer log on startup and should be V1.0.9.3
                              Jon

                              Comment


                              • Originally posted by jon00 View Post
                                1) If you shutdown Homeseer, can you confirm that the exe continues to run? It should terminate whenever HS is not running.
                                It's not terminating when I shutdown HS. I know this USED to work, don't know what's changed, other than several versions of the exe have been replaced.

                                Originally posted by jon00 View Post
                                2) I did send you an email stating I had updated the file. Obviously you never received it. The version number is always displayed in the Homeseer log on startup and should be V1.0.9.3
                                Build shows good, thanks!
                                Mike

                                Comment

                                Working...
                                X