Announcement

Collapse
No announcement yet.

Jon00 Database Charting Utility for Homeseer 3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fair enough.
    Will give it a go.
    Cheers John.

    Comment


    • Originally posted by jon00 View Post
      For the internal watchdog to kick in indicates a poor connection to Homeseer. It may be caused by other plugins communicating at the same time but I really don't know the architecture of HS3 to make proper judgment.

      You can turn off the Watchdog which may assist if this is just a temporary blip.

      Open up Jon00DBCharting.ini and find the [Settings] heading.

      Change/add the following:

      Watchdog=0
      Didn't help Jon

      The taskbar icon for the exe now stays on the taskbar however the problem is that the exe still actually keeps running (at 0%) in Task Manager so I can't even detect that its stopped running properly and restart it automatically. It will stay completely stalled until its restarted.

      Otherwise everything's working but obviously I'm getting massive gaps in the charts that are being created.

      Every straight line below is when the exe has stopped. At the end of each is when I've noticed its stalled state, ended the exe task and then restarted the exe.

      Might there be anything else I could try
      Attached Files

      Comment


      • You are the only one to report this so it does point to something with your setup. How many plugins are your running?

        The charts suggest that this is happening at 7:00am? Do you have Windows update enabled for a 7:00am restart or something else around this time?
        Jon

        Comment


        • Originally posted by jon00 View Post
          You are the only one to report this so it does point to something with your setup. How many plugins are your running?

          The charts suggest that this is happening at 7:00am? Do you have Windows update enabled for a 7:00am restart or something else around this time?
          14 Plugins, machine is rock solid.

          I hadn't noticed it happening around 7am TBH. It appeared to happen every few hours. Appreciate that its probably something on my system but have no idea what that could be.

          I'll disable some of the less used plugins and test it for a day or two.

          Comment


          • Take a note of the times this happens (look at the chart data) and see if a pattern emerges.
            Jon

            Comment


            • Is there a way to capture and email a chart?

              Hi Jon00
              Is there a way to capture, store temporarily and email a chart created by your charting utility plug in? For example, save a chart to a png or jpg file that I could attach to an email?

              Update: SOLVED. Reading the documentation helped (of course). This package is exceptionally powerful. Thank you Jon! I am able to create a custom png file and email it.
              Last edited by jono; February 4th, 2017, 10:48 PM. Reason: update

              Comment


              • jon00dbsetup.asp and the ini file

                Hi Jon
                Whenever I open jon00dbsetup.asp and try to configure a new database, it can mess up my other existing databases. Specifically it will change configurations in Data1, Data2, etc to address entries from other databases. Interestingly, Data1Label, Data2Label are never affected, nor any other fields as far as I can tell.
                It is an easy fix to just go to the underlying ini file and correct the entries. But at least on my set up, opening up jon00dbsetup.asp is just causing problems.
                In case it helps, I have no issues with the Chart Creation Setup (jon00dbsetup1.asp) in terms of messing up prior charts.

                Comment


                • I cannot reproduce this. I've just setup another test database via the web interface and none of the other database sources have been affected. Can you go through the steps you do to cause this issue?
                  Jon

                  Comment


                  • Is there a way to recover deleted chart styles?

                    Hi Jon
                    I have inadvertently deleted several chart styles and I'm interested in recovering them. Is there an easy way to do that?
                    I believe that the jon00setup2.asp page has the default "Enter" key activating the Delete Chart Style button. I thought I was "submitting" but ended up deleting.

                    Comment


                    • Not unless you have a backup.

                      Please note that you do not need to use the submit button in normal use. Once you change a field, it is updated automatically.
                      Jon

                      Comment


                      • Originally posted by jono View Post
                        Hi Jon
                        I have inadvertently deleted several chart styles and I'm interested in recovering them. Is there an easy way to do that?
                        I believe that the jon00setup2.asp page has the default "Enter" key activating the Delete Chart Style button. I thought I was "submitting" but ended up deleting.
                        This is also the case on the Jon00dbsetup.asp page. The Enter button deletes the database.

                        Comment


                        • Originally posted by jon00 View Post
                          Not unless you have a backup.

                          Please note that you do not need to use the submit button in normal use. Once you change a field, it is updated automatically.
                          Yes, I know and even recall reading it in the directions. I have clearly been doing it without thinking. I enter data and inadvertently hit return!

                          Can I do a complete reinstall and then just replace my Jon00DBCharting.ini file on the new installation?

                          Or is there somewhere I could just get a copy of the default Jon00DBChartingStyle.ini? I was just starting to work with it when I deleted several styles.

                          Comment


                          • By enter, you mean the submit button?

                            I've tried it several times and cannot reproduce any of the problems you have raised. Frustrating.
                            Jon

                            Comment


                            • Right, I can reproduce this when you press return. Not sure I can prevent that as it messes with the parameters sent to the page.

                              Just re-download and extract the respective ini file.
                              Jon

                              Comment


                              • Originally posted by jon00 View Post
                                I cannot reproduce this. I've just setup another test database via the web interface and none of the other database sources have been affected. Can you go through the steps you do to cause this issue?
                                So it appears that what is happening is that changing on database on the Jon00dbsetup page changes entries on the other database pages. So for example, lets say I have 3 databases: Temperatures with 9 entries, Lights with 2 entries,and UPS with 2 entries. If I go change the purge days on the UPS database, I find the two UPS database entries appear in the Data1 and Data2 for the Temperatures database and the Lights database, but only on the pulldown for the setup page. If I go to the temperatures database pulldown on the setup page and change any entry, it then changes the database ini so UPS data appears in my temperatures database for Data1 and Data2.

                                So changing the UPS pulldown pages changes the other pulldown pages, but it only affect ini once another value on the other pull down pages is changed.
                                Does that make sense?
                                Thanks as always for the incredible work you do. I find your applications incredibly valuable!!

                                Comment

                                Working...
                                X