Announcement

Collapse
No announcement yet.

Jon00 Database Charting Utility for Homeseer 3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by reggs11 View Post
    14 Plugins, machine is rock solid.

    I hadn't noticed it happening around 7am TBH. It appeared to happen every few hours. Appreciate that its probably something on my system but have no idea what that could be.

    I'll disable some of the less used plugins and test it for a day or two.
    Originally posted by jon00 View Post
    Take a note of the times this happens (look at the chart data) and see if a pattern emerges.
    It appears to be the number of plugins that I'm running.
    If I keep just 4 enabled then Jon00DBChartingHS3.exe runs fine.

    I've tried different combinations and it doesn't appear to be any individual plugin. Once I get over approximately 4 the exe stops working after a couple of hours.

    I don't believe that I'm running a particularly high number of plugins and can get by with:
    BLBackup, BBLED, CM15A, Z-Wave, Global Cache, HSTouchServer, Nest, Pushover, RFXCom, Sonos, weatherXML

    Once I enable 4 or 5 in pretty much any combination the exe eventually appears to lock up.

    I'm running an Intel i5 4690K with 16GB of DDR3 memory so I don't think my machine is under powered.

    Any thoughts on this Jon?

    Comment


    • I've never seen this before. It can only be instability on the plugin communication port which is causing the loss of connection. I really have no answer as to how this can be solved.

      You could download CurrPorts and set the filter to:

      include:both:tcpudp:10400

      This will show all application connections on the plugin port. Refreshing it from time to time may show changes (highlighted in green) which would be disconnects.
      Jon

      Comment


      • Originally posted by fcol View Post
        Any suggestions on how to receive an alert when the .exe locks up and/or the dbcharting Error Log starts swelling? I have jon00's Log Monitor but I don't see anything in the HS3 log that corresponded to this issue. Perhaps I could use jon00's File Watcher?
        Here is how I get notifications when the charts "stop":
        1) I have Jon00's set up generate a HS Device which is the chart
        2) I have a periodic event that runs at half the rate the charts is updating and runs a small script that checks to see that the "device last change" time is changing. If not--ALERT

        I'm running Win10 with latest release HS3 and, very infrequently, something happens in Win10 which stops Jon00's .exe and I cannot restart without a complete reboot.

        BobSpen

        Comment


        • Feature request

          Jon
          I love this feature rich package. If you are considering additional feature requests, may I suggest that on the Device List page where the device is shown (i.e. Utility Jon00 DBChart Chart 002), could you please add a button to the Control section that hyperlinks to the full size chart? For most other devices, this section is used for on or off or dim buttons. Those are not relevant to charts so that section is empty. But a link to show the full size chart would be of great interest, at least to me.
          Thanks for considering it.
          Jono

          Comment


          • Originally posted by BobSpen View Post
            Here is how I get notifications when the charts "stop":
            1) I have Jon00's set up generate a HS Device which is the chart
            2) I have a periodic event that runs at half the rate the charts is updating and runs a small script that checks to see that the "device last change" time is changing. If not--ALERT

            I'm running Win10 with latest release HS3 and, very infrequently, something happens in Win10 which stops Jon00's .exe and I cannot restart without a complete reboot.

            BobSpen
            That's a great idea, thank you.
            I can easily track now when things lock up.
            Will have to figure out how to auto-restart the exe when it does.

            Comment


            • Originally posted by jono View Post
              Jon
              I love this feature rich package. If you are considering additional feature requests, may I suggest that on the Device List page where the device is shown (i.e. Utility Jon00 DBChart Chart 002), could you please add a button to the Control section that hyperlinks to the full size chart? For most other devices, this section is used for on or off or dim buttons. Those are not relevant to charts so that section is empty. But a link to show the full size chart would be of great interest, at least to me.
              Thanks for considering it.
              Jono
              No buttons but in the next version, you will be able to click on the virtual device chart to get a full size version.
              Jon

              Comment


              • V1.1.3 is now available

                Changes since 1.1.12:

                Added button on the three charting setup pages to the dynamic charting web page.
                Added hyperlink on the virtual device charting image to show it in a new page/tab in its native size.
                Corrected bug with the chart style copy function which also renamed other entries.
                Corrected error with Watchdog code.

                Read the Readmefirst.txt file in the download.

                I've also added more debug code to the routine that has caused some errors to see if I can pinpoint the issue.

                It looks like the watchdog I incorporated many versions ago could never have worked (silly mistake). This monitors the connection to HS3. Those with stability issues, please give this one a try.
                Jon

                Comment


                • Jon, thanks for the quick update. the hyperlink feature is great. And the extra button makes it very easy to navigator to the various pages.

                  would it be difficult to add an ini option to "disable the auto submit" every time one makes a change on any of the plugin setup pages? i wouldn't mind just pressing the Submit button once i make all my changes. thanks for the consideration.
                  Mark

                  HS3 Pro 3.0.0.435
                  Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                  Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                  Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                  Comment


                  • That would be a lot of work.
                    Jon

                    Comment


                    • Originally posted by jon00 View Post
                      That would be a lot of work.
                      Jon,

                      I'm still having problems when I edit chart styles. I made a new copy of one but it seems like the auto submit is causing values from the new template to be copied to the original during the refresh.
                      Mark

                      HS3 Pro 3.0.0.435
                      Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                      Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                      Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                      Comment


                      • Originally posted by mnsandler View Post
                        Jon,

                        I'm still having problems when I edit chart styles. I made a new copy of one but it seems like the auto submit is causing values from the new template to be copied to the original during the refresh.
                        Download the package again but just replace the Jon00DBSetupASP.vben file. Hopefully this time the issue should be resolved.

                        As you are spending so much time on the chart style setup pages, perhaps you can post some of your creations?
                        Jon

                        Comment


                        • Originally posted by jon00 View Post
                          No buttons but in the next version, you will be able to click on the virtual device chart to get a full size version.
                          Works great! Thank you Jon.

                          Comment


                          • Originally posted by jon00 View Post
                            Changes since 1.1.12:
                            It looks like the watchdog I incorporated many versions ago could never have worked (silly mistake). This monitors the connection to HS3. Those with stability issues, please give this one a try.
                            No lock-ups at all with the new version Jon. Great stuff

                            Comment


                            • Originally posted by jon00 View Post
                              Download the package again but just replace the Jon00DBSetupASP.vben file. Hopefully this time the issue should be resolved.

                              As you are spending so much time on the chart style setup pages, perhaps you can post some of your creations?
                              Here is the one I spent the most time customizing the stacked column chart template copy I made.
                              Attached Files
                              Mark

                              HS3 Pro 3.0.0.435
                              Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                              Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                              Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                              Comment


                              • Looks good. Did you try the updated chart style setup page?
                                Jon

                                Comment

                                Working...
                                X