Announcement

Collapse
No announcement yet.

Jon00 Homeseer/Echo Skill Helper for Homeseer 3 & Homeseer 4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    yes that works.

    Comment


      I just tried to create a new response trigger. Nothing happens after I click new trigger, in my browser (firefox as well as chrome) its just spinning, trying to load the page. I restarted HS3, and then it loaded the IP:Jon00Alexa1.aspx page again, but when I tried to create a new trigger its just spinning round trying to load the page again. Going back to another page, then trying to load the IP:Jon00Alexa1.aspx page and nothing happens, it wont load the page. The Alexa helper is still functioning, just the page wont load.

      The pages do load, but they are taking a few minutes to load. Normally they only take a fraction of a second

      Comment


        No idea on that one. Nothing has changed in months. Just tried to add a new response trigger and it works fine here.
        Jon

        Comment


          It was slow for a few hours. Then back to normal. Very strange. Bit frustrating when you try to program things, lets hope it stays as it is now.

          Comment


            I have just found this and I am trying to setup a trigger for different rooms with echos and sonos echos in them. I am having a hard time understanding how to identify the echos. I have setup a Trigger setup like in your docs to identify the echos but when I ask Alexa to identify she doesn't say anything. I am really confused about this. Any help would be appreciated.

            Comment


              Open up Jon00Alexa.ini in a text editor,

              Search for the section [DeviceID]

              If everything has worked beforehand, you should see very long string(s) which ends with =-

              Just identify the string with the echo used (from the HS Log) and then change =- to =Kitchen (or whatever room you want to call it).

              Do the same with other Echo's.

              Save and it will show up in the settings page.

              Remember this uses the skill which you have to say "Alexa, Tell Homeseer to....."
              Jon

              Comment


                There isn't anything under the [DeviceID]. I did say "Alexa tell Homeseer to identify your location". Sometimes she will respond with where Homeseer is located. Sometimes she will just beep and the ring will flash. Either way, nothing is being entered into the config file.

                Comment


                  This is how I have it setup.

                  Click image for larger version

Name:	screencapture-192-168-1-15-8000-Jon00Alexa-html-2020-10-03-13_30_38.png
Views:	97
Size:	100.6 KB
ID:	1423820Click image for larger version

Name:	screencapture-192-168-1-15-8000-Jon00Alexa-html-2020-10-03-13_30_52.png
Views:	96
Size:	86.3 KB
ID:	1423821

                  Comment


                    Just reading the top post and you say it uses Homeseer Home Automation Skill. My homeseer skill is called Homeseer SmartHome. I don't have to say Ask Homeseer.......

                    I am in Canada. Does this not work here?

                    Comment


                      I know some people from Canada have the Homeseer Home Automation skill but it maybe because they have created USA Amazon accounts as well. If the skill is not available then the only option is to create your own. Links to most of the instructions have been placed in the first post of this thread but I don't know if they now work.
                      Jon

                      Comment


                        I upgraded to HS4 a couple of weeks ago and am still tacklng the fallout. Almost have everything fixed that broke. Jon00Alexa helper is the last thing. It's weird because I'm 95% sure it worked at first, but now I only get "that Device was not found" when asking Alex to tell homeseer about the jon00Alexa commands. And I lost the Jon00 tab. Thoughts on bringing it back?

                        Comment


                          Park the helper to one side for the moment.

                          Go to your scripts directory and rename check_vcmd2.vb to something else.

                          Then confirm that the Homeseer Home Automation Skill is working. Info Here: https://homeseer.com/amazon-alexa-integration/

                          Once confirmed working we can move forward.
                          Jon

                          Comment


                            Renamed the file. Alexa "tell homeseer" integration working as expected.

                            Comment


                              Ok so I looked at my log and saw that a script I have set to run every two minutes (super simple script that updates a global string variable) was throwing some kind of system error 'cannot find scheduler.dll' and weird stuff. So, I shutdown hs4 and just started it back up, and voila my little script is running fine and so is Jon00Alexa.... I really don't like magic....

                              I do still have problems pulling up the jon00alexa.html page. It takes 20 seconds or so to think about it and then gives me: Timeout from host. Also, if I can resolve that, what is the easiest way to get it added to my menu bar?

                              Note, I recall with HS3 that pulling up the html page was only about 50/50, but if it is supposed to be more stable than that, let me know what I need to do! Its a great utility.

                              Comment


                                If you got the scheduler.dll message, you may be starting HS4 incorrectly.

                                What OS are you running HS4 on? Can you call up /Test.aspx correctly?

                                To add links to the HS4 menu, your only easy option is to use Jon00 Links for HS4: https://forums.homeseer.com/forum/3r...for-homeseer-4
                                Jon

                                Comment

                                Working...
                                X