Announcement

Collapse
No announcement yet.

Web page builder for Homeseer 3 & Homeseer 4

Collapse
This topic is closed.
X
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by jon00 View Post
    It looks like the other two columns are the issue.

    See if this works.

    For all three columns change to:

    <span style='display: inline-block; width: 300px; max-width: 300px;'>[your tag]</span>
    Works for the colums, but the text in the Right colum is displaying outside the pagewidth.
    Here is the code for last column:
    Code:
    Column1Section3-1Right=<span style='display: inline-block; width: 300px; max-width: 300px;'>Været om 8 timer<br>[deviceimage,1230]<br>[devicetext,1237]</span>

    Comment


      Add this to the span:

      overflow:hidden;
      Jon

      Comment


        Originally posted by jon00 View Post
        Add this to the span:

        overflow:hidden;
        Perfect - Tnx!

        Comment


          Hey Jon,

          Would it be possible to add a delay parameter on the EventRefresh or ScriptRefresh Buttons that allow for a delayed page refresh? A delay parameter in seconds would be ideal with default 0.

          The reason I ask is that I have one page that takes over 22 seconds to build and another that takes a few seconds. Instant page refresh doesn't work for those pages.

          I tried working around this by adding a wait statement in my events and scripts, but that doesn't do the trick.

          Having just spent hours getting one page to work right, I can very much appreciate your time and effort invested in your scripts/plugins. Thanks.

          Comment


            Originally posted by prsmith777 View Post
            Hey Jon,

            Would it be possible to add a delay parameter on the EventRefresh or ScriptRefresh Buttons that allow for a delayed page refresh? A delay parameter in seconds would be ideal with default 0.

            The reason I ask is that I have one page that takes over 22 seconds to build and another that takes a few seconds. Instant page refresh doesn't work for those pages.

            I tried working around this by adding a wait statement in my events and scripts, but that doesn't do the trick.

            Having just spent hours getting one page to work right, I can very much appreciate your time and effort invested in your scripts/plugins. Thanks.
            Have a look at the ButtonRefreshTime setting in the docs.
            Jon

            Comment


              Originally posted by jon00 View Post

              Have a look at the ButtonRefreshTime setting in the docs.
              Turns out I was running 1.0.4 and had no idea this was implemented in the later version. Works as expected. Thanks again.

              Comment


                Is it possible to create something with the webpagebuilder that lists all the battery levels of all the devices? But not entering every device manually. Like a wildcard?

                Comment


                  No, it would have to be manually.
                  Jon

                  Comment


                    Originally posted by deloosem View Post
                    Is it possible to create something with the webpagebuilder that lists all the battery levels of all the devices? But not entering every device manually. Like a wildcard?
                    Take a look at a battery monitor Plug-in by SDJ; I think it scans looking for "Battery" and includes in the monitor list---good way to keep track of battery devices.

                    Comment


                      Originally posted by jon00 View Post
                      No, it would have to be manually.
                      Thx I just looked at it but it is way too complicated. I basically need something that sets the device type to Z-Wave Battery in thedevice-management page.
                      But quickly. So I just was looking into a quick way of seeing the battery levels without having to change the group/function/device type drop-down lists.

                      Comment


                        One option is to download my device viewer and documenter. You can filter on many parameters/search so you should be able to just show your batteries by selecting 'All' under 'Select by Name' and entering 'battery' in the search box. It has a device view like the device management page and direct links to each device. The good thing is that you can save your search parameters as a webpage shortcut so you don't have to select again. https://forums.homeseer.com/forum/3r...wer-documenter
                        Jon

                        Comment


                          Hi jon

                          i have 2 questions,
                          • is it possible to add an rtsp stream ?
                          • I having issue stretching an image with embedrefresh.

                          if i add it like this :

                          this shows the image streched like i want
                          <center><img src="http://192.168.1.6:8080/cgi-bin/getliveimage.cgi?sid=XXXXXXXXXXXXXXX&ch=1?"Height=400 Width=610></center>

                          but when adding the embed refresh it won't stretch at all..
                          <center>[embedrefresh,10000,http://192.168.1.6:8080/cgi-bin/getl...800,610,0,0,2]


                          regards
                          Preferred -> Jon's Plugins, Pushover, Phlocation, Easy-trigger,
                          Rfxcom, Blade Plugins, Pushbullet, homekit, Malosa Scripts




                          HS3Pro 4.1.14.0 on windows 10 enterprise X64 on hp quadcore laptop 8 GB.

                          Comment


                            To display a RTSP stream, you would need to generate a web page served by HS with the necessary code to decode it. You can then embed that page in page builder.

                            The embed function creates an iframe which size is set by the parameters. It does not change the defined URL in any way.
                            Jon

                            Comment


                              HS4 style and menus.

                              Hi
                              I was very happy to succeed in migrating my Jon00-webbuilder pages for HS4, I really depend on these pages.
                              Thanks again John, I just cannot believe that Homeseer-team never catches-up with the great improvements you made with your plugins ans scripts.

                              I still have a problem with the style and menus, Having the old HS logo and style showing, and no menu.
                              Here is the beginning of my .ini
                              [Settings]
                              Guestview=0
                              PageTitle=l'e-maison
                              PageWidth=1500px
                              PageCenter=0
                              ColumnNumber=2
                              Column1Width=50%
                              Column2Width=50%
                              Column3Width=
                              Column4Width=
                              PageRefresh=0
                              PageRefreshTime=10
                              RemoveLogoBar=0
                              UseFooter=0
                              ClassTypeHeader=
                              ClassTypeSubHeader=
                              ClassTypeLeft=
                              ClassTypeMiddle=
                              ClassTypeRight=
                              ClassTypeButton=
                              ButtonSize=10
                              UseStylesheet=0
                              CSSName=
                              HeadData=
                              BodyData=
                              Appendini=

                              Thank you again and cheers

                              Click image for larger version

Name:	FireShot Screen Capture #005 - '' - http.png
Views:	205
Size:	94.4 KB
ID:	1414430
                              Visit zee e-maison : http://www.e-maison.com

                              Comment


                                Unfortunately, to maintain compatibility with HS3, that is how HST have implemented the page header in HS4. You see this on all the HS3 legacy pages. Basically they use a different style sheet for HS4 and something called bootstrap.

                                I have corrected this in other packages by the means of a html wrapper page. Please download Jon00 Links for HS4 and extract _events.html and place in your html directory

                                Copy and rename it to something else (say builder.html) and then open it up in a text editor. Find src="/Events" and change it to src="/Buildpage.aspx?val=qv" or whatever ini is in use.

                                Finally call /builder.html in your browser and you will see your page plus the HS4 menu structure.
                                Jon

                                Comment

                                Working...
                                X