No announcement yet.

HS 2.0 Support

  • Filter
  • Time
  • Show
Clear All
new posts

    HS 2.0 Support

    Are you planning on supporting HS 2.0 with this plugin?

    Have you tested it yet with the private alpha and beta releases?

    HomeSeer 2, HomeSeer 3, Allonis myServer, Amazon Alexa Dots, ELK M1G, ISY 994i, HomeKit, BlueIris, and 6 "4k" Cameras using NVR, and integration between all of these systems. Home Automation since 1980.

    I tested many plugins with the Alpha build and I believe the ADIOcelot is one of them. I have no plans to recode ADIOcelot in .NET and will use the COM interop. I'll be running the ADIOcelot as a distributed xAP app and that is another possible option for others to avoid any compatibilty issues.


      Michael, have you done any more tests with the latest betas?
      Hardware: i5-6400T w/16GB RAM & SSD w/HS3Pro, Z-Net, Harmony Hub x2, Echo Dot x2, Ocelot
      Plugins: Z-wave, HSTouch, BLBackup, Harmony, GTS CPUXA, UltraMon3, Nest
      HSTouch: Multiple Android Devices; 5 x ToteVision MD-1001 10.1" Win 7 Tablets
      Devices: Cooper RF9501 x4, RF9517 x6, RF9534 x1, RF9540-N x7, RF9542 x1, RF9542-Z x2, RFHDSCG x1, RFWC5 x5; Intermatic HA02 x6; FortrezZ MIMOLite x3; Leviton VRPD3-1LW x4, VRR15-1LZ x6; Nest Tstat & 9x Protects; Dragon PD-100 x3, PA-100 x3


        1) ADIOcelot - update posted
        2) mcsXAP - updated, not posted
        3) mcsTemperature - update posted
        4) mcsAudrey - update posted
        5) mcsSprinklers - update posted
        6) mcsMusic - update posted
        7) mcsMovement - update posted
        8) mcsDeviceGrid - update posted
        9) mcsMenu - HS1 Only
        10) mcsEnvrionment - updated, not posted
        11) mcsFutureX10IR - HS1 Only
        12) WebAgent - HS1 Only
        13) All scripts - no evaluation or updates

        I run ADIOcelot as an xAP node on a different computer and this has no dependency on the Homeseer version


          Update for HS2.0?

          I see you put down "Update Posted" for HS2.0 but I don't see it in the 2.0 Updater, so wanted to check.

          I am running 1.9.5 under HS2.0 with only a trivial new error every 5-6 minutes in the log of:
          <TABLE cellSpacing=2 cellPadding=0 width="100%" border=0><TBODY><TR><TD class=LOGDateTime0 noWrap align=left></TD><TD class=LOGType0 align=left colSpan=3>ADIOcelot </TD><TD class=LOGEntry0 align=left colSpan=8>Timer3 Line 660 StackOverflowException</TD></TR></TBODY></TABLE>

          I went back to my 1.7 logs to check and did not find this, so apparently it arrived with 2.0.



            1.10.0 and later are the HS2 versions and are available at the top of this subforum. The stack overflow was not something that I saw when running under HS2 so it may be something different than was addressed by the changes that have been made.


              Originally posted by Michael McSharry

              I run ADIOcelot as an xAP node on a different computer and this has no dependency on the Homeseer version
              How do you do this?


                The xAP version of ADIOcelot is posted in the xAP subforum of mcs plugins and scripts. There is a document included with it that I think describes the setup.

                In essence I use my xAP plugin as my Homeseer IR, X10, and one IO interface. Its job is to route Homeseer X10, IR, and specific IO onto the LAN using an xAP protocol. The result of this is that these Homeseer interfaces are now distributed across the LAN and any application or hardware that understands xAP will receive the message and can act upon it. The same happens in the opposite direction where an application on the LAN starts a transaction such as notification that an X10 signal has just been received.

                The xAP version of ADIOcelot is simply the ADIOcelot plugin that talks xAP rather than Homeseer SDK. It also has a browser interface for setup administration and to get a view the current state of stuff within the ocelot.

                There is an xAP plugin posted in the xAP 3rd party plugin section. It should be able to provide the X10/IR/IO conduit as mine does, but I do not know for certain.


                  Stack Overflow

                  I am also getting the same stack overflow error messages.


                    Line 660 is the callback to HS when the ocelot detects IR. This seems to be a HS2 interop-type problem. If I hear about any changes with callbacks in HS2 then I will address it. Until then not much I can do.

                    callback.IREvent iLocation


                      I'm seeing a couple of warnings regarding use of GetDevice in HS2 log file that I think are associated with Adiocelot plugin v1.11.2. I see the warnings on startup/initialization of the plugin and after I do a disconnect/reconnect from the ocelot.

                      the log snippet below is typical of the entry that I see.
                      7/19/2005 10:47:51 PM ~!~ADIOcelot~!~Using Comm Port 2
                      7/19/2005 10:47:51 PM ~!~ADIOcelot~!~Found CPU-XA/Ocelot
                      7/19/2005 10:47:52 PM ~!~ADIOcelot~!~Ocelot IR size: 1024
                      7/19/2005 10:47:54 PM ~!~ADIOcelot~!~Unit found: SECU16 Addr: 1
                      7/19/2005 10:47:54 PM ~!~ADIOcelot~!~Unit found: SECU16I Addr: 2
                      7/19/2005 10:47:54 PM ~!~ADIOcelot~!~Unit found: SECU16 Addr: 5
                      7/19/2005 10:47:55 PM ~!~WARNING~!~GetDevice is not reliable for device enumeration. Please use the new GetDeviceEnumerator method.
                      7/19/2005 10:47:55 PM ~!~WARNING~!~GetDevice is not reliable for device enumeration. Please use the new GetDeviceEnumerator method.



                        Now that I look at the code I see that I only updated it to the HS2 Alpha. I thought that I had done all of them to Beta, but I guess not.


                          I went through and updated the plugin to what I remember needs to be done for HS2. I cannot get into HS2 after the private betas so I'm not able to test. I'm posting it here if someone wishes to play with it.
                          Attached Files


                            The errors are gone and it's working well for me.

                            It does look like you left some debug statements in. On startup there are many of these:
                            7/20/2005 9:50:01 PM ~!~ADIOcelot~!~hsDeviceExists [1 Line 30

                            on a disconnect/reconnect it logs the following:
                            [disconnect here]
                            7/20/2005 10:20:14 PM ~!~ADIOcelot~!~hsDeviceExists [1 Line 30
                            7/20/2005 10:20:14 PM ~!~ADIOcelot~!~LoadVariablesMatrix Progress=0 Line 180
                            [reconnect here]
                            7/20/2005 10:20:26 PM ~!~ADIOcelot~!~hsDeviceExists [1 Line 30
                            7/20/2005 10:20:26 PM ~!~ADIOcelot~!~LoadVariablesMatrix Progress=0 Line 180
                            7/20/2005 10:20:30 PM ~!~ADIOcelot~!~Using Comm Port 2



                              I was able to get into HS2 public beta and saw device object errors such as you see in your log. They are not debug, but error reports whenever the device object is being referenced. It is something that changed between build 1938 private beta and the public one. It occurs with each of my plugins that use the new HS2 method DeviceExistsRef.

                              You may be functional, but dont add or delete I/O and variables otherwise you may have a mess.