Announcement

Collapse
No announcement yet.

Please help an idiot!!! Variable Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Please help an idiot!!! Variable Problem

    Hi

    I am trying ( really hard ) to change the value of a variable via the web interface...

    Problem : My wife forgets to arm the alarm system that I have builted with my ocelot.

    Solution 1 : Change wife : too expensive... tried it once....
    Solution 2 : Arm by internet....

    So I need to change variable 9 from value 0 ( not arm ) to 2 ( full Arm )

    I am trying to use a single line script but it is not working...

    I am using Adiocelot plug in and if needed my variable name is : "Mode Armement" and the homeseer ID is "#10"

    Please can you provide a step by step procedure for me

    Thanks

  • #2
    If you haven't gotten this yet (just noticed this post)- there are a few ways to do it. Were you looking to do it from an event or from a script?

    a single line script would be
    &hs.SetDeviceValue "#10",2
    or
    &hs.SetDeviceValueByName "Mode Armement,2

    jim

    Comment


    • #3
      OK, fine, i tried and it is working IN HOMESEER....

      the variable is not changing in the ocelot memory ( because event are suppose to triger when variable state change )

      So, the data showing in Homeseer work, but dosen't change in ocelot.

      Like an other exemple....

      Sprinkler work in mode 1 for the flowers only, mode 2 full lot and mode 0, dosent work.

      The event wait @ 3h00AM to see what mode I want, if > then 0, action depend of the mode selected....

      I change the value from 0 to 1 and at 3h00, it dosen't work... I have to suspend homeseer, go in CMAX to change the value and resume homeseer to make it work....

      So, thank you Jim... but how do you make it change in the ocelot memory....

      Again, I have tried MANY things, but look like I don't understand it...

      Can it be done by a single line command or do I have to write a script...

      Thanks

      Luc

      Comment


      • #4
        No, it does work - I cut/pasted that line from one of my events that I know works.

        If you goto the setup page for Adiocelot on the general/variables tab, make sure that the Interface Name is set to "ADIOcelot" and not "Applied Digital Ocelot".
        jim

        Comment

        Working...
        X