Announcement

Collapse
No announcement yet.

Adioocelot Setup

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Adioocelot Setup

    I cannot seem to access the config page. From the HS log page, I get an error "Select menu 40" and from the inerface page , I get an error "ConfigIO - Calling ConfigIO for ADIOcelot". I have had this plugin for a year and have never got it to work. I have tried after reinstalling HS with both vers. 2.2 and 2.3. Any help would be appreciated.

  • #2
    I can describe what I did on a fresh install of both HS 2.3 and ADIOcelot

    1. Updater to download ADIOcelot
    2. Restart HS
    3. Setup / Interfaces / ADIOcelot click Other, click Save
    4. Move windows so center of desktop is visible
    5. Click Config for ADIOcelot, ADIOcelot form appears at center of screen
    6. Close ADIOcelot setup form
    7. Click ADIOcelot, Setup from HS Menu/Log page
    8. Close ADIOcelot setup form

    The above shows that the setup can be reached from either the HS browser or from the HS menu/log

    Comment


    • #3
      Thanks for your help, but no, after reinstalling HS and adioocelot yet again, I still get the error "calling Config io for adioocelot.

      Comment


      • #4
        I added some log outputs at the ConfigIO call from HS in the attached as shown below.

        Code:
        Public Sub ConfigIO()
                  On Error GoTo Error_Exit
                  hsWritelog PLUGIN_NAME, "ConfigIO"
        10        If USE_AS_PLUGIN Or gParentIsStandalone Then
                  hsWritelog PLUGIN_NAME, "ConfigIO Load Form"
        20            Load FrmConfig
                  hsWritelog PLUGIN_NAME, "ConfigIO Show Form"
        30            If HS2 Then
        40                FrmConfig.Show vbModal
        50            Else
        60                FrmConfig.Show 'vbModal
        70            End If
        80        Else
        90            On Error Resume Next
        100           CreateObject("xapmcsAdiOcelot.Application").GetPlugins(1).ConfigIO
        110           If Err.Number <> 0 Then
        120               Err.Clear
        130           End If
        140       End If
                  hsWritelog PLUGIN_NAME, "ConfigIO Exit"
        
        Normal_Exit:
        170       Exit Sub
        Error_Exit:
        180       hsWritelog PLUGIN_NAME, "ConfigIO"
        190       Resume Normal_Exit
        End Sub
        Unzip the contents into the Homeseer 2 folder and see what you get.

        Another idea is that the hspi_adiocelot.exe is not registered. From a DOS window and at the Homeseer 2 folder type the command "hspi_adiocelot.exe /regserver" without the quotes. You may then need to close it down with Task Manager
        Last edited by Michael McSharry; November 29th, 2008, 07:23 PM.

        Comment


        • #5
          Thank you for the reply Michael, I replaced the file in Homeseer and recieved the following errors...
          Calling Config io for adiocelot
          config io 0
          Config io load from 0
          Config io 20
          I do not understand how to register the plugin, I tried from a dos promt but it did'nt work. Can you plese explain in more detail? Thanks alot for your help. Jim

          Comment


          • #6
            The plugin is registered as it is being called.

            The error is a result of the inability to load a form. The first code statement on load event was not executed. It looks as if you are running on a Server OS rather than an interactive one or running as a service.

            Comment


            • #7
              OK............ What does that mean? I have the HS program loaded onto a Pro100 from HST. Do you mean it looks like a HS / Pro-100 issue? What do I need to do? Thanks, Jim

              Comment


              • #8
                I do not know what the next step would be. It may be the case that some of the VB form functionality support was not loaded with the embedded XP. If you are running as a service rather than an application then that may be the cause. There is not much else I can do from the debug perspective as the problem has been traced down to statement 20 in what I posted. HST would have better insight, but there is not much motivation on their part since they already supply an Ocelot plugin. Your easiest solution is just to use the one available from HST.

                Comment

                Working...
                X