Announcement

Collapse
No announcement yet.

Ocelot Error on Initialize

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by dallison View Post
    Hi Stef,

    Well - I have setup my config to reflect what you're using.
    Still not having any luck.. Just to clarify.. So when you are setting
    port 5002 for port 3 of the Quatech, what's the port show within
    your virtual ports under your device manager for your serial ports?
    My ports show as 11 through 14. I'm using port 2 of the Quatech
    which is mapped to port 12 under device manager. So setting port
    5001 under xAPmcsOcelot should work? I have the xAP hub running.
    Weird as all I can open under xAPHub is the view traffic option.

    So are you able to use the Quatech/Ocelot for IR at all? or are
    you just using the secu16 input stuff?

    again, many thanks for all your help-
    In my device manager, the port is showing as "Ethernet Serial Port (COM7)". All the other are labeled like this: "Serial Port 1 of QSE-100 as 192.168.0.150 (COM19)"...

    If you right-click on the mcsAdiOcelot icon on the taskbar in the bottom right and select GUI Setup, a dialog box will appear. In the connectivity frame, I have 192.168.0.150 in the field "Serial Comm IP" and 5002 in the "Serial Comm Port" field.

    Comment


    • #17
      Hi Stef-
      You have infinite patience...

      I was able to get all working ..! (thanks to your help)
      I didn't realize that I needed mcsxAP and mcsAdiOcelot..
      The IR tab went away when I disabled mcsAdiOcelot so I realized that
      I needed this as well for IR to work. Once I re-enabled it the IR tab
      came back. But then the traffic monitor via mcsxAP complained about
      missing a project file after it found and attached to the SDS port successfully.
      So I figured out that I needed to load an ocelot project IR file to get it
      to understand and send IR successfully. I can't tell you what a relief it was
      to see the red IR light on the ocelot lighting on IR send.. Now I guess the
      dilemma is how to do IR learn.. I guess worst case would be to disconnect
      and direct connect the Ocelot to the HS server for IR learn..

      What fantastic coding by Michael on all the xAP stuff.

      Stef - I owe you a drink.. look me up if you're ever in S. Cal

      Thanks again,
      -Derek

      Comment


      • #18
        Thank you for the drink!

        When I'll be ready to teach the Ocelot some IR codes, I will connect it directly.

        I have a long cat5 cable and since I'm using DB9-RJ45 adaptors between the Ocelot and the QSE-100D, I only have to connect my long cable to the adaptor on the Ocelot and to a serial port on my pc. My cable is about 50 feets and it could be longer.

        Another thing, my pc is on a UPS in case we loose electricity. My Ocelot and QSE are not since they are elsewhere and I don't want to buy another UPS. So when we loose power, the mcsAdiOcelot crash and I have to do a kill and restart in order to fix it.

        Comment


        • #19
          If I connect to the Ocelot/CMAX through the SDS using the "normal"
          connect option it seemed to work.. although I haven't tried to learn
          any IR this way yet. It sounds like you don't trust it and are direct
          connecting to learn IR? I have two of the Quatech SDS's running now
          One for a WGL W800 and HAI RC80 thermo(still working on getting it to
          work with the SDS and RC80) and the other SDS for AV IR control
          and eventually one in the garage for use with the WGLRain8Net controller.
          Can't beat 28$ for the Quatech SDS and not having to run any wiring
          or worry about wireless headaches.

          I'm curious if you use any kind of blast IR emitters in your IR setup?
          I really don't like the stick on local ones as they inhibit local control
          of AV as they seem to block the IR signal from the remotes..

          I have a UPS on my HS server as well.. but don't on most else..
          costly proposition to put them everywhere I would need them.
          I'm about to put in a whole house surge protector at the electrical box to
          help with any spikes.

          Comment


          • #20
            It's not that I don't trust to connect to the Ocelot/CMAX through the SDS using the "normal" connect option.

            I tried it and it look like it's working. I can see my SECU16i and the SECU16IR. The TX and RX are blinking.

            When I click on the learn button in C-MAX, a red box pop-up. I press a button on my remote facing the Ocelot and nothing happen. The red box used to close in the past but it stay. If I try to send that IR, my emiter don't flash...

            I will eventualy try a more direct connection. Avoiding the QSE to learn IR code. That way, I will be able to use the other ADIOcelot plugin and learn the IR from the HS Infrared web page. That way, it will be easyer to edit the IR codes labels.

            I paid my QSE 25$ each on eBay. It will eventualy allow me to move my server anywhere.

            I'm using a mixe of Xantech, Channel Vision and Buffalo IR devices. It was a mistake. I should have bought from only one company. Xantech use 12v and Buffalo 5v...

            I use stick on emitters. I have receivers so the signal get to the equipement even if the emitters are partialy blocking IR windows.

            You must also know that you can't simply connect the Ocelot IR out the a Xantech (or other) network. You have to use either a Global Cache GC-CGX or build yourself a small circuit like I did. That circuit is easy to build and you will find everything on Appdig forum. The creator of the circuit is Guy Lavoie. You will also find blaster schema on that forum.

            I hope you understand my english! I'm french speaking.

            Comment


            • #21
              I had assumed English was your 1st language.. I live in S. California where
              Spanish is a big language. I wish my Spanish was as good as your English is!

              My IR learn through the SDS/CMAX seems to work as I can learn the command
              and send it to the AV components.. But I'd rather use HS to do so as
              it would be more descriptive to use. I agree on using the Ocelot w/
              a direct connection and use the ADIOcelot plug-in to do IR learn. probably
              what I'll do as well.

              My stuff is all Xantech at this point - other than two channel vision modulators to server video from the surv. cameras. I had read the article you mentioned
              on building the circuit but had purchased a Xantech connecting block with
              the diodes, etc. built into it to transmit IR via breakout. Worked very well..
              I agree the IR receivers are a good route for local control as well.. I'm cheap
              and tried to go w/out them. I wonder what the cost comp. of blast emitters
              vs. receivers would be? Do you use the HSTouch plug-ins as your front-end
              or something else?

              Comment


              • #22
                Do you know the model number of your connecting block? I'm looking for a cleaner solution.

                Yes, I'm using HSTouch. My screens are in constant evolution. I'm currently controling my lighting (mix of Leviton DHC dimmers, X10 modules and Insteons), my Elk M1 security panel, audio/video devices and my home theater receiver with RS232. IR control is cool but RS232 control is very cool!!!

                People are amazed when I show them what I can do with my iPhone.

                Comment


                • #23
                  The Xantech model is 789-44.. As I mentioned though I was only doing
                  single zone IR. I don't use the secuIR breakouts either.
                  I wish I could afford the HSTouch stuff.. two kids in private school and one
                  in expensive pre-school.. not much money for toys these days
                  I'd love to use my I-Phone with the HSTouch software.. I can only imagine
                  what you're able to do with it. The Elk1 secur panel... I'd love to hear
                  what your experience with it? I have been looking at it for awhile as an
                  alternative to my DS10 solution which if flaky at best. I wonder if you
                  can PM via this board.. our post if becoming quite long!
                  I agree RS232 control is very cool.. I love RF control as well.. my WGI
                  W800 is bullet proof.. never locked up in the 9 or so years I've had it.

                  I have to say the Z-wave stuff is intriguing as well.. I am using the
                  HS Z-troller and introducing devices slowly.. so far very reliable and
                  "excellent" signals from slave to slave.
                  Attached Files

                  Comment


                  • #24
                    Direct connexion QSE-100D to Ocelot

                    Hi everybody,

                    This last week was a week of lots power outage from our utility compagny. All of them were lasting less than 3 seconds. Only a few of them reseted our alarm clock... But all of them had the mcsxapADIOcelot plugin crashing.

                    So I decide to give another try to a direct connexion between the QSE-100D and the Ocelot.

                    And this time, I got it working.

                    My step:

                    1 Deactivate in HS setup interface: mcsXap (only if you don't use for something else)
                    2 Activate the ADIOcelot plugin with the serial port number.
                    3 In the QSE-100D Web setup page, choose the port number of the Ocelot and set it to operating mode "Normal" and save.
                    4 restart HS.

                    In my case that's all I've done and now, I can send IR and learned new code from the Infrared HS page.

                    I don't know why it was'nt working the first time. But now it is!

                    Comment


                    • #25
                      Stef -

                      Still doesn't work for me this way..
                      Your outages must of done something magical to your setup

                      I'm assuming the other settings are still the same?
                      port setting via ADIOcelot = 5000 (on 1st port of the SDS)
                      port setting via setup page Quatech = 3 (my virtual PC port)
                      No XAP Hub running, mcsXAP not running.

                      I still get "timeout looking for CPU/Ocelot 0" errors" on plug-in
                      intial.

                      I restarted the Quatech, Ocelot, HS just to make sure.
                      I didn't reboot the HS server though. I'm thinking of trying this
                      on a different server as well just to see..

                      If you discover anything else please let me know.. for sure an easier
                      way to manage IR this way..

                      maybe I should simulate power outages by pulling the plug 3 or 4 times.. HA!

                      Thanks for the post -

                      Comment


                      • #26
                        I'm still thinking that the the port that would make sense to use
                        via the port setting via the ADIOcelot would be the vitual port
                        via the "ports" of device manager not the "5000" which is the actual
                        port of the SDS. otherwise how does it know which SDS to redirect
                        to..(mult SDS setup) I think for me this is part of why the XAP stuff was working as
                        it allows an IP address to be set for the mcsXAP redirect thus not
                        using the port set at all. A confirmation of this for me is when I set
                        the 5000 port via ADIocelot I get the "timeout looking for.." error, when
                        I set port 3 or virtual port I get a different error but it seems to connect
                        to the SDS anyway..

                        Comment


                        • #27
                          I think we should do a Skype session. It would be easier to compare our config.

                          If you have a Skipe account, PM me your id.

                          Comment

                          Working...
                          X