Announcement

Collapse
No announcement yet.

Setup using DS9097U?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Setup using DS9097U?

    I'm trying to get either the one wire plugin or mcs temperature to work. (only one at a time )
    How do I select the DS9097 as the input for temp readings?
    The plugin will only open the comm port if it is specified in the temp 05 box, (I only have a DS9097)
    The buttons in the lower right of the setup screen don't seem to do anything with the DS9097.
    I've tried internal and scripts in the drop down box with no success.

    Thanks
    Warren

    #2
    The way is suppose to work with the DS9097U is to select Internal Data Collection and put the comm port number in the DS9097 box and the update interval in the DS9097 box below it. The device parameters section has a box for number of DS temperature sensors to use and the House code of the virtual device into which the data will be transfered. These all need to be filled-in.

    The buttons you refer to are mostly for the Temp05 interface. There are very few bells and whistles for supporting the DS9097. The plugin will poll the 1-wire bus at the interval you specified, transfer to the virtual devices, then transfer to the database.

    The TMEX drivers are needed, but should be automatically downloaded if you do not already have them.

    I'm making a significant change in the user setup since the current setup screen if quite confusing. When I get over this hurdle I might be able try the DS9097U on a virgin computer and see what setup problems may exist on clean installs with the DS9097.

    If you've tried what I suggested in the first paragraph and it does not work for you, then I suggest waiting until I can look into it.

    Comment


      #3
      With the plugin set up as you describe I get this error in HS log:
      InitHW: Object variable or With block variable not set.

      I get this when the comm setting for the temp 05 is nulled out.

      Warren

      Comment


        #4
        I have error traps in each function and I do not see use of any objects in inithw, except the hs object. The function's code is here. You can send me you mcsTemperature.ini file and I can see if I can replicate the problem.
        <pre class="ip-ubbcode-code-pre">
        Function InitHW(port As Long) As String

        On Error GoTo Error_Exit
        If gX10Enabled Or gIREnabled Or gIOEnabled Then
        ' called already, just exit
        Exit Function
        End If

        databaseSchemaIsBeingChanged = False

        InitINIVariables
        GetPluginTriggers
        GetPluginTriggersFlag = False
        WebTemp = hs.GetAppPath & "\HTML\~mcsForecast.txt"

        ' InitDevices
        DSCommPortOpened = False
        If LCase(hs.GetINISetting("Temperature", "InternalDataCollection", "False", "mcsTemperature.ini")) = "true" Then
        If Temp05CommPort &lt;&gt; "" Then
        InitCommPort
        End If
        If DS9097CommPort &lt;&gt; "" Then
        DSCommPortOpened = Not OpenDSCommPort
        End If
        End If

        WindGust = 0
        InitHW = ""
        Normal_Exit:
        Exit Function
        Error_Exit:
        hs.writelog "Temperature Plugin", " InitHW: " & Err.description
        Resume Normal_Exit
        End Function
        </pre>

        Comment


          #5
          Thanks
          Warren

          Comment


            #6
            I assume that you are now collecting data after the java vm was installed?

            You are the first to admit to using mcsTemperature with the DS9097 so your feedback is valuable to work out any initial introduction problems.

            The libraries provided by DallasSemi have an acknowledged problem when trying to do Analog conversions from VB. This means that mcsTemperature is not able to process the wind direction, humidity, and baro sensors at this time. The C libraries handle this properly and my current plan is to make a wrapper in C that be accessed from VB to handle this deficiency. This will be my first time trying to do something like this so ...

            Comment


              #7
              Michael,

              I was thrown off with the plugins because the one wire viewer worked without the java vm.

              The DS9097 is working on this computer ok now with the One Wire Interface plugin.

              There is a problem with the get_temp scrip.
              After the first run of the script, the comm port locked up. Shutting down and restarting HomeSeer didn't help as you can see from the log below. One wire viewer could not access it either.
              I had to reboot the computer to get the comm port back.


              First try...

              1/13/2003 4:49:38 PM~!~startup~!~Initializing I/O
              1/13/2003 4:49:38 PM~!~Temperature Plugin~!~Register callback completed
              1/13/2003 4:49:39 PM~!~startup~!~Done Initializing I/O
              1/13/2003 4:49:39 PM~!~Info~!~Web Server started on port 8001
              1/13/2003 4:49:39 PM~!~Info~!~Local IP address is: 192.168.2.24
              1/13/2003 4:49:39 PM~!~startup~!~Initializing voice recognition
              1/13/2003 4:49:40 PM~!~startup~!~Done Initializing voice recognition
              1/13/2003 4:49:40 PM~!~startup~!~Initializing text to speech
              1/13/2003 4:49:40 PM~!~startup~!~Done Initializing speech
              1/13/2003 4:49:40 PM~!~startup~!~Initializing Telephone Interface
              1/13/2003 4:49:41 PM~!~startup~!~Waiting for HomeSeer Phone to start up ...
              1/13/2003 4:49:44 PM~!~Speak~!~HomeSeer Phone is Ready
              1/13/2003 4:49:45 PM~!~startup~!~Done Initializing Telephone Interface
              1/13/2003 4:49:45 PM~!~Info~!~Script engine version: 5.6.7426
              1/13/2003 4:49:45 PM~!~Speak~!~Welcome to Home Seer
              1/13/2003 4:49:59 PM~!~Info~!~ Web Server authorized login successful from: 127.0.0.1
              1/13/2003 4:51:39 PM~!~Debug~!~Adapter: {DS9097U} Port: COM2
              1/13/2003 4:51:41 PM~!~Error~!~Script error in file: get_temps.txt: -2147467259:com.dalsemi.onewire.adapter.OneWireIOException: Invalid temperature data! in line 82
              1/13/2003 4:53:04 PM~!~Event Trigger~!~Trigger from menu (Tempurature reading)
              1/13/2003 4:53:20 PM~!~Error~!~Script error in file: get_temps.txt: -2147467259:com.dalsemi.onewire.OneWireException: 1-Wire Net not available in line 64
              1/13/2003 4:55:22 PM~!~Info~!~Application shutdown now...

              Second try...

              1/13/2003 4:55:23 PM~!~Info~!~Web Server stopped
              1/13/2003 4:55:33 PM~!~startup~!~Done Loading Settings
              1/13/2003 4:55:33 PM~!~Info~!~HomeSeer version is: 1.6.0
              1/13/2003 4:55:33 PM~!~startup~!~Loading config file
              1/13/2003 4:55:34 PM~!~startup~!~Done Loading config file
              1/13/2003 4:55:34 PM~!~startup~!~Restoring device status
              1/13/2003 4:55:34 PM~!~startup~!~Initializing X10 Interface 2
              1/13/2003 4:55:34 PM~!~startup~!~Done Initializing X10
              1/13/2003 4:55:34 PM~!~startup~!~Initializing Infrared Interface
              1/13/2003 4:55:34 PM~!~startup~!~Done Initializing Infrared Interface
              1/13/2003 4:55:34 PM~!~startup~!~Initializing I/O
              1/13/2003 4:55:34 PM~!~Temperature Plugin~!~Register callback completed
              1/13/2003 4:55:50 PM~!~Temperature Plugin~!~OpenDSCommPort, DS9097 Interface not discovered {DS9097U}:COM2
              1/13/2003 4:55:50 PM~!~startup~!~Done Initializing I/O

              I'll be glad to help iron the bugs out any way that I can.

              Warren

              Comment


                #8
                Warren,
                I do not recognize the get_tempts scripts you are referencing. It must be burried in the bowels of the TMEX drivers. Even the "debug" line is foreign.

                The initialization that is done at startup is:
                <pre class="ip-ubbcode-code-pre">
                Set access = CreateObject("owapi.OneWireAccessProvider")
                Set adapter = access.getDefaultAdapter()
                </pre>

                I suspect that if homeseer/mcsTemperature terminates abnormally then the opportunity does not exist for normal release of the port. I'm not certain what DallasSemi does when it reserves it and what needs to be undone to make it available again.

                Unfortunately there is not much I can do about it until I get back home in a few weeks when I can play with the hardware.

                Comment

                Working...
                X