Announcement

Collapse
No announcement yet.

Any volunteer for V3.3.0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    V3.3.0 is in the attachment along with a description of the setup page functionality. I have changed the organization several times and the document may not track exactly, but hopefully will provide enough to understand the setup.

    I'm still not comfortable with how the database field attributes are being generated. If there are problems with the attributes then I suggest using Access to change a field that may be defined as "Required" to not be required. The attribute to allow zero length is being set to allow it, but not taking effect. This should not matter, however.

    The intialization routine attempts to complete the new setup screen settings based upon the old data. It then sets a flag in mcsTemperature.ini to remember that it has done the conversion. If all worked corrrectly then no additional setup should be needed, but you will be able to see the new mechanism implemented for the setup. Any usabilty suggestions are welcome.

    The problem report thread has been updated to reflect the PRs that this version has addressed.

    Comment


      #17
      I installed 3.3.0 this morning, and although I didn't have time to do complete testing, I am impressed. I like the changes you've made - it's much easier to work with.

      It does appear that the Forecast Now button is a placebo - I couldn't see any network activity as a result of pressing it, not did the Forecast update. I didn't have time to see whether perhaps Forecast updating is broken altogether - should see that tonight, though.

      --Bill

      Comment


        #18
        Bill,
        Oh, you meant you wanted "Forecast Now" to do something.

        Comment


          #19
          all I asked for was the button. That'll teach me.

          --Bill

          Comment


            #20
            I believe I took care of the problems reported n V3.3.0. I disabled the text file input because I found a problem with it and I do not think anyone is using it at this moment. The only word of caution is with new database fields being created with the "Required" attribute set sometimes. If you get a "Resize Fields" info message in the log then you may need to use Access to set the attribute to "no" so it is not a required field.

            Comment


              #21
              McS,

              Was 3.3.1 meant to be attached to your last post ?

              Also, FYI, I've rolled back to 3.2.0 and I'm getting all Virtual Devices updating OK.

              Duncan

              [This message was edited by Duncan Ellison on Sunday, 19 January 2003 at 10:12 AM.]

              Comment


                #22
                I have aways problems with V3.3.0 and previous version under Xp pro, but I am sure it's a problem with Java VM.(I instal allready)

                To day I install under W2K Pro and it's work fine.

                Only one problem it is working only on port 3.??

                I don't test temperature.asp

                Nice Interface, Very great work.

                I use the DS9097 interface only .

                Comment


                  #23
                  The update is posted at the top of the problem report thread mcsTemperature V3.3.1

                  I tried to post it last night but the message board would not accept it (or the ISP would not deliver it). I fixed the problems related to text file input with the additional time this morning.

                  Comment


                    #24
                    Tested so far :

                    Virtual devices now updating with TEMP05 - OK

                    Local temp in forecast.asp seems to now only show zero (none of my virtual temperature devices are currently zero

                    Degrees C now showing correctly on the temperature.asp chart scales

                    Wind Direction STILL not being logged in R21 (just zero)

                    Ticking mmHg for Baro output, makes Baro Pressure now show correctly in forecast.asp, unticking it makes both figures display correctly in inHg. However, the legend in forecast.asp is also incorrectly showing inHg, when it is, in fact, showing metric. I guess by OUTPUT, you mean in the asp as opposed to the virtual device.

                    Still some inconsistencies where the Temp device tabs write the wrong values to the ini file. Need to check each time that the ini file is correct,

                    More feedback as I get it.

                    Duncan

                    Comment


                      #25
                      Nantes,
                      I just caught that you are only working on port 3. I believe this was due to the port not being saved from the setup page and 3 happened to be in your mcsTemperature.ini file for the key DS9097CommPort. It has been fixed in V3.3.1 / V3.3.2. Let me know if there is still a problem. You can manually edit mcsTemperature.ini to change it for testing purposes. You can also use the iButton viewer from DallasSemi to test if the adapter works on other ports.

                      Comment


                        #26
                        Michael,

                        Allways working only on port 3.

                        Your page setup save the number of port in the ini file.
                        But it seems it is like your plug in don't take in consideration the number of port in the ini.
                        When I connect on port 3, if I edit to modify the ini file and put another port 1/2 or 4 the plug in after work fine on port 3....

                        In attachement find my ini file and txt file for error log.

                        Anyway it's a good plug in.
                        Attached Files

                        Comment

                        Working...
                        X