Announcement

Collapse
No announcement yet.

Initinivariables ErrorOverflow

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Initinivariables ErrorOverflow

    I had installed the plugin V3.23, and it ran fine for a day. It stopped running and I had lost all the devices. I have tried many things to regenerate the device list but with no luck. I updated to .30 and still no luck. What seems to happen is when this error occurs you cannot change anything in the setup file as it fails to open. The message in the log before this is ini7. It also insists on detecting a house code of [ (and r). Using a Temp05.

    #2
    Sombody else also had the problem of the house code R being the second device with the V3.3.23 vintage. This will cause problems. The solution procedure I provided was

    What I would suggest doing is:
    >1. Delete the devices defined by the plugin from the homeseer GUI. Make
    >certain that you are showing all devices (View show all devices) when you do
    >this. House code R devices should not need to be deleted unless you wish to
    >2. Edit mcsTemperate.ini and remove the two llines starting with HouseCode=
    >and HouseCode2=
    >3. Get a current version of the plugin from the message board if you have
    >not already. Not from the updater, but from the message board
    >4. Restart homeseer and use the Create Devices button again. Removal of the
    >two house code lines in step 2 should reenable this button


    If this is to dramitic for you then send me your mcsTemperature.ini and I'll look for an alternate.

    Comment


      #3
      I have attached the .ini and a log to this post. I had attempted yesterday to delete the devices by altering the Devices= line in the INI file and cannot regenerate it. A problem seems to be that I cannot edit the Setup file because it will not load. Also it will not see the database file even though it exists. When it first ran it created the files and headings but did not add data.
      Attached Files

      Comment


        #4
        The problem that you are having relates to the 60000 entered for the switch polling interval for the DS9097. I'll fix the plugin to accept this big of a number. A value of 500 to 2000 is an expected range and it only applies when the DS9097 checkbox is checked. You will need to edit the mcsTemperature.ini to remove a trailing zero or otherwise make it smaller so the setup page can load.

        Once you get over this hurdle you will also want to press the create devices button on Devices/Files tab the so the Relay05 will have a home from which GUI control can be performed.

        FYI, What I mean by deleting devices is to use the homeseer GUI to do this. This list is shown by either the light bulb in the Views panel or from the menu View\Devices. Select the location pullown to be either "All Locations" or likely "Temperature" to view the devices associated with the plugin. Highlight a device or range of devices and use the delete key or mouse right\delete.

        [This message was edited by Michael McSharry on Thu, 22 May 2003 at 12:02 PM.]

        Comment


          #5
          Thats what I did today after following your instructions. I had previously tried by deleting the line in the ini file and I have now no way of regenerating the ini file.

          Comment


            #6
            I was editing while you were responding. I added info for the real problem you are seeing

            Comment


              #7
              Changing the poll time on 9097 did help, but it still comes up with a
              <Setup load: type mismatch>
              Then
              <Setup page did not load properly so no changes where made>
              show in the homeseer log on setup load, and will not allow me to edit.
              What should be in the line after Devices= ( i.e. the first line) or how can I get a "clean" .ini . I tried renaming it ( in case it does not overwrite on updating) and updating but to no effect.
              Thanks for your excellent assistance.

              Comment

              Working...
              X