Announcement

Collapse
No announcement yet.

Trouble with Triggers

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Trouble with Triggers

    I have used the Increase to upper limit trigger and it does not work. The temperature just keeps rising.

    I have set it to trigger when it hits the upper limit of 135F. But it does not trigger. Does it have to hit that amount exactly?

    Rob

    #2
    The level trigger should function as the temperature passes through the specified level and retains the above/below condition for the specified dwell time.

    I have not looked into it for quite awhile, but I will do a little test at this end to see if there is a problem.

    Comment


      #3
      I just tried a test case and it worked just as expected.

      There are three things to confirm:

      1)I notice that you indicated 135F. The suffix "F" cannot be entered on the trigger condition. All HTML formatting and suffixes are stripped from the device string of the Trigger Sneosr when the plugin does the evaluation. The values entered into the trigger event must be numeric since no preprocessing of these is performed. Someting I can add in the future so the same situation will not occur.

      2) There have been two updates to the trigger event since the initial release of the plugin. At each time the prior definitions may have become obsolete since changes occurred in the information retained by homeseer about the event. This is overcome by redefining the event so the new format is captured by homeseer.

      3) Confirm the setup. A basic trigger when a temperature goes above 135F would have the sensor selected on the first Sensor (Trigger Sensor), Increase to Upper Limit checkbox checked, Upper Limit value of 135.

      Comment


        #4
        I have done. And it still does not give me good results. I have had to use the device value change to program my events to monitor the kiln.

        I found the lower limit to work but not he upper.

        Also, when I apply conditions, it does not seem to work either.

        When I push the conditions button to toggle back and forth between the initial and secondary condition, it does not work.

        Rob

        Comment


          #5
          Michael,

          I'm also haveing trouble with the triggers. I have the latest version of the plugin and all of the latest Homeseer Products and I can't seem to get any events using your plugin to trigger.

          Judd

          Comment


            #6
            When I tested last night I used the increases to upper limit on a virtual device where I had a script run very minute to increase the value of the virtual device string and the trigger did occur. I tried some variants with retrigger and dwell time and all worked as expected for me. Something is different there than here.

            What I did was put log file output which is enabled with general debug checkbox and it will dump and evaluation status for the upper and lower limit triggers. We can then see what evaluations are being performed. It should write to the log file every minute if a lower or upper limit trigger is defined.

            The plugin has not conditions implemented that involved the devices the plugin manages. The logic associated with the condition button is built into homeseer and not the plugin. I do see what you mean when the Condition button is clicked for a native homeseer trigger vs when it is clicked for the mcsTemperature trigger, but to my knowledge there is nothing the plugin can do about/with it since it is not part of the plugin logic. The plugin does return a status to homeseer indicating that it does not have any conditons that it wants to add to homeseer's normal conditions.

            Comment

            Working...
            X