Announcement

Collapse
No announcement yet.

MCStemp with DS9097:cannot enter COM port

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    MCStemp with DS9097:cannot enter COM port

    I just got my wether station and other sensors along withthe D29097 provided by AAG. SO I enabled
    communication in Interface/Main and clicked successfully onto that field/.

    HOEWEVER I was NOT able to specify the COM port
    in the setup...when I try to click into the COMM port field I cannot enter anything..I tried a few times....all other fields can be clicked on and modified...strange

    Note I disabled the temp05 (BTW?can they both be working togethe?) just to make sure

    #2
    is set in the driver when you install it, not in the plug-in setup. The setup GUI for mcsTemperature just shows the port setting that it finds in the driver.

    You can have both DS9097 and Temp05 (as well as virtual devices and three text files) all active at the same time.

    --Bill

    Comment


      #3
      Ok, with the DS9097, should there be a comport identified in the setup field? The docs say yes. I have a blank. I am setup at com2 for the DS9097 device and am able to see temp / humidity readings of my one wire device in the Java applet (part of the one wire driver suite).
      I get "Get DS9097 data" in the log, but no charting.

      What am I missing?

      Oh, when I did the initial MStemp install, my DS9097 wasn't found on the comport it was connected to (PCI 2 serial port adapter that works for my Slinke, but apparantly not for the DS9097). When I added a USB serial port (port 2) the Java test application finds the device and I see results. Just not from within MStemp.

      How can I tell if the TMEX drivers are truly installed as well as Java VM?
      I have XPPro IE6 with all updates as well as Java JRE 1.4.2

      TIA

      [This message was edited by DavidL on Sun, 20 July 2003 at 10:02 PM.]

      Comment


        #4
        The plugin looks for the default adapter which was selected when the drivers were installed. I believe the default can be changed with the iButton viewer / java web start applet. If you are running the java web start then you should have everything you need installed.

        There are others that are more familiar with this, but it is my understanding that Microsoft's java is needed to run the 1-wire support library. Sun's version does not work. Part of the recent Microsoft settlement was to remove their Java so you need to find a service pack that was released before the court ruling. I run W2K so I cannot be much help in this area.

        If the plugin sees the adapter it will populate the com port field on the setup page the next time the page is opened. If it does not see it it will show a message in the log about not finding it. It will try 10 times before giving up.

        If the debug flag is set on the Interface/Main tab it will show every device connected to the adapter, but of course the adapter first needs to be recognized.

        Comment


          #5
          Well,
          It looks like it was the lack of MS Java VM. I had Sun's JRE 1.4.2, but that wasn't compatible. Now I can see my com port selection of the 1 wire device in setup.
          One step out of the way...

          BTW - it took me a bit to find the MS version. Looks like Bill can't distribute it. I had to do a Google search for msjavx86.exe and keep my fingers crossed that the site I found it on could be trusted.

          [This message was edited by DavidL on Mon, 21 July 2003 at 07:57 AM.]

          [This message was edited by DavidL on Mon, 21 July 2003 at 07:58 AM.]

          Comment

          Working...
          X