Announcement

Collapse
No announcement yet.

weatherxml not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    weatherxml not working

    It was suggested I use weatherxml to get forecasts rather than built-in msnbc forecast but I can't get it to work.

    I installed weatherxml and found instructions somewhere in this forum to add the following lines to mcsForecast.ini
    - adapted to my situation, of course -

    [WeatherXML]
    CodeArea=yourCode
    PartnerID=yourPartnerID
    License=yourLicense
    units=m
    mintime=30
    lastran=28/09/2004 10:00:42 PM

    HS log reported that mcsTemperature can't find file C:\Program Files\Homeseer\data\weatherxml.com, which might be because the file is actually one directory lower at C:\Program Files\Homeseer\data\weatherxml.com\weatherxml.com

    Have been playing with both options: Get From WeatherXML File and Get From WeatherXML Site but Forecast values are not ending up in either my devices or the database.

    Am not really interested in letting mcsTemperature query the site because it checks the site somewhat at random and excessively - as reported in a separate post - which violates the restrictions to query weather.com no more than every 30 minutes.

    What am I missing to get "Get From WeatherXML File"? Manual does not cover the weatherXML feature.

    Any info would be appreciated

    #2
    The following ended up below [WeatherXML] section in mcsForecast.ini in case that helps:

    [Debug]
    ErrorCode=-2146697210

    Comment


      #3
      The Get Weatherxml for file you need another plug or script for xmldata download.

      This my script, this run every 30 minuts

      And my xml_to_mcstemp.ini
      [Settings]
      CodeArea=xxxx
      PartnerID=xxxx
      License=xxxx
      Units=s
      mintime=30
      lastran=2004-09-29 10:01:38
      Attached Files

      Comment


        #4
        Some of my devices (for forecast) aren't getting updated.

        Here's an excerpt from my device.txt file with device names added and data snipped for brevity. devices s49 - s53 are not getting updated.


        Wind Speed s47,17,39,03/10/2004 3:45:57 PM,3C7461626C6<snip>
        Humidity s48,17,55,03/10/2004 3:45:57 PM,3C7461626C6<snip>
        Baro Pressure s49,17,0,12:00:00 AM,
        UV INdex s50,17,0,12:00:00 AM,
        Visibility s51,17,0,12:00:00 AM,
        Real Feel s52,17,0,12:00:00 AM,
        Current Temp s53,17,0,12:00:00 AM,

        Day 1-5 Min, Max:
        s55,17,16,03/10/2004 3:45:57 PM,3C7461626C65<snip>
        s57,17,14,03/10/2004 3:45:57 PM,3C7461626C65<snip>
        s59,17,10,03/10/2004 3:45:57 PM,3C7461626C65<snip>
        s61,17,13,03/10/2004 3:45:57 PM,3C7461626C65<snip>
        s63,17,16,03/10/2004 3:45:57 PM,3C7461626C65<snip>
        s54,17,6,03/10/2004 3:45:57 PM,3C7461626C653<snip>
        s56,17,1,03/10/2004 3:45:57 PM,3C7461626C653<snip>
        s58,17,3,03/10/2004 3:45:57 PM,3C7461626C653<snip>
        s60,17,6,03/10/2004 3:45:57 PM,3C7461626C653<snip>
        s62,17,8,03/10/2004 3:45:57 PM,3C7461626C653<snip>

        Here's the top of the weatherxml file showing the data for s49-s53 is getting downloaded:

        <?xml version="1.0" encoding="ISO-8859-1" ?>
        - <!-- This document is intended only for use by authorized licensees of The Weather Channel. Unauthorized use is prohibited. Copyright 1995-2004, The Weather Channel Enterprises, Inc. All Rights Reserved.
        -->
        - <weather ver="2.0">
        - <head>
        <locale>en_US</locale>
        <form>MEDIUM</form>
        <ut>C</ut>
        <ud>km</ud>
        <us>km/h</us>
        <up>mb</up>
        <ur>mm</ur>
        </head>
        - <loc id="CAXX0343">
        <dnam>Ottawa, Canada</dnam>
        <tm>4:30 PM</tm>
        <lat>45.32</lat>
        <lon>-75.67</lon>
        <sunr>7:04 AM</sunr>
        <suns>6:38 PM</suns>
        <zone>-4</zone>
        </loc>
        - <cc>
        <lsup>10/3/04 4:00 PM Local Time</lsup>
        <obst>Ottawa, Canada</obst>
        <tmp>16</tmp>
        <flik>16</flik>
        <t>Mostly Cloudy</t>
        <icon>28</icon>
        - <bar>
        <r>1,018.6</r>
        <d>falling</d>
        </bar>
        - <wind>
        <s>19</s>
        <gust>N/A</gust>
        <d>190</d>
        <t>S</t>
        </wind>
        <hmid>55</hmid>
        <vis>Unlimited</vis>
        - <uv>
        <i>1</i>
        <t>Low</t>
        </uv>
        <dewp>7</dewp>
        </cc>


        Is this fixable?

        Comment


          #5
          By the way a database record does get updated, but some fields aren't right.

          vWindS = 3889 (19 in cc section of xml file)
          vBarometer = 3451350 (1018.6 in cc section of xml file)
          vUv = 200 (1 in cc section of xml file)

          Comment


            #6
            I attempted to recognize the units of measure in the weatherxml file and scale appropriately. I also now check the device string rather than the device value for a change. I have no means to test while I'm traveling. Save your current version and give this one a try

            Comment


              #7
              Am getting the following errors in HS log:

              04/10/2004 8:38:41 PM~!~mcsTemperature~!~WeatherXML on line 0 Object variable or With block variable not set
              04/10/2004 8:39:42 PM~!~mcsTemperature~!~WeatherXML on line 0 Object variable or With block variable not set
              04/10/2004 8:40:42 PM~!~mcsTemperature~!~WeatherXML on line 0 Object variable or With block variable not set
              04/10/2004 8:41:13 PM~!~mcsTemperature~!~WeatherXML on line 0 Object variable or With block variable not set
              04/10/2004 8:41:43 PM~!~mcsTemperature~!~WeatherXML on line 0 Object variable or With block variable not set
              04/10/2004 8:42:43 PM~!~mcsTemperature~!~WeatherXML on line 0 Object variable or With block variable not set
              04/10/2004 8:43:44 PM~!~mcsTemperature~!~WeatherXML on line 0 Object variable or With block variable not set
              ... repeat every minute

              No devices have been updated nor db records written since I installed about an hour ago. Am going back to previous version.

              Comment


                #8
                Help!

                04/10/2004 9:19:26 PM~!~Error~!~Cannot access plug-in: hspi_mcsTemperature.exe->Automation error
                The system cannot find the file specified.
                04/10/2004 9:19:26 PM~!~Info~!~HomeSeer version is: 1.7.7
                <snip>
                04/10/2004 9:19:28 PM~!~Error~!~Unable to find interface: mcsTemperature
                04/10/2004 9:19:38 PM~!~Error~!~Initializing I/O interface: mcsTemperature->Could not find plugin mcsTemperature


                I confirmed the file hspi_mcsTemperature.exe exists in C:\Program Files\HomeSeer, along with GetWebFile.exe in bin\mcsTemperature.

                I tried to re-download 4.28.2 from message board and overwrote both existing files.

                Also rebooted Windows (XP). Plug-in won't load.

                Comment


                  #9
                  Give this attachment a try. I see where the other had a problem. I also noticed that binary compatibility was not set for the project on my laptop. This is likley why you had problems going back.

                  I suggest unregistering your current hspi_mcsTemperature.exe, installing this attachment, and registering it.
                  Attached Files

                  Comment


                    #10
                    UGH! Everything in HS is gone! No devices and no events!

                    In the absence of instructions on how to unregister and re-register plug-in, I "Removed" it in HS amd clicked "More Plugs-in" to select/install mcsTemperature. I shutdown HS, which had restarted after installation, and which hung on this subsequent shutdown. Copied hspi_mcsTemperature.exe over existing file after backing it up. Rebooted Windows.

                    Now everything is gone in HS and the following showed up in the HS log:

                    05/10/2004 5:37:03 PM~!~Error~!~Script error in file: shutdown.txt Error: Object variable or With block variable not set

                    05/10/2004 5:48:03 PM~!~mcsTemperature~!~ TemperatureReceiveVersion5: on line 680 Type mismatch

                    Help!

                    What files do I need to restore, assuming I can find a backup? How can I avoid this in the future?

                    Comment


                      #11
                      The file that contains the devices and events is your xml file in the \Config folder. I think the default is my_house.xml if you did not change it. There may be some backups (_bck) in the same folder.

                      mcsTemperature has many file so the easiest way to restore it is to download it from the updater.

                      Attached is registration utility that someone else on the board originally posted. dblclick it and then right click in windows explorer on any file and you have options to register or unregister it.

                      I have returned from my trip and tried the version 4.28.4 and I have had no problems with it for the last 30 minutes or so with weatherxml feed. Of course I do not have metric units in the weatherxml feed, but it should not make that much difference. It is just a scaling difference.
                      Attached Files

                      Comment


                        #12
                        Have recovered from my lost devices/events and everything seems to be fine. Forecast related devices that were not getting updated now are, however devices and db fields for Day 2 to Day 5 Maximums are not the data from XML file. Neither are WindSpeed and Barometer. Other db fields/devices are okay.

                        Have attached my mdb with 4 recent forecast entries and, over the same period, the XML files that were downloaded by separate event/script.
                        Attached Files

                        Comment

                        Working...
                        X