Announcement

Collapse
No announcement yet.

Chartdirector

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Chartdirector

    I have been using Chartdirector v3.1 but tried version 4.0 (which is the latest one) with mcsTemp plugin. V3.1 works great but v4.0 doesn't. On the other hand I have noticed that Chartdirector v3.1 works with HS version 1.7.7. but not with the latest one. Problem is that I don't get any graphs. I haven't tried Chartdirector v4.0 with latest HS 1.7 version. I wonder whether anyone else has noticed this same problem.

    Jari

    #2
    I've used V3.1 and V4.0 interchangabily in standalone apps and with mcsTemp under HS 1.6.xxx. Never tried either version with HS 1.7.xxx

    Comment


      #3
      OK, thanks ofr the info.

      I forgot to mention that I have same problem with my own asp-pages which plot graphs using Chartdirector. So, this is a HS problem and not a problem in mscTemp plugin.

      Jari

      Comment


        #4
        I notice quite often I'll get a blank chart on first draw of the webpage. A page refresh usually picks it up correctly a second time. I think the reliability of HS Webserver leaves a lot to be desired, a lot of times I get icons swapped around depending on how much HS is processing at the moment.
        Mike

        Comment


          #5
          For me v3.1 has been working really well and I get very seldom a blank graph. With v4 I don't get even a blank graph; it just doesn't work at all. One thing which i have noticed that Chartdirector v3.1 stopped working completely with HS builds above 1.7.7.

          Jari

          Comment


            #6
            The generation of the jpg file is done in-line and before the response is started back to the browser which means that it is assured to be present when the browser requests that the img-src tag is present.

            A blank chart can be considered a jpg file where the content is blank and this means that the chartdirector output is not generated correctly. It can also be blank due to the handshake between the browser and the Homeseer server as it tries to deliver the binary file.

            With the web servers I write within my HA applications I serve binary files in chunks of roughly 1000 byte packets and allow up to 25 or so simultaneous connections. Each .jpg/gif file will use a connection as it is being delivered. When a page is delivered to the browser it will have many img-src tags and all of these will be requested from the server in roughly the same time.

            The jpg file generated by mcsTemperature is contained in the \Data folder. One could look to see if the size is any different between 3.1 and 4.0 of ChartDirector.

            While I do not believe it would do it, it is possible that the new ChartDirector spawns the generation of the jpg file into a new process and this process does not finish before the browser requests the image. If they did this then I think many of their host applications would break.

            Comment


              #7
              Mike,

              I installed v4 once more. In my own asp-pages where I use chartdirector, I don't get a plot at all. In the temperature.asp page I get the table showing my devices and when I click a location I don't get any plot, but there is a text saying "No items selected for line graph". So, something has changed in v4 that prevents it working. I uninstalled v4 and went back to v3.1 and everything works. As I have said before this is not a problem in mscTemp plugin.

              I just found this error message in HS log:

              24.6.2005 7:31:46~!~mcsTemperature~!~ Draw CD Chart with on line 3750 Automation error
              The specified module could not be found.



              Jari
              Last edited by jlikonen; June 24, 2005, 02:25 AM.

              Comment

              Working...
              X