Announcement

Collapse
No announcement yet.

MCSTemperature / Temp08 / Lantronix

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    MCSTemperature / Temp08 / Lantronix

    I am using a Lantronix ETS16 serial device server to connect my Temp08 to HS using MCSTemp. I installed the Lantronix com redirector software which created Com8 and I configured it to connect to port 2 of the Lantronix serial server. I started up HyperTerminal and was able to connect to the Temp08 and retrieve the sensor readings. I then changed mcsTemp from using physical com port 6 to the virtual com 8. I then restarted HS. mcsTemp says it opened com 8 in the HS log. When I go to mcsTemp, 1-wire Data Monitor Window I noticed the Comm Status display on the left was empty, no numbers like I usually see in there. I sent a TMP and didn't get a response. I tried several times no luck. I then closed HS and started HyperTerminal and I got several replies from the Temp08 with sensor readings. It was like the TMP commands got from mcsTemp to the Temp08 but the Temp08 didn't reply until I connected to it with HyperTerminal. I also tried entering in 192.168.1.2:3002 for the Com port setting in mcsTemp instead of using a virtual com port. I looked like from Michael's instructions about using Lantronix that that would work but it just gave me errors in the HS log. Any ideas?

    Thanks,
    Jabran
    Last edited by jabrans; June 26, 2005, 08:31 PM.

    #2
    I'm not surprised that the redirector provides no status since it is hardware-related and the information is not conveyed over the IP connection. I know I made to attempt to update status when I talked directly to the port.

    The direct connection to the IP port was implemented in xapmcsTemp0x, but not in mcsTemperature. xapmcsTemp0x is what I run to manage the Temp05. I tried the TMP and VER commands with the direct IP connection and the Temp05 did respond as expected.

    If hyperterm provides the desired results via the port redirector, then any application should work just as well. Are you getting the periodic data in the I/O window and only missing the ability to send it commands?

    Comment


      #3
      I'm not getting any data in the I/O window when using the virtual com port through the redirector. The HS log shows Com 8 opened by mcsTemp. I telnet to the Lantronix and did a "show port 2 status" and it has the ip address of HS server as the Current Service and Status as connected. I would think that means mcsTemp has successfully connected to Port 2 of the Lantronix device? I turned on the extra logging in mcsTemp and all I see is Database Timer=2 then =1 then =5, =4, etc, changes every minute. I guess that's the poll interval since I have it set to 5 minutes. But I don't see data in the I/O window. I also don't see the clock every minute from the Temp08 in the I/O window when using the virtual com port. The LED on the Temp08 is flashing green most of the time and occasionally flashed red for 4 or 5 flashes, not sure what that indicates?
      Last edited by jabrans; June 26, 2005, 03:47 PM.

      Comment


        #4
        If you connect hyperterm to the lantronix port rather than mcsTemp you expect to see the data delivered whenever the Temp08 is flashing red. If you do not see the data then confirm the lantronix port has been configured for the same baud etc that the Temp08 is using. The hyperterm connection and the mcsTemp I/O window should show the exact same information. Note that the hyperterm connection to the lantronix from the PC has the lines swapped vs the cable from the temp08 to the lantronix.

        Comment


          #5
          The Temp08 is connected to port 2 of the Lantronix box. When I was using Hyperterm to connect to the Temp08 I was doing it by choosing Com 8 which is the virtual port that the com redirector software created and is configured to connect to port 2 of the lantronix box. I have verified that port 2 of the lantronix box is configured for 9600,8,none,1 and no flow control.


          I don't follow what you are saying about using Hyperterm connected to the Lantronix box with a crossed over cable. When I've been using Hyperterm to connect to the Temp08 I do it through a virtual com port not a physical com port directly connected to the Lantronix box. Although I did initially use Hyperterm connected to the Lantronix box via a physical com port to setup the ip address of the Lantronix box but I haven't been using that in my troubleshooting.
          Last edited by jabrans; June 26, 2005, 08:54 PM.

          Comment


            #6
            I installed mcsTemperature and connected it to Lantronix via redirector. Brought up IO Window and issued the VER command and Temp05 reported its version. I did it with TMP and it started dumping readings.

            My redirector for the port settings is all checkboxes checked except Inband Listen and Force V2 protocol.

            If you connect hyperterm to the Lantronix port and Temp08 to the Lantronix port you will need to use different cables. The hyperterm cable will be a straight-through one and the Temp08 will be a standard crossover.

            Comment


              #7
              I had No Net Close and Raw Mode checked but the others unchecked. I checked Timeout Reconnect and Server Reconnect and now it is working. Thanks for your help that got me going.

              Jabran

              Comment


                #8
                lockup of Temp08 with lantronix

                Hi All,

                I have connected my temp08 to my lantronix ets16.

                The first time I make the connection to the temp08 after power off the lantronix box it works fine.

                After that if I restart homeseer without restarting the Lantronix box first, I can no longer connect to the Temp08.

                It actually causes the flashing light on the temp08 to stop flashing and the only way to return service is by disconnecting the temp08 serial cable and then power cycling the temp08 before reseting the lantronix box as well.

                I am not having this same problem with my oregon weather station or the CM11A x-10 interface. Both of these disconnect and reconnect easily time and time again.

                Can anyone shed some light on why the lantronix is locking up my temp08 and how to fix it?

                Thanks

                Nick.

                Comment

                Working...
                X