No announcement yet.

DS2405 problem continued from temp08 forum

  • Filter
  • Time
  • Show
Clear All
new posts

    DS2405 problem continued from temp08 forum


    At your suggestion I have moved the Ds2405 problem from the Temp08 forum. Although 4.38.4 has stopped the Line 890 DIS problem I still have no control of the DS2405 from the MCS temperature. The device permanently displays that fact that it is on.

    I am still seeing the same problem in the log that the device shows it is has received the command to turn on ( in my case this appears as "r1 on" ) but no command is used to the temp08 by mcstemperature. Same thing for off.

    I have included a copy of the startup log with debug turned on, but cannot see any obvious errors.

    Again, the device works fine when I issue an ONA or OFA command directly using the i/o window in mcstemperature.

    What can we do to find this problem?

    Next round to find the problem I guess.
    Attached Files

    It looks to me that mcsTemperature thinks the DS2405 is house code ]1 and the device that you are trying to control is R1.

    When the plugin first starts it defaults to house "R". When a house code button is used then it creates a pair of house codes for its own use. Perhaps the R1 is a leftover from the original and you have both ]1 and R1?

    This may be as simple as deleting the R1 and using ]1. If this is not the case then edit your mcsTemperature.ini in the [Devices] and [Database] sections to remove the E90000001FB64F05 & R1 lines and let the plugin rediscover them. If that does not work then post your mcsTemperature.ini so I can work with it.


      Hi Michael,

      Still no joy, I did remove the device as you suggested and let it rediscover the device.

      I see it is now using the # house code.

      Although I saw what you were talking about with the ]1 device, no such device actually exists in homeseer.

      I have attached my .ini file as well as a copy of the last startup log.
      Attached Files


        Everything in the setup looks good. It shows the two house codes to be ] and # and see the DS2405 as #2 from the Temp08 index 5. The command you issued to set #2 was before the Temp08 had finished transfering its configuration info to the PC. While this might work it is best to wait the minute or so after HS startup. With the data I did see how the command got half way and then it routed it to the DS9097 rather than the Temp08. V4.38.7 takes care of that problem.


          Hi Michael,

          Well done, that last change fixed it. Things are now operating as they should. I had almost given up hope that we would find the problem.

          This also explains why it used to work fine when I was running a 9097U adaptor.

          When I clink "on" for the device ONA 05 appears in the i/o window.

          One little thing I did notice however, when you first detect the DS2405 it starts as a switch. Nothing new here.

          However when I change the DS2405 into a relay by ticking the "out" box it doesnt go all that smoothly. I see that the original "switch" device gets deleted and replaced with a "relay" device that part goes well.

          But when I go to issue an on or off command in HS, the command part of the drop down box in homeseer is still greyed out. This is even after 90 seconds.

          I have to reboot before HS will show me these options.

          Is this normal behaviour?


            I just tried it with one of my discretes and I had no delay between when I exited mcsTemperature setup and when the proper options were presented on the HS Device GUI. I'm also running HS1.x.

            When I review the code I see only two places were the IOType property is set by mcsTemperature. One is when a new device is discovered and it sets it to Digital Input. The other is when the Update button is clicked on the setup and then it sets it based upon the "out" checkbox. During mcsTemperature initialization this property is not changed. The IOType property tells HS if it can be controled and HS will then present or gray the control buttons.

            I dont have a rationale why it is different between when you do it and when I do it. If you run the little script below it will toggle the IOType property and you can see how HS responds with its update of the GUI controls. Even if we do not understand it is not something that will happen very often and a work around does exist.

            sub main
            ToggleIOType "#2"
            end sub

            sub ToggleIOType (sDC)
            index = hs.DeviceExists(sDC)
            if index <> -1 then
            set oDevice = hs.GetDevice(index)
            oDevice.IOType = (oDevice.IOType + 1) mod 2
            set oDevice = Nothing
            end if
            end sub