Announcement

Collapse
No announcement yet.

mcsTemperature HS2 Install Instructions

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    The weather feeds supported by mcsTemperature are NOAA National Weather Service and it will read the data files that have been downloaded from Weather.com. The Homeseer script WeatherXML will do the download. You need to contact Weather.com to get rights for the feed and there are usage constraints. The information should be in the WeatherXML documentation. I previously allowed mcsTemperature to download from Weather.com, but removed it because I had no means to enforce the license terms such as the display of the advertisements that are to be shown.

    NWS likley only has feeds for United States, but not positive.

    Comment


    • #62
      Pierrot, do you use LFQQ code in the NWS Site ID (ICAO), its Lille, France
      The 2nd choice is your need to register here:
      https://registration.weather.com/ursa/xmloap/step1
      and your partner ID and license id put in the weatherXML part, ohh and change the unit to s for celsius degrees

      Comment


      • #63
        Mcs, i use nws LHBP code in hungary, so working outside US

        Comment


        • #64
          Originally posted by Pierrot View Post
          Hello,

          I finally bought mcs and I'm happy with it.

          I don't see how to get the forecast for european countries. I'm living in Lille, France.

          I have a blank graph when the period is set to "24 hours". With all the other periods, my graph is ok...

          Thanks
          Peter
          [IMG]file:///Users/PS/Desktop/Image%206.png[/IMG][IMG]file:///Users/PS/Desktop/Image%206.png[/IMG]

          Hello,

          I still have no graph when the period is set to "24 hours". With all the other periods, my graphs are ok...
          I've uninstalled then re-installed my virtual device with no result.
          Thanks for your help
          Peter

          Comment


          • #65
            New threads should be created when new subjects are being discussed. This makes it easier for others in the future to find information. Take a look at the thread http://board.homeseer.com/showthread.php?t=145967. It discusses the issues some have had with 24 hr time scales. In essence it is related to how you have elected to not connect lines when data is missing and the scale of the chart is such that a pixel column will never be populated due to the sample rate of the data.

            Comment


            • #66
              new 1-wire driver Version: 4.03 solved some issues

              I'm using MCSTemperature with xapmcs1Wire and I just wanted to let people know about the new 1-wire driver Version: 4.03 that was released recently.

              This driver update solved some issues I have been having with the xapmcs1Wire connection to the 1-wire network. Sometimes when I started xapmcs1Wire it just said that is could not find a 1-wire network and USBx. I have not had any problems so far with the new driver.

              Just wanted to let people know

              BR

              Tomas

              Comment


              • #67
                Good to know that a driver improvement is available. Note that the driver is used by xapmcs1Wire and this newer driver is not compatible with the the 1-wire interface supported natively by mcsTemperature. mcsTemperature still requires the one that is based upon Microsoft Java Virtual Machine.

                Comment


                • #68
                  new 1-wire driver Version: 4.03 solved some issues

                  I might have spoken too soon that the new 1-wire driver solved my issues. It still happens from time to time but not as frequent as befor. what happens is that some sensors stop communication and this is what I see from the homeseer log:

                  9.2.2012 08:18:36 xapmcs1wire mcs.onewire.server | setadapterport=usb2, err#=5,err desc=1-wire net not available line 126 1-wire net not available
                  9.2.2012 08:18:32 xapmcs1wire mcs.onewire.server | setadapterport=usb2, err#=5,err desc=1-wire net not available line 126 1-wire net not available
                  9.2.2012 08:18:31 xapmcs1wire mcs.onewire.server | device bc00080192c1aa10 has invalid hub reference of c200000003d8aa1f, channel 0
                  9.2.2012 08:18:31 xapmcs1wire mcs.onewire.server | device 1c0000000ce44c1d has invalid hub reference of c200000003d8aa1f, channel 0
                  9.2.2012 08:18:31 xapmcs1wire mcs.onewire.server | device 630000000db0f01d has invalid hub reference of c200000003d8aa1f, channel 0
                  9.2.2012 08:18:30 xapmcs1wire mcs.onewire.server | setadapterport=usb2, err#=5,err desc=1-wire net not available line 126 1-wire net not available
                  9.2.2012 08:18:28 xapmcs1wire mcs.onewire.server | setadapterport=usb2, err#=5,err desc=1-wire net not available line 126 1-wire net not available

                  What I have to do when this starts to happen is that I need to try and restart xapmcs1Wire a few times and then is stops. Anyone have any clue about why this happens?

                  BR / Tomas

                  Comment


                  • #69
                    The not available messages come from the 1-wire driver. I can guess either of two causes. One is the the USB adapter is not responding when queried. The other is that the adapter is busy with prior request.

                    Is the DS9490D on the compuer or somewhere through USB hubs? What is the polling rates that you are trying to achieve?

                    Comment


                    • #70
                      The USB 1-wire adapter is connected directly to the USB port through a 1 meter USB extension cord. Polling rate is set to 5min (changed it to 6min yesterday to see if there is any effect). Might bee that it takes a while to know if there is any improvement because it usually runs smoothly for a few weeks before it starts to malfunction.

                      BR / Tomas

                      Comment


                      • #71
                        Tomas

                        You could also try the native Maxim 1-WIre viewer to validate the intermittent disconnects and whether its software or hardware. It could be as simple as a bent pin on the USB dongle.

                        http://www.maxim-ic.com/products/ibu...WireViewer.cfm

                        You can make sure too that the USB port / device isn't going into some power savings mode.
                        - Pete

                        Auto mator
                        Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU - Mono 6.4X
                        Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.4X

                        X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

                        Comment


                        • #72
                          Draw CD Chart on line 4380 Automation error

                          When trying to draw the chart I get the following error:


                          <TABLE style="WIDOWS: 2; TEXT-TRANSFORM: none; BACKGROUND-COLOR: rgb(255,255,255); TEXT-INDENT: 0px; FONT-FAMILY: Verdana, Arial, sans-serif; ORPHANS: 2; LETTER-SPACING: normal; WORD-SPACING: 0px; -webkit-text-size-adjust: auto; -webkit-text-stroke-width: 0px" border=0 cellSpacing=2 cellPadding=0 width="100%"><TBODY><TR><TD style="BACKGROUND-COLOR: rgb(239,239,239); PADDING-LEFT: 3px; PADDING-RIGHT: 3px; FONT-FAMILY: Verdana, Tahoma, Arial, Helvetica, sans-serif; FONT-SIZE: 8pt; background-origin: initial; background-clip: initial" class=LOGType0 colSpan=3 align=left>mcsTemperature </TD><TD style="BACKGROUND-COLOR: rgb(239,239,239); PADDING-LEFT: 3px; PADDING-RIGHT: 3px; FONT-FAMILY: Verdana, Tahoma, Arial, Helvetica, sans-serif; FONT-SIZE: 8pt; background-origin: initial; background-clip: initial" class=LOGEntry0 colSpan=8 align=left>Draw CD Chart on line 4380 Automation error

                          </TD></TR></TBODY></TABLE>


                          any ideas?

                          Comment


                          • #73
                            The line with the error is
                            Set cd = CreateObject("ChartDirector.API")

                            It means that ChartDirector is either not installed or not registered. The plugin attempts to download it, but you can install it independently from

                            http://advsofteng.com/download.html

                            Select the first on on the page under "ChartDirector for ASP/COM/VB"

                            Comment


                            • #74
                              Hi!
                              I want to try your plugin before buying it.
                              Installation is ok but impossible to discover the adapter.

                              My pc is Windows 7 64bits
                              Adapter is DS9490

                              Ive installing microdoft virtual machine and 1wire drivers 64bits...

                              This is my error:


                              mcsTemperature - InitINIVariables sensorType=0, index=0 on line 8040 ActiveX component can't create object
                              2


                              Thank you

                              Comment


                              • #75
                                I do not think there is a version of the 1-wire drivers that existed before the .NET implementation (V4.00) that supported 64 bit machines. The most current version of the 1-wire drivers do not work with mcsTemperature. xapmcs1wire does use the .NET version. It, however, is not a direcect HS plugin, but it interfaced via mcsXap plugin.

                                Comment

                                Working...
                                X