Announcement

Collapse
No announcement yet.

mcsTemperature - new errors

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Michael McSharry
    replied
    I do not think there is much you can do, but I'm curious as to how such a situation can occur. I look a little to see if I can see how it might happen.

    Leave a comment:


  • MalcolmS
    replied
    Originally posted by Michael McSharry
    Can you try simply editing the ini file to change the 61, 62, and 63 to 02, 03, and 04?
    apologies. I had already tried that and it didn't seem to work the values had changed back to 62, 63, etc.

    However I've just tried it again and it seems to have worked this time. I suspect I was too impatient and hadn't waited long enough for HS / mcsTemp to shutdown fully the last time...

    Thanks for your help.

    Should I worry about how the .ini file was corrupted in the first instance??

    Malcolm

    Leave a comment:


  • Michael McSharry
    replied
    Can you try simply editing the ini file to change the 61, 62, and 63 to 02, 03, and 04? If that does not do it then enable the general debug and post the data in the log immediately after the Update button is clicked.
    Last edited by Michael McSharry; January 25, 2006, 03:04 PM.

    Leave a comment:


  • MalcolmS
    replied
    The feedback from the DIS and TMP all looks okay:

    18:34:00 | [Sent to Temp05: DIS ]
    18:34:00 | 01 B0000800135B3710 DS1820 OK
    18:34:00 | 02 C600080037F7F010 DS1820 OK
    18:34:00 | 03 7E00080013514210 DS1820 OK
    18:34:00 | 04 B9000800382FF710 DS1820 OK
    18:34:00 |
    18:34:01 | Update interval = 05 minutes
    18:34:01 | Relay off timer = 05 minutes
    18:34:01 | Temp display = C
    18:34:01 | Serial # display = Y
    18:34:01 | Wind dirn reverse = N
    18:34:01 | Debug = N
    18:34:01 | Some temp sensors Parasitic powered
    18:34:01 | Qty of DS1820=04
    18:34:02 | Qty of DS1822=00
    18:34:02 | Qty of DS18B2=00
    18:34:02 | Qty of DS2438=00

    18:34:10 | [Sent to Temp05: TMP ]
    18:34:10 | >
    18:34:10 | Reading Sensors...
    18:34:14 | Temp #01[B0000800135B3710]=32.56C
    18:34:16 | Temp #02[C600080037F7F010]=05.50C
    18:34:18 | Temp #03[7E00080013514210]=04.81C
    18:34:20 | Temp #04[B9000800382FF710]=14.06C

    However in the HS log mcsTemperature is complaining that it doesn't know sensor 03 and 04(?) ; i.e.

    25/01/2006 18:34:00~!~mcsTemperature~!~Sensor 03 7E00080013514210 DS1820 OK reported by Temp05 has not yet been recorded by mcsTemperature
    25/01/2006 18:34:00~!~mcsTemperature~!~Sensor 7E00080013514210 is reported as Temperature sensor DS1820 but known by mcsTemperature as type 0
    25/01/2006 18:34:00~!~mcsTemperature~!~Sensor 04 B9000800382FF710 DS1820 OK reported by Temp05 has not yet been recorded by mcsTemperature
    25/01/2006 18:34:00~!~mcsTemperature~!~Sensor B9000800382FF710 is reported as Temperature sensor DS1820 but known by mcsTemperature as type 0


    So I guess the .ini file isn't the route of the problem??

    Leave a comment:


  • Michael McSharry
    replied
    The segment below looks to be the problem. The 61,62,63 likely should be 02,03,04. This information is gather at startup after the plugin issues the TMP and DIS commands. Observe the data in the IO window at startup to confirm the Temp05 is returning reasonable indexes to the sensors following each of these two commands. The data from the ini file should only be used when the Temp05 does not respond to the startup query.

    [Devices]
    B0000800135B3710="R1,01:01,,0,0"
    C600080037F7F010="R2,02:61,,0,0"
    7E00080013514210="R3,03:62,,0,0"
    B9000800382FF710="R4,04:63,,0,0"

    Leave a comment:


  • MalcolmS
    replied
    i've had a quick look myself and can't see anything untoward and unfortunately my backup (of that file) is now quite old (like almost two years old!).

    I'll post the file... and go off an find out why it isn't included in my current weekly backup.

    Malcolm
    Attached Files

    Leave a comment:


  • Michael McSharry
    replied
    First guess is that the mcsTemperature.ini became messed up. Install a backup of this file and if that does not work then post it

    Leave a comment:


  • MalcolmS
    replied
    I've tried re-installing and also installing the latest version - but i'm still getting the same errors...

    Any ideas anyone??

    Malcolm

    Leave a comment:


  • MalcolmS
    started a topic mcsTemperature - new errors

    mcsTemperature - new errors

    My mcsTemperature installation has thrown up a whole load of errors after a HS restart tonight. Everything was working fine - can someone point me in the right direction please?? Thanks.


    Extract from the HS log file
    24/01/2006 22:02:55~!~mcsTemperature~!~Version 4.37.7 Registered with Homeseer
    24/01/2006 22:02:57~!~mcsTemperature~!~InitINIVariables Error on line 4840 Subscript out of range
    24/01/2006 22:03:06~!~mcsTemperature~!~Last temperature sample recorded at 24/01/2006 21:55:06
    24/01/2006 22:03:06~!~mcsTemperature~!~Last forecast sample recorded at 24/01/2006 21:26:56
    24/01/2006 22:04:20~!~mcsTemperature~!~Temp05/08 Comm Port 2 Opened
    24/01/2006 22:04:23~!~mcsTemperature~!~ EvaluateTemperatureTrigger: on line 50 Subscript out of range
    24/01/2006 22:04:57~!~mcsTemperature~!~Trigger UI Error: on line 100 Subscript out of range
    24/01/2006 22:05:15~!~mcsTemperature~!~Sensor 03 7E00080013514210 DS1820 OK reported by Temp05 has not yet been recorded by mcsTemperature
    24/01/2006 22:05:16~!~mcsTemperature~!~Sensor 7E00080013514210 is reported as Temperature sensor DS1820 but known by mcsTemperature as type 0
    24/01/2006 22:05:16~!~mcsTemperature~!~Sensor 04 B9000800382FF710 DS1820 OK reported by Temp05 has not yet been recorded by mcsTemperature
    24/01/2006 22:05:16~!~mcsTemperature~!~Sensor B9000800382FF710 is reported as Temperature sensor DS1820 but known by mcsTemperature as type 0
    24/01/2006 22:05:20~!~mcsTemperature~!~ TemperatureReceiveVersion5 on line 760 Subscript out of range
    24/01/2006 22:05:20~!~mcsTemperature~!~ TemperatureReceiveVersion5 on line 760 Subscript out of range
    24/01/2006 22:05:38~!~mcsTemperature~!~ EvaluateTemperatureTrigger: on line 50 Subscript out of range
    24/01/2006 22:06:06~!~mcsTemperature~!~ UpdateOK on line 2700 Subscript out of range
    24/01/2006 22:06:38~!~mcsTemperature~!~Trigger UI Error: on line 100 Subscript out of range
    24/01/2006 22:06:49~!~mcsTemperature~!~ EvaluateTemperatureTrigger: on line 50 Subscript out of range
    24/01/2006 22:07:38~!~mcsTemperature~!~Trigger UI Error: on line 100 Subscript out of range
    24/01/2006 22:07:56~!~mcsTemperature~!~ EvaluateTemperatureTrigger: on line 50 Subscript out of range
    24/01/2006 22:08:13~!~mcsTemperature~!~Trigger UI Error: on line 100 Subscript out of range
    24/01/2006 22:09:03~!~mcsTemperature~!~ EvaluateTemperatureTrigger: on line 50 Subscript out of range
    24/01/2006 22:10:09~!~mcsTemperature~!~ EvaluateTemperatureTrigger: on line 50 Subscript out of range
    24/01/2006 22:10:09~!~mcsTemperature~!~ UpdateOK on line 2700 Subscript out of range
    24/01/2006 22:10:19~!~mcsTemperature~!~ Log_Temperature: on line 540 Subscript out of range
    24/01/2006 22:11:16~!~mcsTemperature~!~ EvaluateTemperatureTrigger: on line 50 Subscript out of range
Working...
X