No announcement yet.

Trouble installing MCSTemp....

  • Filter
  • Time
  • Show
Clear All
new posts

    Trouble installing MCSTemp....


    I am stilll within my 30 days eval and have trouble with MCSTemp.

    It installs fine (latest ver) and when I go into config to select the 1-wire interface etc then "update" I get the error below.

    It then goes on to chartdirector and fails there too - see error below.

    I guess the cant create object and "~ of object ~ failed is the root... but if only I knew why!

    I do have the dallas driver kit and the onewireviewer (from dallas) works fine, so devices and serial port work ok.

    Any help will be much appreciated.

    25/01/2006 20:29:27 ~!~ConfigIO~!~Calling ConfigIO for mcsTemperature
    25/01/2006 20:29:39 ~!~mcsTemperature~!~UseDS9097_Click: on line 90 Method '~' of object '~' failed
    25/01/2006 20:29:51 ~!~mcsTemperature~!~InitINIVariables sensorType=0, index=0 on line 6820 ActiveX component can't create object
    25/01/2006 20:30:08 ~!~mcsTemperature~!~ CreateEnvironment on line 2030 Method '~' of object '~' failed
    25/01/2006 20:30:37 ~!~mcsTemperature~!~UseDS9097_Click: on line 90 Method '~' of object '~' failed
    25/01/2006 20:30:44 ~!~mcsTemperature~!~InitINIVariables sensorType=0, index=0 on line 6820 ActiveX component can't create object
    25/01/2006 20:33:58 ~!~mcsTemperature~!~ CreateEnvironment on line 2030 Method '~' of object '~' failed

    Last edited by Bestgear; January 25, 2006, 03:25 PM. Reason: missed out the log details!


    Guys... sorry for messing around...

    I have done two restarts of HS, and it appeared to install stuff the second reboot. Some appeared to be mcstemp related so I guess that might be why the above errors appeared.

    After what appeared to be a download in background, chart direct installed ok.

    If I go into mcs config screen it still gives me the driver message (download them..) but I have the drivers in the home directory and it tells me (if I try to install them) that they are installed and use add/remote to change that. should I remove the Dallas driver set?

    I still get this in the log when the drivers fail....
    25/01/2006 21:58:01 ~!~mcsTemperature~!~InitINIVariables sensorType=0, index=0 on line 6820 ActiveX component can't create object


    Last edited by Bestgear; January 25, 2006, 04:34 PM.


      The usual reason for missing drivers is the missing Microsoft Java VM. It was provided under W2K and early XP, but is no longer available from Microsoft due to antitrust.

      I obtained it for my XP machine with a google search and found the original and a bug fix update that can be installed after the original is installed. I do not know if this is the best link, but it is worth a try


        Thanks Michael.... that was the issue.. really appreciate your help.

        Sorry for being thick... but why is the SUN Vm not used? Given the MS one has been withdrawn, why the dependancy on the old code?



          That is a Dallas Semi/Maxim decision. They are using features of the MS product that are not available on Sun and the recode effort is too large for them. Since they are primarily a HW company it is understandable that resources are not put into something that will not generate any additional hardware sales. Perhaps some day when XP is very obsolete then a new solution will be made available for the then current OS.


            Ah... I understand now. As an aside, the (Dallas) OneWireViwer.jnlp no longer works... and I cannot see what to open it with now I have MS rather than Sun JVM... ideas?

            Last one - I hope... mcsTemp now sees my DS9x9x port and the three DS2409's on the HobbyBoard hub... but it does not see any temp sensors... Before I changed JVM the OneWireViewer was definately seeing all 20 temp sensors.. so I trust the network...this time! I have tried "poll switches" and also "poll only alarming" to no avail, although the timings with them was a stab in the dark!

            Any ideas much appreciated



              I have not used the viewer in a long time so I cannot be much help there.

              xapmcs1wire supports the DS2409 hub, but mcsTemperature does not.

              The one thing you need to do with the xapmcs1wire setup is to select the DS2409 channels that you want to use. Select them all initially and then later deselect ones on which no sensors are located. You can leave them all enabled if you do not mind the time it takes to select a branch and then query to see if anything is there.


                Thanks yet again Michael...

                Seems that the light at the end of the tunnel was a train comming.... so I'm off to play with xapmcs1wire now!

                This game is costing me more in wine than software!