Announcement

Collapse
No announcement yet.

Ambigous sensor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Ambigous sensor

    My Hobby Board barometer is reconized as a humidity sensor.
    I understand that both unit use the DS2438 chip.

    Please let me know how to help mscTemperature to recognize the sensor as a barometer

    yves

    #2
    Change the sensor type pulldown from Humidity to Barometer. There are some calibration values that are associated with a barometer that also need to be defined.

    Comment


      #3
      Originally posted by Michael McSharry
      Change the sensor type pulldown from Humidity to Barometer. There are some calibration values that are associated with a barometer that also need to be defined.
      Michael,

      I have a DS9490 (no Temp05/temp8) and cant find the location for changing the sensor type, as described in page 13 of the manual
      Please be more specific

      yves


      Gogs: Did you find your way ??

      Comment


        #4
        If you are running V5 of mcsSprinklers then you can select the Sensor page option and the sensor type will be a pulldown selection on the row where the sensor shows up.

        If you are running either V4 or V5 then you the setup form, Analog tabs will list the sensors and a combo box on the same row as the sensor is used to select the sensor type.

        When I look at the manual I see this showing on Figure 15 - Analog Setup Tab as the second column.

        Comment


          #5
          Originally posted by Michael McSharry
          When I look at the manual I see this showing on Figure 15 - Analog Setup Tab as the second column.
          Michael
          Your manual is very comprehensive and I spend a ot of time reading it; looking at my various posts, you certainly discovered that English is not my native language.

          I changed the sensor type from humidity to barometer on the analog setup tab. I now get one humidity and one barometer sensor with same device name and data field (see attached)
          Also I dont have the oportunity to fill the calibration data

          In the HS Status page "sensor type" for the barometer appear as "virtual" and "virtual.1". Should I delete one ??

          TIA
          yves
          Attached Files

          Comment


            #6

            Comment


              #7
              I looked at the code and see that the barometer interface via the DS2490 was only done in the xapmcs1Wire. I will need to add it to mcsTemperature. Give me a day or two and I will integrate the code there.

              Comment


                #8
                Originally posted by Michael McSharry
                I looked at the code and see that the barometer interface via the DS2490 was only done in the xapmcs1Wire. I will need to add it to mcsTemperature. Give me a day or two and I will integrate the code there.
                Michael,

                Thanks, I will disconnect the barometer from the bus for a couple of days. Can I safely delete the Barometer and humidity devices from the HS status pages?

                I assume DS2490 to be a typo; Hobby boards baro is based on DS2438

                yves

                Comment


                  #9
                  Download the zip file from http://board.homeseer.com/showthread.php?t=116165. This has the barometer added as well as the browser setup interface if you prefer it over the windows form. I was able to test the UI, but I do not have a barometer to test everything.

                  Comment


                    #10
                    Michael,

                    Thanks for this very fast reaction
                    All sensors are now recognized.

                    In the sensor setup page, barometer has no ID (see attachment) is it normal ?


                    Barometer is in the 6 (vhatever unit) range; no way to toggle between inHg and mmHg, either from web page or the old windows form.

                    Any clue for barometer calibration?

                    Toggling between Hi and low temperature resolution has no effect

                    Toggling C/F and mph/kph does not seem to work from web page (OK from the old windows form)

                    yves
                    Attached Files
                    Last edited by kas; November 4, 2006, 10:35 AM.

                    Comment


                      #11
                      In the device/files tab or browser page you will find the baro calibrations. I just went through all the radio buttons that would not save so I'm surprised they are not toggling. I'll look into it.

                      I also saw the lack of ID when I first tested it. I do not think it matters when using the USB/DS9490 as the interface. It is primarily for the Temp05/08.

                      When debugging the barometer value the items of interest are the slope, offset and second voltage reading with the barometer calculation being
                      baro = Voltage * Slope + Offset. I may have forgotten to apply the metric conversion when needed. I do that also on the next pass.

                      Comment


                        #12
                        Updates made to V2.1.5. I would suggest deleting the device code from the Sensor page for all of your barometer-related devices. This will include the temperature and voltage measurements. This will allow them to be rediscovered and the baro trend device be created as well.

                        The resolution setting is dependent upon sensor family. Some provide only a single resolution. It is primarily used when you want to speed the A/D conversion time and dont care about 0.5 vs 0.125 resolution.

                        I played with the metric vs english radio buttons and did not see anything wrong. There may be something else other than the setting toggle itself that you are seeing.

                        Comment


                          #13
                          Originally posted by Michael McSharry
                          Updates made to V2.1.5. I would suggest deleting the device code from the Sensor page for all of your barometer-related devices. This will include the temperature and voltage measurements. This will allow them to be rediscovered and the baro trend device be created as well.
                          Michael,

                          I assume you mean 5.1.2 (now 5.1.8) located:
                          http://board.homeseer.com/showthread.php?t=116165
                          I will download and let you know the outcome

                          Originally posted by Michael McSharry
                          The resolution setting is dependent upon sensor family. Some provide only a single resolution. It is primarily used when you want to speed the A/D conversion time and dont care about 0.5 vs 0.125 resolution.
                          Originally posted by Michael McSharry
                          I played with the metric vs english radio buttons and did not see anything wrong. There may be something else other than the setting toggle itself that you are seeing.
                          If I select Web interface setup/Interfaces/temperature Output/"C" and press save change, the radiobutton reverses to "F".
                          No problem through the old window form road.
                          Well... no big deal, maybe related to my regional (French) setting

                          yves

                          Comment


                            #14
                            The display page/tab has a setting for number of significant digits for temperature display. This will affect the contents of the virtual device, but if the sensor is only providing x.0 and x.5 then you will not see x.1. With xapmcs1Wire you are able to average temperature data to provide a smoother trend. You can average other sensors with mcsTemperature, but the calibration for a temperature sensor with mcsTemperature is a bias rather than a smooting function.

                            You have the correct link and it should have been 5.1.5 and now 5.1.8.

                            Comment


                              #15
                              The DS18S20 only 9 bit precision, the DS18B20, DS18B20-PAR can use 9-12 bit precision

                              http://para.maxim-ic.com/cache/en/results/4866.html

                              Comment

                              Working...
                              X