Announcement

Collapse
No announcement yet.

Problem with this plugin v 5.2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Problem with this plugin v 5.2

    I have just updated this plugin to version 5.2.0 and enabled it in HS v 2.1.104
    There are no errors but the plugin is not functioning (no graphs displayed). The top of the webpage says "No File" and on the configuration page I see "Plugin House Code is Unassigned". I can see my analog variables with correct HS names but when I press the Update button nothing shows in HS log, when before I would get an entry saying what has been saved. Also, clicking the Help menu results in error that the file is not found. I have tried to re-install the plugin, but with the same result. Is there anything I am missing to make it work? Thanks

    #2
    I would suggest enabling the General Debug and show what happens from a HS startup. If the setup pages are not saving, then edit the mcsTemperature.ini file and look for keys with the name Debug in it and change them to have a value of 1 rather than 0.

    Comment


      #3
      Michael

      I have set 7 analog devices to be monitored by the plugin via setup. Nothing is shown on graphs. Hope you can help.

      This is what in the .ini file

      [Database]
      W23="Wtr_d,30,1"
      W24="Wtr_mo,29,1"
      ]1="Hall_temp,0,1"
      \18="Bed_temp,0,1"
      V30="w_speed,2,1"
      V31="w_gust,3,1"
      V32="w_chil,0,1"
      [Cals]
      \18=""
      ]1=""
      V32=""
      V30=""
      V31=""
      W24=""
      W23=""

      here is my log for mcstemperature entries

      2/3/2007 8:43:48 AM ~!~Info~!~Found plug-in: mcsTemperature, version: 5.2.0.0
      2/3/2007 8:43:49 AM ~!~mcsTemperature~!~Version 5.2.0 Registered with Homeseer
      2/3/2007 8:43:49 AM ~!~COM Plugin~!~Calling InitIO
      2/3/2007 8:43:49 AM ~!~mcsTemperature Debug~!~Registering Callback Mask 0
      2/3/2007 8:43:49 AM ~!~mcsTemperature Debug~!~Internal Timer Started
      2/3/2007 8:43:49 AM ~!~mcsTemperature Debug~!~GetPluginTriggers Trigger Ubound=-1, Prior Trigger Ubound=-1
      2/3/2007 8:43:49 AM ~!~Database Item~!~Saving Device Composite Error Rate
      2/3/2007 8:43:49 AM ~!~Info~!~Finished initializing plug-in mcsTemperature
      2/3/2007 8:43:50 AM ~!~Database Item~!~Saving Device TEMP05 Error Count
      2/3/2007 8:43:50 AM ~!~Database Item~!~Saving Device Sensor Error Count
      2/3/2007 8:44:37 AM ~!~mcsTemperature Debug~!~SensorCount=2
      2/3/2007 8:44:37 AM ~!~mcsTemperature Debug~!~Chart SQL=SELECT SampleDate AS StartDate, (Hall_temp) AS Q1, (Bed_temp) AS Q2 FROM Temperature WHERE SampleDate >= #2007-02-02 9:00# AND SampleDate < #2007-02-03 9:00#
      2/3/2007 8:44:37 AM ~!~mcsTemperature Debug~!~Chart SQL2=
      2/3/2007 8:44:37 AM ~!~mcsTemperature Debug~!~Chart SQL3=
      2/3/2007 8:44:37 AM ~!~mcsTemperature Debug~!~FixTable field [Temperature].[Hall_temp]
      2/3/2007 8:44:37 AM ~!~mcsTemperature Debug~!~FixTable SQL UPDATE Temperature SET [Temperature].[Hall_temp] = 0 WHERE ((([Temperature].[Hall_temp]) Is Null))
      2/3/2007 8:44:37 AM ~!~mcsTemperature Debug~!~FixTable field [Temperature].[Bed_temp]
      2/3/2007 8:44:37 AM ~!~mcsTemperature Debug~!~FixTable SQL UPDATE Temperature SET [Temperature].[Bed_temp] = 0 WHERE ((([Temperature].[Bed_temp]) Is Null))
      2/3/2007 8:44:38 AM ~!~mcsTemperature Debug~!~X Axis Data Completed
      2/3/2007 8:44:38 AM ~!~mcsTemperature Debug~!~Y Axis Data Completed
      2/3/2007 8:44:50 AM ~!~mcsTemperature Debug~!~EvaluateDeviceAction DeviceActionCollection.Count=0, MonitoredEventCount=0
      2/3/2007 8:45:52 AM ~!~mcsTemperature Debug~!~EvaluateDeviceAction DeviceActionCollection.Count=0, MonitoredEventCount=0

      2/3/2007 1:54:16 PM ~!~mcsTemperature Debug~!~EvaluateDeviceAction DeviceActionCollection.Count=0, MonitoredEventCount=0
      2/3/2007 1:55:16 PM ~!~mcsTemperature Debug~!~EvaluateDeviceAction DeviceActionCollection.Count=0, MonitoredEventCount=0
      2/3/2007 1:56:16 PM ~!~mcsTemperature Debug~!~EvaluateDeviceAction DeviceActionCollection.Count=0, MonitoredEventCount=0
      2/3/2007 1:56:34 PM ~!~mcsTemperature Debug~!~SensorCount=2
      2/3/2007 1:56:34 PM ~!~mcsTemperature Debug~!~Chart SQL=SELECT SampleDate AS StartDate, (Hall_temp) AS Q1, (Bed_temp) AS Q2 FROM Temperature WHERE SampleDate >= #2007-02-02 14:00# AND SampleDate < #2007-02-03 14:00#
      2/3/2007 1:56:34 PM ~!~mcsTemperature Debug~!~Chart SQL2=
      2/3/2007 1:56:34 PM ~!~mcsTemperature Debug~!~Chart SQL3=
      2/3/2007 1:56:34 PM ~!~mcsTemperature Debug~!~FixTable field [Temperature].[Hall_temp]
      2/3/2007 1:56:34 PM ~!~mcsTemperature Debug~!~FixTable SQL UPDATE Temperature SET [Temperature].[Hall_temp] = 0 WHERE ((([Temperature].[Hall_temp]) Is Null))
      2/3/2007 1:56:34 PM ~!~mcsTemperature Debug~!~FixTable field [Temperature].[Bed_temp]
      2/3/2007 1:56:34 PM ~!~mcsTemperature Debug~!~FixTable SQL UPDATE Temperature SET [Temperature].[Bed_temp] = 0 WHERE ((([Temperature].[Bed_temp]) Is Null))
      2/3/2007 1:56:34 PM ~!~mcsTemperature Debug~!~X Axis Data Completed
      2/3/2007 1:56:34 PM ~!~mcsTemperature Debug~!~Y Axis Data Completed
      2/3/2007 1:57:16 PM ~!~mcsTemperature Debug~!~EvaluateDeviceAction DeviceActionCollection.Count=0, MonitoredEventCount=0
      2/3/2007 1:58:16 PM ~!~mcsTemperature Debug~!~EvaluateDeviceAction DeviceActionCollection.Count=0, MonitoredEventCount=0

      Comment


        #4
        During startup there is an expected log output that indicates when the last data was stored in the database. It is not in your log output. Post the entire ini file so I can see how you have your database specified. You can also look to make ceratain the path to the database is consistent to where you expect it to be.

        Comment


          #5
          The database is in HS directory. When I have renamed it, I got these 3 lines at startup (it did not complain that there is no database)

          2/3/2007 7:39:26 PM ~!~mcsTemperature~!~Version 5.2.0 Registered with Homeseer
          2/3/2007 7:39:26 PM ~!~COM Plugin~!~Calling InitIO
          2/3/2007 7:39:26 PM ~!~Info~!~Finished initializing plug-in mcsTemperature


          Here is .ini (I have removed the licence line).

          [Temperature]
          WeedLastDays=180
          WeedMaxInterval=60
          WeedFirstDays=180
          RainCalibration="1"
          WaterFlowCalibration="1"
          WattCalibration="1"
          RainCalibrationRate="0.2"
          WaterFlowCalibrationRate="0.4"
          WattCalibrationRate="1.0"
          WindCalibration="1"
          RelayCommandDelay="250"
          WDTString=""
          iconPixels="16"
          UseRelay05=0
          StoreRelay1=0
          StoreRelay2=0
          StoreRelay3=0
          StoreRelay4=0
          StoreRelay5=0
          StoreRelay6=0
          StoreRelay7=0
          StoreRelay8=0
          ReverseColorScale=0
          RetainSettingByClient=0
          InMenu=1
          forceHumidityScale=0
          UseHTML=0
          OnlyTemperatureIcon=0
          alwaysShowGraph=0
          UseForecast=0
          UseDatabase=0
          csvDelete=0
          csvDelete2=0
          csvDelete3=0
          HumidityCal=0
          NormalPriority=0
          UseCSV=0
          UseCSV2=0
          UseCSV3=0
          UseWeatherPLUG=0
          AverageSites=1
          UseTemp05=0
          ShowRawData=0
          UseQuasar=0
          UseWeatherXMLFile=0
          UseWeatherXMLSite=0
          UseDS9097=0
          MetricInTemp=0
          MetricTemp=0
          MetricBaro=0
          MetricWind=0
          ReverseWind=0
          MetricRain=0
          EnableTriggers=1
          DisableWindow=0
          AlarmingSwitches=0
          UseSQL=0
          SQLSource=""
          SlowWeight=""
          FastWeight=""
          showTemperatureDataPoints=0
          ConnectDots=0
          LimitHumidity=0
          IncludeHumidity35=0
          excludeHeaderAndFooter=0
          ShowOnlyDeviceName=0
          CompatibilityMode=0
          AllowLocalHostForTouchscreen=0
          Temp05Version5=1
          DebugLog=1
          DebugLog2=1
          VersionAfter416OrUsingV1=1
          usePreviousOnBadReadings=0
          NorthDirection="0"
          DSPort=""
          QuasarPort=""
          Temp05CommPort=""
          StyleSheet="StyleNoBody.css"
          Database="mcsTemperature.mdb"
          TemperatureTable="Temperature"
          DateFieldName="SampleDate"
          TemperatureFieldPrefix="R"
          DataCollectionInterval=5
          LegendHeight="35"
          LegendLeft="55"
          TemperatureHouse="`"
          decimalCharacter="."
          Version_Id=""
          GUIColor="gray"
          TextColor="gray"
          ForecastLowColor="Black"
          ForecastHighColor="Red"
          TextColorSize=""
          TableFontColor="gray"
          TableFontColorSize=""
          MaxVerticalPixels=16
          GraphColorBase="motion/TEMP"
          bca="#000000"
          DisplayOrder="RCur"
          WindOnThreshold="5"
          RefreshImageRate="1"
          TemperatureDeviceLocation="Temperature"
          DiscreteSpacing="2"
          QuasarSampleInterval=1
          DSSampleInterval=1
          CSVSampleInterval=5
          CSVSampleInterval2=5
          CSVSampleInterval3=5
          T05SampleInterval=5
          high_wind="`50"
          MinimumHumidity="20"
          SignificantDigits="1"
          UserDefinedLabel0=""
          UserDefinedLabel1=""
          UserDefinedLabel2=""
          UserDefinedLabel3=""
          LineWidthTemperature="1"
          LineWidthOther="1"
          SymbolSizeL="2"
          SymbolSizeR="5"
          SymbolDeltaL="2"
          SymbolDeltaR="2"
          barocalibrationslope="1"
          barocalibrationoffset="0"
          ClientChartLegendSize="8, 8, 8, 8, 8, 8, 8, 8, 8, 8"
          ClientChartUpdateTimeSize="7, 7, 7, 7, 7, 7, 7, 7, 7, 7"
          ClientChartAxisTitleSize="8, 8, 8, 8, 8, 8, 8, 8, 8, 8"
          ClientChartAxisSize="8, 8, 8, 8, 8, 8, 8, 8, 8, 8"
          ClientChartOverallHeight="300, 370, 440, 510, 580, 650, 720, 790, 860, 930"
          ClientChartOverallWidth="600, 700, 800, 900, 1000, 1100, 1200, 1300, 1400, 1500"
          ClientChartWidth="520, 620, 720, 820, 920, 1020, 1120, 1220, 1320, 1420"
          ClientChartHeight="210, 280, 350, 420, 490, 560, 630, 700, 770, 840"
          LineChartBorderColor=D0D0D0
          LineChartCenterColor=FCFDCF
          DefaultLineColors=""
          Client0="Default,0"
          Client1=",0"
          Client2=",0"
          Client3=",0"
          DefaultGraph=LinSel
          DefaultPeriod=24Hour
          DefaultAggregate=None
          SelectedGroup=Temperature
          HouseCode=96
          HouseCode2=35
          [Database]
          W23="Wtr_d,30,1"
          W24="Wtr_mo,29,1"
          ]1="Hall_temp,0,1"
          \18="Bed_temp,0,1"
          V30="w_speed,2,1"
          V31="w_gust,3,1"
          V32="w_chil,0,1"
          [Cals]
          \18=""
          ]1=""
          V32=""
          V30=""
          V31=""
          W24=""
          W23=""
          [Forecast]
          ForecastVDCode0="#47"
          ForecastVD0=0
          ForecastChart0=0
          ForecastVDCode1="#48"
          ForecastVD1=0
          ForecastChart1=0
          ForecastVDCode2="#49"
          ForecastVD2=0
          ForecastChart2=0
          ForecastVDCode3="#50"
          ForecastVD3=0
          ForecastChart3=0
          ForecastVDCode4="#51"
          ForecastVD4=0
          ForecastChart4=0
          ForecastVDCode5="#52"
          ForecastVD5=0
          ForecastChart5=0
          ForecastVDCode6="#53"
          ForecastVD6=0
          ForecastChart6=0
          ForecastVDCode7="#54"
          ForecastVD7=0
          ForecastChart7=0
          ForecastVDCode8="#55"
          ForecastVD8=0
          ForecastChart8=0
          ForecastVDCode9="#56"
          ForecastVD9=0
          ForecastChart9=0
          ForecastVDCode10="#57"
          ForecastVD10=0
          ForecastChart10=0
          ForecastVDCode11="#58"
          ForecastVD11=0
          ForecastChart11=0
          ForecastVDCode12="#59"
          ForecastVD12=0
          ForecastChart12=0
          ForecastVDCode13="#60"
          ForecastVD13=0
          ForecastChart13=0
          ForecastVDCode14="#61"
          ForecastVD14=0
          ForecastChart14=0
          ForecastVDCode15="#62"
          ForecastVD15=0
          ForecastChart15=0
          ForecastVDCode16="#63"
          ForecastVD16=0
          ForecastChart16=0
          [Group]
          Default="None","LinSel","\18"-1,"]1"-1,"V32"-1,"V30"-1,"V31"-1,"W24"-1,"W23"-1
          Temperature="None","LinSel","]1"-1,"\18"-1
          Water="None","LinSel","W23"-1,"W24"-1
          [ASP]
          HouseWaterMonth=checked
          HouseWaterDay=checked
          ELK-M1KeypadTemp1=checked
          ELK-M1Bedroomtemp=checked
          [Scale]
          Temperature=,,,
          Water=,,,

          Comment


            #6
            I have also noticed that all fields and buttons are disabled on the Database menu page of the setup screen, if this could be of help.

            Comment


              #7
              The UseDatabase key = 0 which means the checkbox is not checked to use the database on main setup page. If you are expecting charts then you will need to have this option enabled.

              Comment

              Working...
              X