Announcement

Collapse
No announcement yet.

registration error automation error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    registration error automation error

    The other day I started getting error dialogue windows at HS startup, and MCSTemp stopped working. the title of the dialogue was "registration error automation error" and the content of hte dialogue was:
    invalid access to memory location

    Then I click OK, and I get this one, regarding MCSTemp:

    the instruction at "x0x7c911f6c" referenced meory at "0x00000064". The memeory could not be "read".
    click on ok to terminate the program
    click on cancel to debug the program

    here's some stuff from the startup log:

    <TABLE cellSpacing=2 cellPadding=0 width="100%" border=0><TBODY><TR><TD class=LOGDateTime1 noWrap align=left>7/1/2007 10:03:44 PM </TD><TD class=LOGType1 align=left colSpan=3>Info </TD><TD class=LOGEntry1 align=left colSpan=8>Initializing Plug-in: Applied Digital Ocelot</TD></TR><TR><TD class=LOGDateTime0 noWrap align=left>7/1/2007 10:03:44 PM </TD><TD class=LOGType0 align=left colSpan=3>Info </TD><TD class=LOGEntry0 align=left colSpan=8>Finished initializing plug-in mcsTemperature</TD></TR><TR><TD class=LOGDateTime1 noWrap align=left>7/1/2007 10:03:44 PM </TD><TD class=LOGType1 align=left colSpan=3>Error </TD><TD class=LOGEntry1 align=left colSpan=8>Initializing interface: mcsTemperature->Method '~' of object '~' failed</TD></TR><TR><TD class=LOGDateTime0 noWrap align=left>7/1/2007 10:03:44 PM </TD><TD class=LOGType0 align=left colSpan=3>COM Plugin Error </TD><TD class=LOGEntry0 align=left colSpan=8>Error initializing Custom Interface: Method '~' of object '~' failed</TD></TR><TR><TD class=LOGDateTime1 noWrap align=left>7/1/2007 10:03:44 PM </TD><TD class=LOGType1 align=left colSpan=3>COM Plugin </TD><TD class=LOGEntry1 align=left colSpan=8>InitIO error: Method '~' of object '~' failed</TD></TR><TR><TD class=LOGDateTime0 noWrap align=left>7/1/2007 10:03:44 PM </TD><TD class=LOGType0 align=left colSpan=3>COM Plugin </TD><TD class=LOGEntry0 align=left colSpan=8>Calling InitIO</TD></TR><TR><TD class=LOGDateTime1 noWrap align=left>7/1/2007 10:03:44 PM </TD><TD class=LOGType1 align=left colSpan=3>mcsTemperature </TD><TD class=LOGEntry1 align=left colSpan=8>Version 5.6.9 Registered with Homeseer</TD></TR><TR><TD class=LOGDateTime0 noWrap align=left>7/1/2007 10:03:44 PM </TD><TD class=LOGType0 align=left colSpan=3>Info </TD><TD class=LOGEntry0 align=left colSpan=8>Initializing Plug-in: mcsTemperature</TD></TR><TR><TD class=LOGDateTime1 noWrap align=left>7/1/2007 10:03:44 PM </TD><TD class=LOGType1 align=left colSpan=3>Info </TD><TD class=LOGEntry1 align=left colSpan=8>Finished initializing plug-in mcsMovement</TD></TR><TR><TD class=LOGDateTime0 noWrap align=left>7/1/2007 10:03:44 PM </TD><TD class=LOGType0 align=left colSpan=3>Error </TD><TD class=LOGEntry0 align=left colSpan=8>Initializing interface: mcsMovement->Method '~' of object '~' failed</TD></TR><TR><TD class=LOGDateTime1 noWrap align=left>7/1/2007 10:03:44 PM </TD><TD class=LOGType1 align=left colSpan=3>COM Plugin Error </TD><TD class=LOGEntry1 align=left colSpan=8>Error initializing Custom Interface: Method '~' of object '~' failed</TD></TR><TR><TD class=LOGDateTime0 noWrap align=left>7/1/2007 10:03:43 PM </TD><TD class=LOGType0 align=left colSpan=3>COM Plugin </TD><TD class=LOGEntry0 align=left colSpan=8>InitIO error: Method '~' of object '~' failed</TD></TR><TR><TD class=LOGDateTime1 noWrap align=left>7/1/2007 10:03:43 PM </TD><TD class=LOGType1 align=left colSpan=3>mcsMovement </TD><TD class=LOGEntry1 align=left colSpan=8>BuildDeviceDictionary on line 730 Automation errorInvalid access to memory location. </TD></TR><TR><TD class=LOGDateTime0 noWrap align=left>7/1/2007 10:03:42 PM </TD><TD class=LOGType0 align=left colSpan=3>COM Plugin </TD><TD class=LOGEntry0 align=left colSpan=8>Calling InitIO</TD></TR><TR><TD class=LOGDateTime1 noWrap align=left>7/1/2007 10:03:42 PM </TD><TD class=LOGType1 align=left colSpan=3>Info </TD><TD class=LOGEntry1 align=left colSpan=8>Initializing Plug-in: mcsMovement</TD></TR><TR><TD class=LOGDateTime0 noWrap align=left>7/1/2007 10:03:42 PM </TD><TD class=LOGType0 align=left colSpan=3>Info </TD><TD class=LOGEntry0 align=left colSpan=8>Finished initializing plug-in UPB</TD></TR><TR><TD class=LOGDateTime1 noWrap align=left>7/1/2007 10:03:41 PM </TD><TD class=LOGType1 align=left colSpan=3>Database Item </TD><TD class=LOGEntry1 align=left colSpan=8>Saving Device All Off</TD></TR></TBODY></TABLE>

    Any ideas?
    I was using version 5.6.0.3 and tried downloading the 5.6.9, but it didn't change anything.
    Plugins:
    BLLogMonitor, BLGarbage, BLBackup, BLOutGoingCalls, BLUps, BLRfid, JvEss, DooMotion, Applied Digital Ocelot, AC RF Processor, UltraMon, PJC AVR 430, UPB, Rain8net, DSC Panel, JRiver Media center, Windows Media Player, SageMediaCenter, SnevlCID, MCSTemperature.

    #2
    You have the same error on both mcsTemperature and mcsMovement. mcsMovement is the simplier plugin. During initializtion is uses only hs methods other than ADODB for the database, Scripting.Dictionary, and ScriptControl. The database is MDAC 2.6 or later. Dictionary is part of Windows Scripting Host version 5.6. ScriptControl is also a Microsoft download.

    You can try reinstalling these, but my guess is that you have something else going on

    Comment


      #3
      wow. those are a lot of big words. :-)

      I put in a help ticket, because I noticed some of my own basic scripts are not even working properly. It also had affected HSTV and Maestro.

      I'll let you know what the result is.

      Thanks,

      Ian
      Plugins:
      BLLogMonitor, BLGarbage, BLBackup, BLOutGoingCalls, BLUps, BLRfid, JvEss, DooMotion, Applied Digital Ocelot, AC RF Processor, UltraMon, PJC AVR 430, UPB, Rain8net, DSC Panel, JRiver Media center, Windows Media Player, SageMediaCenter, SnevlCID, MCSTemperature.

      Comment


        #4
        per the instructions in the help ticket response, i did a repair of the hs install, and then a repair of the .net framework. after rebooting the problem went away.

        Thank you,

        Ian
        Plugins:
        BLLogMonitor, BLGarbage, BLBackup, BLOutGoingCalls, BLUps, BLRfid, JvEss, DooMotion, Applied Digital Ocelot, AC RF Processor, UltraMon, PJC AVR 430, UPB, Rain8net, DSC Panel, JRiver Media center, Windows Media Player, SageMediaCenter, SnevlCID, MCSTemperature.

        Comment

        Working...
        X