Announcement

Collapse
No announcement yet.

Weather quit forecasting in mcstemprature

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Weather quit forecasting in mcstemprature

    Michael,

    Suddenly on on 4-11-2007 the weather forecast quit updating. I see in the log that it report the last weather update as occurring 4-11-2007 as well. The manual get forecast button in the setup window doesn't seem to want (or at least nothing noticable is reported) to fetch any data. If checked the option for general debug log and no wether forcast data entries are made.

    Am I out of luck becasue I am running homeseer 1.7.30? I running mcstemprature 4.7.31. Can I install version 5 on homeseer 1.7?

    ACCID is set to 60527 which it has been for several years...

    thanks for any help or direction

    -Richard Morton
    -Rick

    #2
    MSNBC stopped their feed. You will need to swith to Weather.com. You need to register with Weather.com but it is free. You can get the data using the WeatherXML script and share the file it generates or have mcsTemperature pull it directly from the site. There has been some discussion on the setup recently in this subforum.

    Comment


      #3
      Michael,

      thanks for the hint

      Can I install verions 5 of mcstemprature on homeseer 1.7?

      thanks

      -Richard Morton
      Last edited by rmorton27; July 6, 2007, 05:13 PM.
      -Rick

      Comment


        #4
        Yes, it will configure itself for either version

        Comment


          #5
          weather forecast updating

          Hello,
          I think I'm missing something obvious, so maybe others are too:
          I found the forum messages which said MSNBC wasn't working and to switch to Weather.com's XML data. I have correctly entered my license info and my \Data\weathercom_xml\weathercom.xml file is correctly updating...I can see current data within.
          My HS2 log says "Weather XML site cannot be accessed more often than 30 minutes" every minute, which probably corresponds to my "transfer mapped virtual devices" rate? I never see a successful forecast download message in the log, that might be useful?
          My real problem is that I can't then read/graph the current temperature - what am I missing? I am storing the forecast data in devices and db (temp into R7), but I don't get any data with a graph or table. I've tried an analog virtual device entry in the setup screen, but no joy - I ended up with two entries in my Groups table :P
          I'm sure it's obvious, but help a guy out?
          thx!
          p.s. Love the plugin btw, I am successfully monitoring my CamStat temp and set points...more sensors soon! Can we get all the analog and discrete pages in the setup screen into the web gui? Uninstalling the service to access that page is extra work

          Comment


            #6
            It seems you are using V4 or mcsTemperature. V5 contains the Browser interface. To start with use the Updater and get the current mcsTemperature install. Then extract the attachment into the Homeseer 2 folder that is found at http://board.homeseer.com/showthread.php?t=116165.

            When you have the current configuration then we will know that we will not be chasing issues that have already been overcome.

            Does HS reflect the downloaded weather data in its virtual devices?

            Comment


              #7
              updating

              Thanks and apologies! Well, I definitely should have prefaced my prior posting with this posting, but I didn't think the small revision change I thought I had might be to blame...

              I used the updater to originally attempt the install, but it kept hanging. I ultimately ran the install manually and had success. Subsequent runs of the updater always (successfully) leave me at 5.7.0.0, not 5.7.0.2 according to the updater:

              <TABLE cellSpacing=2 cellPadding=0 width="100%" border=0><TBODY><TR><TD class=LOGDateTime1 noWrap align=left>8/1/2007 2:50:45 PM </TD><TD class=LOGType1 align=left colSpan=3>Updater </TD><TD class=LOGEntry1 align=left colSpan=8>Starting installation of updates</TD></TR><TR><TD class=LOGDateTime0 noWrap align=left>8/1/2007 2:50:45 PM </TD><TD class=LOGType0 align=left colSpan=3>Updater </TD><TD class=LOGEntry0 align=left colSpan=8>Applying update: mcsTemperature</TD></TR><TR><TD class=LOGDateTime1 noWrap align=left>8/1/2007 2:50:45 PM </TD><TD class=LOGType1 align=left colSpan=3>Updater </TD><TD class=LOGEntry1 align=left colSpan=8>Executing installer: C:\Program Files\HomeSeer 2\updates2\mcsTemperature5.7.0.2\setup_mcsTemperature.exe</TD></TR><TR><TD class=LOGDateTime0 noWrap align=left>8/1/2007 2:51:11 PM </TD><TD class=LOGType0 align=left colSpan=3>Updater </TD><TD class=LOGEntry0 align=left colSpan=8>Copying file: C:\Program Files\HomeSeer 2\Config\mcsTemperature.lf</TD></TR><TR><TD class=LOGDateTime1 noWrap align=left>8/1/2007 2:51:11 PM </TD><TD class=LOGType1 align=left colSpan=3>Updater </TD><TD class=LOGEntry1 align=left colSpan=8>Installation of updates completed</TD></TR><TR><TD class=LOGDateTime0 noWrap align=left>8/1/2007 2:51:11 PM </TD><TD class=LOGType0 align=left colSpan=3>Startup </TD><TD class=LOGEntry0 align=left colSpan=8>Checking for available plug-ins</TD></TR><TR><TD class=LOGDateTime1 noWrap align=left>8/1/2007 2:51:11 PM </TD><TD class=LOGType1 align=left colSpan=3>Info </TD><TD class=LOGEntry1 align=left colSpan=8>Found plug-in: AC RF Processor, version: 1.2.0.3</TD></TR><TR><TD class=LOGDateTime0 noWrap align=left>8/1/2007 2:51:11 PM </TD><TD class=LOGType0 align=left colSpan=3>Info </TD><TD class=LOGEntry0 align=left colSpan=8>Found plug-in: X10 CM11A/CM12U, version: 2.1.2363.27042</TD></TR><TR><TD class=LOGDateTime1 noWrap align=left>8/1/2007 2:51:11 PM </TD><TD class=LOGType1 align=left colSpan=3>Info </TD><TD class=LOGEntry1 align=left colSpan=8>Found plug-in: mcsTemperature, version: 5.7.0.0</TD></TR></TBODY></TABLE>

              Please advise...thanks again!

              Comment


                #8
                Extract the file at http://board.homeseer.com/showthread.php?t=116165 into your Homeseer 2 folder and you will be current.

                Comment


                  #9
                  updating

                  Wow, apologies, I must practice better reading comprehension...I saw four attachments on the forum you mentioned the first time, but it took your 2nd reply to get me to see that there were 3 pages of forum entries!

                  Ok, I'm running 5.7.2 and I have weather data! At work we call that an id10T error...

                  Thanks much!!

                  Comment

                  Working...
                  X