Announcement

Collapse
No announcement yet.

Graphing no longer working (?)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MalcolmS
    replied
    thanks Michael - sorted now...

    Leave a comment:


  • Michael McSharry
    replied
    You have selected a period of "monthly". If you want a chart of the last 30 days then select "month". The ones ending in "ly" will generally not be used. They still should work, but there is very little application for them so they may not have been maintained over the years.

    You are getting a chart produced but it is only 1 pixel because of the chart size parameters on the Display page. I selected values of 300, 600, 210, 520 going across the row for the screen size of 600. You can manually select them as I did or you can let the plugin fill in the matrix by deleting the 4 keys ClientChartOverallHeight, ClientChartOverallWidth, ClientChartHeight and ClientChartWidth from the mcsTemperature.ini file when HS2 is not running


    arrOH = Split(Replace(hs.GetIniSetting(TemperatureGroup, "ClientChartOverallHeight", "300, 370, 440, 510, 580, 650, 720, 790, 860, 930", TemperatureIniFile), q, ""), ",")
    arrOW = Split(Replace(hs.GetIniSetting(TemperatureGroup, "ClientChartOverallWidth", "600, 700, 800, 900, 1000, 1100, 1200, 1300, 1400, 1500", TemperatureIniFile), q, ""), ",")
    arrH = Split(Replace(hs.GetIniSetting(TemperatureGroup, "ClientChartHeight", "210, 280, 350, 420, 490, 560, 630, 700, 770, 840", TemperatureIniFile), q, ""), ",")
    arrW = Split(Replace(hs.GetIniSetting(TemperatureGroup, "ClientChartWidth", "520, 620, 720, 820, 920, 1020, 1120, 1220, 1320, 1420", TemperatureIniFile), q, ""), ",")

    Leave a comment:


  • MalcolmS
    replied
    ok - try these. Thanks
    Attached Files

    Leave a comment:


  • Michael McSharry
    replied
    Since there are no hints the next step is to enable general debug and collect data for the period where a line chart is being drawn. You can also attach your mcsTempearture.ini. While I wll not have any data from your database I will still get a shell of a chart.

    Leave a comment:


  • MalcolmS
    replied
    no errors in HS log and Chart Director was installed but I tried an uninstall/re-install and that made no difference...

    Leave a comment:


  • Michael McSharry
    replied
    The charts are produced with Chart Director which should be installed on the first attempt to draw a line chart. Do you know if it is installed? It will not hurt to reinstall it from http://download2.advsofteng.com/chartdir_com_win32.exe

    Are there any errors in the HS Log?

    Leave a comment:


  • MalcolmS
    replied
    No

    Leave a comment:


  • Michael McSharry
    replied
    Do you get the chart when you click the Draw button?

    Leave a comment:


  • MalcolmS
    replied
    Sorry Michael - should have said, I do have groups defined. I get the same display with these.




    Should this not display a line graph as well as the data table??

    Leave a comment:


  • Michael McSharry
    replied
    They are all correctly displayed. You want to define your own group(s) rather than the Default group as Default has some issues in trying to maintain backward compatibility with earlier versions of mcsTemperature.

    I think there is also a setting to show line charts on first access. The default is to not show them, but require the use of the Draw button. This was a design that was considerate of low bandwidth connections.

    Leave a comment:


  • MalcolmS
    replied
    last two options





    Which of the six options are displaying correctly??

    Leave a comment:


  • MalcolmS
    started a topic Graphing no longer working (?)

    Graphing no longer working (?)

    I haven't used the graph options in mcsTemperature for a while so i'm not sure if it's boken but I don't seem to get all of the graphs to display. Here's what I see as I scroll through the options...











Working...
X