Announcement

Collapse
No announcement yet.

Trial Problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Trial Problems

    Hey guys,

    I've recently delved into TEMP08 and was looking for a program that would chart it, plus my CPU temperatures that come in via different devices.

    So, I have a device, code ]5 which is for my server CPU temperature. This is updated every minute or so. I installed mcsTemperature and went into Interface and put a tick in "Transfer mapped virtual devices to database at interval" and set it to 1 minute. I then went into sensors. In DC I put ]5 and in the DB field I just put 1 as a test. I then clicked Save Setup changes. After a few minutes the name field changed to the correct name of the field.

    So after an hour I clicked on Groups and clicked on Show and Draw next to the sensor, then clicked Update default. I then went into Trend which defaulted to Table view. It showed my sensor with the correct temperature of 51, but Avg, Min, & Max were empty. I then clicked on type Line and pressed Draw. All I get is a graph with a single line at 0.01 going across the screen.

    Obviously I am missing something here. Can anyone help ? What am I doing wrong ?

    Any help appreciated.

    Marc

    #2
    Your database fields names need to be names that are valid in SQL or Access. Something like CPUTemperature would be an appropriate name. The database engine is likely choking on the "1" for a name.

    Comment


      #3
      Ah that got it

      OK, next problem. I have setup TEMP08 interface. It's detected my sensors and created associated devices. It updated those devices with initial temperature readings. The trouble is it's no longer updating them. They had one initial update and that's all !

      What am I missing ?

      Many Thanks

      Marc

      Comment


        #4
        It updates changes. Open the IO Echo window and observe the data being delivered from the Temp08. The frequency of data delivery will depend upon how you programmed the Temp08. If you see values changing in this window for a given sensor and the devices are not being updated then enable general debug and collect data for a period where you observe a sensor change and post the log for that segment.

        Comment


          #5
          Righto, I enabled debug and this looks like the cause.. no idea how to fix it though..

          28/07/2007 08:09:41 mcsTemperature Debug Log Temperature SQL Error Duplicate output destination 'sD7000000751CE526A'. on line 840 Duplicate output destination 'sD7000000751CE526A'.
          28/07/2007 08:09:41 mcsTemperature Debug Change Field because , error number=0, Fields=sD7000000751CE526V,2,sD7000000751CE526A,1,sD700000075 1CE526,4,sE900080017D3A910,4,sC3000000EBCC9628,4,sDB000000EC 614128,4,VD_TEMP,4,VD_TEMP2,4,VD_TEMP3,4,sD7000000751CE526A, 5
          28/07/2007 08:09:41 mcsTemperature Debug Log Temperature Retry SQL Error Duplicate output destination 'sD7000000751CE526A'. on line 900 Duplicate output destination 'sD7000000751CE526A'.
          Appreciate any help you can give !!

          Cheers

          Marc

          Comment


            #6
            You have a sensor sD7000000751CE526A (DS2438 voltage measurement) which appears to be setup twice as Analog input to mcsTemperature. The Temp08 does deliver multiple voltages, but I suspect you are intereseted in what the voltage means rather than what the voltage is (e.g. Humidity sensor).

            As a minimum rename the database field for one of these. For example sD7000000751CE526A2. It may be more appropriate to just remove both from the analog setup unless you really do have a need for raw voltage measurements.

            Comment


              #7
              Excellent, thankyou !!

              Very steep learning curve on this one

              Cheers

              Marc

              Comment

              Working...
              X