Announcement

Collapse
No announcement yet.

Bias has no effect for DS2438 temperature?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Bias has no effect for DS2438 temperature?

    I have temp/humidity sensors based on the DS2438, HIH-4000 and a DS1820. I can "calibrate" the DS1820 devices using the 'Bias' (offset) in mcsTemp, but this does not work for DS2438 temperature devices. Is this by design or am I missing something?
    Best regards,
    -Mark-

    If you're not out on the edge, you're taking up too much room!
    Interested in 3D maps? Check out my company site: Solid Terrain Modeling

    #2
    Michael, when you get a chance could you have a look at mcsTemp v5.12.1 and see if there's any reason why a bias entered for temperature has no effect on the reported temperature while bias offsets work fine for DS1820 parts? I have tried values from +/-.01 to +/-100 with no change.

    I have tested this in mcs1wire and any cal value entered for the same '38 devices works perfectly.
    Best regards,
    -Mark-

    If you're not out on the edge, you're taking up too much room!
    Interested in 3D maps? Check out my company site: Solid Terrain Modeling

    Comment


      #3
      Give 5.12.3 a try.

      Comment


        #4
        That's the ticket - DS2438 temperature bias is now functional!
        Thank you very much for your quick resolution Michael.
        Best regards,
        -Mark-

        If you're not out on the edge, you're taking up too much room!
        Interested in 3D maps? Check out my company site: Solid Terrain Modeling

        Comment

        Working...
        X